Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th December 2012, 22:08
bigmatlem bigmatlem is offline
Junior Member
 
Join Date: Sep 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default Got a new one here. Permissions and ownership askew

ISPConfig 3. When it created the directory for the new site it created it properly and gave it permissions for say web1 client1. However here is the strange part. When it gets done creating that and this just started out of the blue it won't allow anything to be written to the directory structure without changing the ownership to www-data:www-data.

What happened? It is running Ubuntu 12.04.1 LTS Server Edition 64bit. This started today. And nothing that I know of changed.

My guess is that somehow apache user group is messed up and isn't allowing what was work and ignores the ispconfig configurations.

GRRR! Ideas would be greatly appreciated.
Reply With Quote
Sponsored Links
  #2  
Old 30th December 2012, 23:26
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

You selected the wrong php mode or did not enable suexec.

1) Change the ownership back to web1;clienbt as itw as before.
2) Set the php mode to "php-fcgi" and enable the suexec checkbox in the website settings.

Btw, thats described in the manual.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 31st December 2012, 04:13
bigmatlem bigmatlem is offline
Junior Member
 
Join Date: Sep 2010
Posts: 12
Thanks: 0
Thanked 0 Times in 0 Posts
Default fcgi

Yeah its not a problem with executing cgi its a problem writing out to the directory. Its creating directories as www-data when the directory is owned by web1. It appears to be picking it up from apache rather than what it should be.

Are you saying that the fcgi will force apache to write as web1...? I did buy the manual by the way.
Reply With Quote
  #4  
Old 31st December 2012, 10:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

Quote:
Its creating directories as www-data when the directory is owned by web1. It appears to be picking it up from apache rather than what it should be.
Enable suexec, you will see that it works then.

Quote:
Are you saying that the fcgi will force apache to write as web1...?
Yes, thats the purpose of the suexec function. But ensure that you switched php mode to php-fcgi, do not use mod_php.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem with logs.php - script change ownership of user webs to root:root SupuS Installation/Configuration 5 6th March 2011 20:43
PureFTPd and Directory Permissions Tastiger HOWTO-Related Questions 3 15th February 2011 20:33
Joomla permissions in CentOS/ISPConfig 3 setup willko Tips/Tricks/Mods 3 17th November 2010 11:13
Changing default file upload permissions in PHP-CGI dabro Installation/Configuration 1 27th September 2008 09:53
Backup /home keeping permissions Jellus Installation/Configuration 0 17th August 2005 21:32


All times are GMT +2. The time now is 12:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.