Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th December 2012, 15:26
fatbear fatbear is offline
Member
 
Join Date: Jul 2010
Location: Raleigh, NC US
Posts: 41
Thanks: 4
Thanked 9 Times in 4 Posts
Default Not Cleaned Up after Client Deletion

After I deleted a website, I noted the following still remained:

/var/spool/mail/web11
/var/www/php-fcgi-scripts/web11

Note that in testing this issue, I only created a website and waited for it to come into existence, then deleted it, and then observed what was not cleaned up.

These should have been deleted during the website deletion, right?
__________________
Steve Amerige, Fat Bear Incorporated
Server Leasing | Web Software Development | User Experience & Graphic Design
Managed Services, Website, Java, and Source-Code Hosting
Did my post help you? Click the Thanks button!

Last edited by fatbear; 30th December 2012 at 16:03.
Reply With Quote
Sponsored Links
  #2  
Old 30th December 2012, 18:11
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
Default

The file in spool is not created by ispconfg, so ispconfig will not remove it. The directory /var/www/php-fcgi-scripts/web11 shall be deletecd by ispconfig. Have you tested this in 3.0.5, its most likely been fixed there already.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 30th December 2012, 19:09
fatbear fatbear is offline
Member
 
Join Date: Jul 2010
Location: Raleigh, NC US
Posts: 41
Thanks: 4
Thanked 9 Times in 4 Posts
Default

Hi Till,

Thanks for the reply. I haven't tested it in the non-stable 3.0.5 release. But, I'll take that as a push to my placing some domains that I keep around for testing purposes to put them on a server permanently for the purpose of testing ISPConfig svn code.

Do you happen to know what command that ISPConfig invokes that is responsible for creating the /var/spool/mail/<webid> directory? And, is there a hook in the code that I can use during website deletion to write some code that can take care of the cleanup?

As an aside, I really need to figure out how to start writing such code. Perhaps the learning curve to being an ISPConfig developer has discouraged me so far. Maybe you can point me at some resources that will help jump start me to writing such things.

Again, thanks for everything you do for all of us!

Almost... Happy New Year!
__________________
Steve Amerige, Fat Bear Incorporated
Server Leasing | Web Software Development | User Experience & Graphic Design
Managed Services, Website, Java, and Source-Code Hosting
Did my post help you? Click the Thanks button!
Reply With Quote
  #4  
Old 30th December 2012, 23:30
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,413
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
 
Default

Quote:
Do you happen to know what command that ISPConfig invokes that is responsible for creating the /var/spool/mail/<webid> directory? And, is there a hook in the code that I can use during website deletion to write some code that can take care of the cleanup?
Maybe the useradd command sends a welcome email on your system or similar. Take a look whats in the mail file.

Quote:
And, is there a hook in the code that I can use during website deletion to write some code that can take care of the cleanup?
ISPConfig backend is event based, so you can hook your code to the event "web_domain_delete" by creating a custom plugin.
Example:

$app->plugins->registerEvent('web_domain_delete',$this->plugin_name,'my_delete_function');
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
fatbear (30th December 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Doesnt update zones almere General 20 16th November 2012 14:49
link my domain to my server, impossible! 007007 Installation/Configuration 7 17th January 2012 13:59
DNS Lookups kieron General 4 4th May 2011 19:49
Being Spammed/Hacked/Probed not sure PLEASE HELP! kresser General 10 29th October 2010 17:25
Can't access to my website - after install problem pallermo Installation/Configuration 18 4th June 2010 13:29


All times are GMT +2. The time now is 12:46.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.