#1  
Old 31st August 2012, 15:24
ijujym ijujym is offline
Junior Member
 
Join Date: Aug 2012
Posts: 10
Thanks: 2
Thanked 1 Time in 1 Post
Default php-fpm configuration on nginx

Hi all,
Im tuning up the Centos vps with ispconfig and nginx for Drupal 7 site. Ispconfig is realy greate panel and all works fine. But there is one problem with configurations I cant fix myself, the site has an XML import plugin and it suppose to handle large 5-10mb documents. Currently there is such error on import:

Code:
[error] 11085#0: *389 upstream timed out (110: Connection timed out) while reading response header from upstream, client ... upstream: "fastcgi://127.0.0.1:9013"
After searching for solutions for this error I have already increased the max_execution_time but cant find how to increase max_client to check if it is the reason. Please help, what can be the reason this error?
Reply With Quote
Sponsored Links
  #2  
Old 1st September 2012, 08:53
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You might have to set something like

Code:
fastcgi_read_timeout 240;
To do this, copy your location ~ \.php$ {} section, place it inside the location / {} section and add the above line to the new location ~ \.php$ {} section.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
ijujym (6th September 2012)
  #3  
Old 12th December 2012, 12:52
abdi abdi is offline
Senior Member
 
Join Date: Sep 2012
Posts: 118
Thanks: 0
Thanked 10 Times in 6 Posts
Default

Hi Falko,

Is it possible to set that variable through API. Ie setting

Code:
fastcgi_read_timeout 240;
ALL through API
Reply With Quote
  #4  
Old 14th December 2012, 18:14
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
 
Default

You can use the nginx Directives field for this.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 Autoresponder, adding subdomain problem BlackHat Installation/Configuration 4 18th October 2011 14:24
ISPConfig3 Debian Squeeze Crontab - Log petrichbg Installation/Configuration 5 22nd March 2011 12:25
Multiserver setup: repquota command not found. CSsab Installation/Configuration 2 27th January 2011 15:11
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
network issues now it says "401 The web site is blocked by administrator" Check General 3 26th February 2008 14:22


All times are GMT +2. The time now is 04:23.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.