Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th December 2012, 14:10
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default ispconfig3 3.0.5 jobqueue processing problem

I noticed today whlie inserting new webdomain, DNS records that Job queue status is not updating and not getting cleared.

I have not faced this problem anytime before.

What could have caused this problem and how can rectify this?

I have rerun the update script, but still no joy.

Thanks.
Reply With Quote
Sponsored Links
  #2  
Old 13th December 2012, 08:47
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

following this thread - http://www.howtoforge.com/forums/sho...t=42597&page=2

I have executed the below commnad and the result is pasted here. But I still can't find the cause of the problem.

root@server1:/home/pawan# rm -f /usr/local/ispconfig/server/temp/.ispconfig_lockroot@server1:/home/pawan# /usr/bin/php -q /usr/local/ispconfig/server/server.php13.12.2012-07:42 - DEBUG - Set Lock: /usr/local/ispconfig/server/temp/.ispconfig_lock
13.12.2012-07:42 - DEBUG - Found 42 changes, starting update process.
13.12.2012-07:42 - DEBUG - Calling function 'ssl' from plugin 'apache2_plugin' raised by event 'web_domain_insert'.
13.12.2012-07:42 - DEBUG - Calling function 'insert' from plugin 'apache2_plugin' raised by event 'web_domain_insert'.
root@server1:/home/pawan#
Reply With Quote
  #3  
Old 14th December 2012, 09:29
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

Following this thread
http://www.howtoforge.com/forums/sho...ight=job+queue
Login to phpmyadmin as root, go to the dbispconfig database and there to the table "server". In this table there is a record for your server which has a column 'updated'. Increase the value of the updated field by 1 (updated = updated + 1) to skip the failed job.
I was able to clear the job queue.
Now I observe that job queue for deletion works find, but while inserting webdomain etc. it hangs, it creates folders in /var/www/clients/ but symlinks for webdomain in var/www and var/www/clients are not created and job queue constantly shows pending.

I also get this error occasionally in the cron file
Quote:
chattr: No such file or directory while trying to stat /var/www/clients/client70/web111
I am completely stuck and need help to overcome this problem.

Thanks.
Reply With Quote
  #4  
Old 14th December 2012, 09:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
Default

Please update to the latest ispconfig 3.0.5 revision and test if the problem still exists after skipping the hanging job. You get the code with this command:

svn export svn://svn.ispconfig.org/ispconfig3/branches/ispconfig-3.0.5
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pawan (14th December 2012)
  #5  
Old 14th December 2012, 10:37
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

Till,
Thank you so very much. updating from the SVN resolved the problem.

Thank you once again.
Reply With Quote
  #6  
Old 14th December 2012, 17:47
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 222
Thanks: 44
Thanked 6 Times in 6 Posts
Default

Till
Now I am facing a new problem.
I cannot access the DNS records in ISPCONFIG interface. When I click on records in DNS Zone I get an error

Quote:
ERROR

xfer_error_regex
Reply With Quote
  #7  
Old 14th December 2012, 17:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,422 Times in 4,264 Posts
 
Default

This has been fixed today, please update to todays svn
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
pawan (14th December 2012)
Reply

Bookmarks

Tags
jobqueue

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails: fine > recive: bad Moundy General 1 19th June 2012 23:40
Courier Imap is not working HellMind General 5 12th April 2012 01:04
table lookup problem aurelius Installation/Configuration 5 2nd November 2011 19:12
Login on ISPConfig3 problem Kyeto Installation/Configuration 13 24th May 2011 15:18
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20


All times are GMT +2. The time now is 19:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.