Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 5th December 2012, 15:59
thewebguy thewebguy is offline
Junior Member
 
Join Date: Dec 2012
Posts: 6
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix Email appearing as SPAM to GMail

Hi,

So I run my own hosting company and have done for some years. I recently decided to take the decision to ditch Plesk for various reasons and give ISPConfig 3 a try.

I successfully setup my own cluster of servers, 6 in total, Panel, DNS 1, DNS 2, Web, Mail, DB all running on Ubuntu 12.04 LTS.

Everything is working perfect except for my mail server which has a very peculiar problem. Everything is working fine with incoming and outgoing email except for outgoing email via Postfix to GMail accounts (I guess Hotmail and Yahoo could be similar but I am concentrating on GMail at the moment). This issue is happening with all domains, not just one inparticular.

rDNS and SPF are set correctly. I have run blacklist tests and the mail server IP is clean (there is only one IP). The hostname is set correctly too.

After running various tests, I have discovered the following.

1) If I setup the account as IMAP on a client such as Windows Live Mail with and without SSL turned on for outgoing mail, then any emails sent to a GMail account land in the GMail SPAM folder.

2) If I use SquirrelMail to send an email to GMail then again the email lands in the GMail SPAM folder.

HOWEVER;

3) If I setup the IMAP account on an iphone with SSL turned on then the email gets delivered to the GMail Inbox as you would expect it to.

1, 2 and 3 above are all being sent from the same IP address (then sent to the postfix mail server as any normal setup) via my broadband connection (the Iphone is connected to wireless) so that cannot be the reason seeing as scenario 3 delivers the email correctly.

All 6 servers are in a data centre and are not hosted within a local home network.

After comparing the headers of each of the emails with scenarios 1 (With SSL on) and scenarios 2 and 3 they are exactly identical apart from the section that explains the email was sent was from an Iphone for scenario 3 and from Windows Mail for scenario 1 and SquirrelMail for scenario 3.

Outgoing authentication is turned on for all scenarios as Postfix will not allowing relaying without authentication using the account username and password for the email account setup.

I believe I have checked and covered everything that I can except for something that may be wrong with the PostFix configuration in some way or something I have missed.

After reading many many forum posts both on this site and others I was starting to believe it was just GMail being picky as it does and having to wait over time for them to start allowing emails from the server to the Inbox rather than flagging as SPAM but when analyzing the headers the SPF passes, rDNS is set correctly and why did the Iphone mail (yes going through the same mail server as all scenarios) land in the Inbox?

As you can tell I am confused to say the least and would appreciate any help in solving this so I can put my new infrastructure into production.

Thank you in advance.
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
gmail, postfix, postfix outgoing spam

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix/courier/Centos 6 cant send email to external email servers maxtorzito Installation/Configuration 14 7th October 2011 10:56
Email being accepted but not delivered punto Installation/Configuration 8 25th May 2011 00:13
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
RoundCube Sends but will not receive. happz Installation/Configuration 33 17th April 2010 21:55
Ubuntu 8.04 Spamsnake - all SA scores 0.00 Thomas_Powers HOWTO-Related Questions 23 24th June 2008 17:37


All times are GMT +2. The time now is 04:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.