Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 5th December 2012, 08:27
electronico_nc electronico_nc is offline
Member
 
Join Date: Oct 2012
Posts: 42
Thanks: 9
Thanked 4 Times in 4 Posts
Default using ISPConfig as a local dev server

Hi all,

Well, I would like to use an ISPConfig installation as a local (LAN) web site dev server.

There is another server (running ISPConfig3) that is the real one with clients/websites all OK and running.

This local server would be a test server, to dev sites, test them and upload sites from this one to the real one once a site is OK.

LAN PCs (running Win7) are IP/DNS addressed from an ADSL router.

wan real server : domain.tld
wan test server : local.domain.tld
lan test server : 10.10.10.6

Real server has domains :
domain1.tld
domain2.tld
domain3.tld

I would like the test server to have this ones :
local.domain1.tld
local.domain2.tld
local.domein3.tld
Not especially accessibles from WAN, a LAN access would be enough.

I can edit the %systemroot%\system32\drivers\etc\hosts file on the develloper's PC to point to the ISPConfig3 test server, but I'm confused on how to setup the DNS zones on this test server.

Thanks in advance for your time.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
ISPConfig 3 Installation - Postfix queue stuck andrew971218 Installation/Configuration 21 15th July 2011 14:42
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Can't Ping over VPN RoMiONeT Server Operation 2 4th July 2010 00:19


All times are GMT +2. The time now is 23:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.