Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Closed Thread
 
Thread Tools Display Modes
  #1  
Old 4th December 2012, 07:15
wasanzy wasanzy is offline
Junior Member
 
Join Date: Mar 2010
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default Bind not resolving remote domains

Hi all,

I have two DNS server (primary and secondary) which uses bind9. The problem am having currently is that, my primary dns server is able to resolve both private and remote domains while the secondary server is able to resolve only the local domains but not able to resolve the remote domains.

Primary server test:

local domain:

$ host zorinco.com 192.168.2.30
Using domain server:
Name: 192.168.2.30
Address: 192.168.2.30#53
Aliases:

zorinco.com has address 64.81.168.12
zorinco.com mail is handled by 10 mail.zorinco.com.

remote domain test:

$ host yahoo.com 192.168.2.30
Using domain server:
Name: 192.168.2.30
Address: 192.168.2.30#53
Aliases:

yahoo.com has address 72.30.38.140
yahoo.com has address 98.138.253.109
yahoo.com has address 98.139.183.24
yahoo.com mail is handled by 1 mta6.am0.yahoodns.net.
yahoo.com mail is handled by 1 mta7.am0.yahoodns.net.
yahoo.com mail is handled by 1 mta5.am0.yahoodns.net.




Secondary server test

local domain test:

$ host zorinco.com 192.168.2.20
Using domain server:
Name: 192.168.2.20
Address: 192.168.2.20#53
Aliases:

zorinco.com has address 64.81.168.12
zorinco.com mail is handled by 10 mail.zorinco.com.


remote domain test:
$ host yahoo.com 192.168.2.20
Using domain server:
Name: 192.168.2.20
Address: 192.168.2.20#53
Aliases:




As you can see the "Aliases" section of the secondary server test for remote domain test, there is no answer.

Please what could be the possible cause? This means if my primary server failed, the secondary server can not act on it's behalf.


Thank you.
Sponsored Links
  #2  
Old 4th December 2012, 08:17
edge edge is offline
Moderator
 
Join Date: Dec 2005
Location: The Netherlands
Posts: 2,034
Thanks: 265
Thanked 151 Times in 131 Posts
 
Default

Please do not double post!
http://www.howtoforge.com/forums/showthread.php?t=59862
__________________
Never execute code written on a Friday or a Monday.
Closed Thread

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Bind9 Error Messages (and a problem with A records...) erosbk Server Operation 0 23rd May 2011 07:18
Unable to connect to Mysql mbascombe Installation/Configuration 12 10th January 2010 22:46
Exim Gateway with mailwatch (Unable to receive emails) siul0_0 HOWTO-Related Questions 10 8th May 2009 23:00
ISPConfig and BIND on Debian sarge (rfc1912 : failed on zonecheck) arnaud Installation/Configuration 13 6th March 2007 12:40
Bind-Chroot-Howto (Debian) spaz HOWTO-Related Questions 5 9th March 2006 14:50


All times are GMT +2. The time now is 19:35.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.