Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 3rd December 2012, 07:12
ikt ikt is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default Spamassassin settings

Hi,

If I wish to change a value of a score in spamassassin, where does one change this?

I have changed in /root/.spamassassin/user_prefs to no avail.

Many thanks
Reply With Quote
Sponsored Links
  #2  
Old 3rd December 2012, 09:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

You changed it in the spamassassin file of the root user, but root is not running spamassassin so this file is never read. Change it in /etc/spamassassin/local.cf instead.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
ikt (3rd December 2012)
  #3  
Old 3rd December 2012, 10:55
ikt ikt is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by till View Post
You changed it in the spamassassin file of the root user, but root is not running spamassassin so this file is never read. Change it in /etc/spamassassin/local.cf instead.
thanks
Reply With Quote
  #4  
Old 3rd December 2012, 17:58
ikt ikt is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Still not picking it up.

score RCVD_IN_BRBL_LASTEXT 5.0
score URIBL_PH_SURBL 5.0
score URIBL_BLACK 5.0
score URIBL_DBL_SPAM 3.0

is what I added to /etc/spamassassin/local.cf

and URIBL_PH_SURBL=0.61 is what came through on the test email.

Any ideas?
Reply With Quote
  #5  
Old 3rd December 2012, 18:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,499 Times in 4,328 Posts
Default

Did you restart amavisd after you changed the values?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 3rd December 2012, 18:27
ikt ikt is offline
Junior Member
 
Join Date: Feb 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Quote:
Originally Posted by till View Post
Did you restart amavisd after you changed the values?
Yup, then rebooted the whole server just to be sure.

edit:

amavisdebug
localcf

If these help.

edit edit: I mean I can see it picking up the rules correctly, so I don't understand where it's going wrong ... it's now working...

o_O

edit edit edit edit: ok the fix is you make a file called 90_myrules.cf in /etc/spamassassin with your scores in it, then reboot spamassassin and amavis.

Last edited by ikt; 3rd December 2012 at 18:54. Reason: removed my log files
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
[The Perfect Spamsnake Ubuntu 10.10] - No mail relay, just errors. itsnedkeren HOWTO-Related Questions 2 20th February 2011 10:45
Migration of spamassassin settings from an old to a new server voltron81 Installation/Configuration 8 17th February 2010 10:43
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
ISPconfig 2.2.21 Load Averange Very High mmiyamoto General 3 6th March 2008 13:13
Question on Clamscan and SpamAssassin AZMel Installation/Configuration 3 11th January 2007 19:56


All times are GMT +2. The time now is 19:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.