Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd December 2012, 15:53
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 263
Thanks: 32
Thanked 6 Times in 5 Posts
Default server wide cron job

I need to run some cron jobs on PHP scripts that should have server-wide access, what would be the best location to store them and how to set them up so that they don't have any permissions issues?
Reply With Quote
Sponsored Links
  #2  
Old 3rd December 2012, 10:45
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,745 Times in 2,578 Posts
Default

You can set them up as root by running
Code:
crontab -e
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 3rd December 2012, 11:10
manarak manarak is offline
Senior Member
 
Join Date: Apr 2009
Posts: 263
Thanks: 32
Thanked 6 Times in 5 Posts
 
Default

thank you Falko

I need to test the script first, is there a way to execute the PHP script from http with root privileges?

would something like that work if I add it to /etc/sudoers
Code:
web1 ALL=(ALL) NOPASSWD: /usr/bin/php -f /var/www/clients/client1/web/myscript.php
?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.3.3 fresh instalation - email tab is empty artur_gib Installation/Configuration 14 28th January 2014 20:02
Cron job runs on both master and mirror server, why? snowfly Installation/Configuration 7 15th May 2013 22:37
Statistic not working mzo Installation/Configuration 49 20th April 2011 13:19
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 13:47
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 18:02


All times are GMT +2. The time now is 10:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.