Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 26th November 2012, 02:49
bungeebones bungeebones is offline
Junior Member
 
Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default Network manager gone - eth renamed, can't load config

I thought I had successfully bonded two nic cards but then, started getting the message "Waiting for network configuration" and "waiting up to 60 more seconds for network configuration" and then it boots without network configuration.

I'm running edubuntu 12.04 with an LTSP network.

While struggling to get the nic cards bonded I saw some warnings to deactivate the Network Manager but it seemed to vanish on its own. The "two arrow icon" in the nav bar that starts the manager disappeared but everything still seemed to work. I had internet anyway, and was working on getting the clients to connect via dhcp. The last change I made was to etc/default/isc-dhcp-server where I changed the INTERFACES setting to "bond0" (and then the clients were able to boot into the LTSP server). At the next reboot, however, everything was broke again.

What the command line lshw revealed was that the one of the three nic cards that faces the internet (the onboard nic card) had been renamed from eth0 to eth3. Nothing I've tried in the etc/network/interfaces file or in the etc/udev/rules.d/70-persistent-net.rules file makes any difference. There is no "eth3" config in either of those files (only eth0, eth1, and eth2).

So, can anyone help with where the system is renaming eth0 to eth3?

But, back to NetworkManager, looking at etc/NetworkManger/Netwrokmanager.conf I remember changing [ifupdown] managed to "true" way, way back when I first installed the server but some frum post said that turned NetworkManager "off". So I am in a state of confusion about bthe whole NewtworkManager issue, whether it should be on or off when bonding nic cards etc and whether it is related to the current problem of renaming the eth names.

Thanks in advance for any help you can lend.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Tags
eth naming, network config, network manager, nic card bonding

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Unable to connect to Mysql mbascombe Installation/Configuration 12 10th January 2010 22:46
Spamsnake - Problem with spamassassin, FuzzyOcr and MySQL debuguser HOWTO-Related Questions 6 16th September 2008 18:37
ISPConfig 2.2.14 released till General 48 19th July 2007 23:46
spamassasin/clamAV not working Daisy Installation/Configuration 32 15th February 2007 00:09
Problem with the apache (I can't start ist) M.Behrens Installation/Configuration 11 31st March 2006 10:48


All times are GMT +2. The time now is 07:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.