Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 13th November 2012, 04:32
halsafar halsafar is offline
Junior Member
 
Join Date: May 2012
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default Jailed users cannot access /log

I am using ISPCONFIG 3.0.4.6.

I have many jailed users who have never been able to access their respective /log.

If I view the client directories /var/www/client1/web1/log as a regular user (not jailed) then the sym link /log -> /var/log/ispconfig/httpd/website/ works. If I log in as the jailed user it shows the sym link as dead, no file found.

The permissions for /var/log/ispconfig/httpd/website are web1:client1 755 for the directory.

Do I have to restart any services for a fix to take effect?

I'm at a loss, any help please and thanks.
Reply With Quote
Sponsored Links
  #2  
Old 13th November 2012, 04:58
halsafar halsafar is offline
Junior Member
 
Join Date: May 2012
Posts: 6
Thanks: 0
Thanked 1 Time in 1 Post
Default

I updated to dev build, svn update. Tools->Resync, problem solved.

So clearly a bug somewhere?
Reply With Quote
  #3  
Old 13th November 2012, 10:35
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Thats not a bug. The log directory was not acessible for ssh users in all versions prior ISPConfig 3.0.5 if jailkit is enabled as the log directory is outside of the jail. The setup has been changed in 3.0.5to use mount bind instead of a symlink so that the log directories are accessible now.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
lzgzytqo (17th November 2012)
  #4  
Old 16th November 2012, 17:32
itanium itanium is offline
Member
 
Join Date: Jul 2008
Location: france
Posts: 37
Thanks: 18
Thanked 3 Times in 3 Posts
Default

Hi Till,

I have found that if you change the domain name of a website, the "mount bind" in the fstab doesn't change. So if you reboot for example the server, he will stop at the mount startup process.

Do i need to add that to the bugtracker?
Reply With Quote
The Following User Says Thank You to itanium For This Useful Post:
ailesqcahvsa7752 (17th November 2012)
  #5  
Old 16th November 2012, 17:47
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 35,981
Thanks: 825
Thanked 5,371 Times in 4,218 Posts
Default

Yes, please add it to the bugtracker.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 16th November 2012, 17:55
itanium itanium is offline
Member
 
Join Date: Jul 2008
Location: france
Posts: 37
Thanks: 18
Thanked 3 Times in 3 Posts
 
Default

Task FS#2541 added
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with ISPConfig Mail and Squirrelmail m.xander Installation/Configuration 109 3rd February 2012 00:15
Jailed SSH users just exit. xrstokes Installation/Configuration 15 31st December 2011 03:51
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
Mail Users cannot login to Squirrelmail - access is denied vinayajmani Server Operation 1 7th February 2010 13:34
regarding proftpd and users with shell access Ovidiu Server Operation 2 5th December 2005 13:03


All times are GMT +2. The time now is 18:19.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.