Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > General

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 9th November 2012, 18:19
John Ford John Ford is offline
Member
 
Join Date: Jan 2010
Location: Kingston, Ontario, Canada
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Default Squirrelmail file attachment error

Using Ubuntu 11.04 perfect install and squirrelmail throws a
Code:
ERROR:
Could not move/copy file. File not attached
Everything else re: emails works fine.

Anyone had similar problems?

Thanks
Reply With Quote
The Following User Says Thank You to John Ford For This Useful Post:
lzgzytqo (16th November 2012)
Sponsored Links
  #2  
Old 9th November 2012, 20:44
concept21 concept21 is offline
Senior Member
 
Join Date: Dec 2011
Posts: 142
Thanks: 27
Thanked 17 Times in 13 Posts
Default

file size too big???
Reply With Quote
  #3  
Old 10th November 2012, 14:21
John Ford John Ford is offline
Member
 
Join Date: Jan 2010
Location: Kingston, Ontario, Canada
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Default

That was my first thought but the file size is only 20K.

I was thinking it has something to do with permissions. I tried chmod 777 on the attachment folder of squirrelmail but that didn't work either.

Reply With Quote
  #4  
Old 10th November 2012, 19:36
concept21 concept21 is offline
Senior Member
 
Join Date: Dec 2011
Posts: 142
Thanks: 27
Thanked 17 Times in 13 Posts
Default

I just tested on my Ubuntu 10.04 ispconfig 3.046, I could attached a 2 MB pdf file and sent it out correctly.

I suggest you check the squirrelmail log at /var/log/mail.log and see what happened.
Reply With Quote
The Following User Says Thank You to concept21 For This Useful Post:
John Ford (11th November 2012)
  #5  
Old 10th November 2012, 23:03
John Ford John Ford is offline
Member
 
Join Date: Jan 2010
Location: Kingston, Ontario, Canada
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Default

The mail.log doesn't say much except for connects and disconnects of pop3d
and imapd and postfix/smtpd lost connection from localhost
Reply With Quote
  #6  
Old 11th November 2012, 20:38
concept21 concept21 is offline
Senior Member
 
Join Date: Dec 2011
Posts: 142
Thanks: 27
Thanked 17 Times in 13 Posts
Default

that means you should check other log files like www, suphp, suexec etc if I were you.
Reply With Quote
The Following 2 Users Say Thank You to concept21 For This Useful Post:
John Ford (11th November 2012), lzgzytqo (16th November 2012)
  #7  
Old 11th November 2012, 22:52
John Ford John Ford is offline
Member
 
Join Date: Jan 2010
Location: Kingston, Ontario, Canada
Posts: 37
Thanks: 5
Thanked 2 Times in 2 Posts
Default [solved]

I found this in the apache2 error logs.

[Sun Nov 11 15:27:16 2012] [error] [client 192.168.1.101] PHP Warning: file_exists(): Fopen_basedir restriction in effect.File(/var/spool/squirrelmail/attach/kGbuxfcRnU3vd6VeCMuI1CzkqLzYJM2Q) is not within the allowed path(s): (/usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname) in /usr/share/squirrelmail/src/compose.php on line 1464, referer: http://192.168.1.105/webmail/src/com...startMessage=1

I found the solution here.
http://www.howtoforge.com/forums/arc...p/t-55043.html

and its fixed.

Last edited by John Ford; 11th November 2012 at 22:53. Reason: added info
Reply With Quote
The Following User Says Thank You to John Ford For This Useful Post:
falko (12th November 2012)
  #8  
Old 13th November 2012, 16:52
concept21 concept21 is offline
Senior Member
 
Join Date: Dec 2011
Posts: 142
Thanks: 27
Thanked 17 Times in 13 Posts
 
Default

Happy Ending
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Hacked server Captain Installation/Configuration 8 23rd December 2010 10:39
rkhunter report Captain Installation/Configuration 6 10th October 2010 13:05
I can't finish install due a problem Sam9999 Installation/Configuration 7 17th September 2010 22:33
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
Systemimager (rsync) doesn't copy all comedit HOWTO-Related Questions 11 19th January 2007 17:17


All times are GMT +2. The time now is 13:13.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.