Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 30th April 2012, 10:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

Quote:
Originally Posted by fco View Post
I have the same problem:
I'm using ISPCONFIG 3.0.4.4
With default configuration wordpress give Error 500.
I've tried various patch in site->options->nginx Directives textarea but I have not found a vali solution.
If I deactivate the site ttw and create a custom vhost file in /etc/nginx/sites-available and activate it, wordpress works

What is the correct code to past in site->options->nginx Directives for Wordpress ?

Thanks
Are there any errors in your logs? Can you post the vhost configuration that triggers the 500 error?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Sponsored Links
  #12  
Old 30th April 2012, 10:54
fco fco is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks hanti.
I try another way:
- copy the template in conf-custom dir:
Code:
cp /usr/local/ispconfig/server/conf/nginx_vhost.conf.master /usr/local/ispconfig/server/conf-custom/
- move these 3 lines (141-143):

Code:
<tmpl_loop name="nginx_directives">
        <tmpl_var name='nginx_directive'>
</tmpl_loop>
at line 19 (under "root <tmpl_var name='web_document_root_www'>;").

In this way I can override nginx rules from web interface. For wordpress in site->options->nginx Directives I write:

Code:
location / {
   try_files $uri $uri/ /index.php?$args;
}

location ~ \.php$ {
            try_files $uri =404;
            include /etc/nginx/fastcgi_params;
            fastcgi_pass 127.0.0.1:9014;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_script_name;
            #fastcgi_intercept_errors on;
}
Can it be ?
Reply With Quote
  #13  
Old 30th April 2012, 11:25
fco fco is offline
Junior Member
 
Join Date: Apr 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Are there any errors in your logs? Can you post the vhost configuration that triggers the 500 error?
Hi falko. I have not errors in log. I think because the error is captured by 500.html ?

my vhost configuration is the standard generated from ispconfig:

Code:
server {
        listen *:80;
        server_name mysite.it www.mysite.it;
        root   /var/www/mysite.it/web;

        index index.html index.htm index.php index.cgi index.pl index.xhtml;

        error_page 400 /error/400.html;
        error_page 401 /error/401.html;
        error_page 403 /error/403.html;
        error_page 404 /error/404.html;
        error_page 405 /error/405.html;
        error_page 500 /error/500.html;
        error_page 502 /error/502.html;
        error_page 503 /error/503.html;
        recursive_error_pages on;
        location = /error/400.html {
            internal;
        }
        location = /error/401.html {
            internal;
        }
        location = /error/403.html {
            internal;
        }
        location = /error/404.html {
            internal;
        }
        location = /error/405.html {
            internal;
        }
        location = /error/500.html {
            internal;
        }
        location = /error/502.html {
            internal;
        }
        location = /error/503.html {
            internal;
        }
        error_log /var/log/ispconfig/httpd/mysite.it/error.log;
        access_log /var/log/ispconfig/httpd/mysite.it/access.log combined;

        ## Disable .htaccess and other hidden files
        location ~ /\. {
            deny all;
            access_log off;
            log_not_found off;
        }
        location = /favicon.ico {
            log_not_found off;
            access_log off;
        }

        location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
        }
        location /stats {
            index index.html index.php;
            auth_basic "Members Only";
            auth_basic_user_file /var/www/clients/client2/web5/.htpasswd_stats;
        }

        location ^~ /awstats-icon {
            alias /usr/share/awstats/icon;
        }

        location ~ \.php$ {
            try_files $uri =404;
            include /etc/nginx/fastcgi_params;
            fastcgi_pass 127.0.0.1:9014;
            fastcgi_index index.php;
            fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
            fastcgi_param PATH_INFO $fastcgi_script_name;
            fastcgi_intercept_errors on;
        }
}
to bypass the problem hanti suggest me a solution disabling
fastcgi_intercept_errors on; (see my previuos posts)
but I'm not sure this is the optimal solution..

Thanks
Franco
Reply With Quote
  #14  
Old 1st May 2012, 10:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,741 Times in 2,575 Posts
Default

http://www.howtoforge.com/forums/sho...08&postcount=9
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 2nd May 2012, 16:20
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I had just overcome these 500 and 502 Errors.
See this post: http://www.howtoforge.com/forums/sho...531#post278531
Please check if youve no misspelling written your database entries in the wp-config.php

Good luck
Reply With Quote
  #16  
Old 9th November 2012, 12:17
untor untor is offline
Junior Member
 
Join Date: Nov 2012
Posts: 10
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

I bumped my head more than an hour on that intercept errors declaration, I am using the conf suggested by fco, even tough the conf files get a bit messy...

It would be cool if any directive declared for any website would replace default directives if found.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Problem Updating and Uploading to Wordpress website on ISPConfig3 - Fedora 13 MrCompTech Tips/Tricks/Mods 8 25th August 2014 14:18
nginx Segmentation fault Error,The Perfect Server - CentOS 6 With nginx [ISPConfig 3] alihan1988 HOWTO-Related Questions 0 2nd February 2012 17:07
Nginx doesnt restart after installation of ISPConfig 3 cyprus Installation/Configuration 2 6th November 2011 18:48
A Working Nginx Catchall with ISPConfig 3. renders Tips/Tricks/Mods 4 15th April 2011 21:53
ISPConfig 3.x - First Steps (Creating Web Sites, Email Addresses, Etc.) sighkick Suggest HOWTO 18 7th October 2010 00:12


All times are GMT +2. The time now is 00:07.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.