Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd November 2012, 21:15
egulik1 egulik1 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 9
Thanks: 0
Thanked 1 Time in 1 Post
Default [SOLVED] openSSO version 9.5.2 installation from response file

Hello, all

I've been trying to install openSSO v _9.5.2_RC1 using a response file with openDS(ldap) backend and have

a problem for which I can't seem to find a real answer, so any tip would be helpful. I'm running CentOS

release 6.3 in a virtualbox with 1,5 GB of RAM. I was able to install openDS and start it but I'm not sure

if its configured correctly. I'm attaching a script that I used for auto installation. (openDS-

autoinstall.txt)

If I ask lsof here is what I get:
Code:
$ lsof -i -n -P | grep 4444
java      6658    ldap   75u  IPv6  37916      0t0  TCP *:4444 (LISTEN) -- which is ok, right :)
If I ask ps about openDS here is what I get:
Code:
$ psg opends
 6658 pts/3    Sl     2:47 /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java -server -

Dorg.opends.server.scriptName=start-ds org.opends.server.core.DirectoryServer --configClass 

org.opends.server.extensions.ConfigFileHandler --configFile /u02/OpenDS-2.2.1/config/config.ldif
Here are couple of more information that might help:

]
Code:
$ showmemusage
 6764 /usr/sbin/httpd
 7208 /usr/sbin/httpd
 7372 /usr/sbin/httpd
 9856 /usr/sbin/httpd
12028 /usr/libexec/mysqld --basedir=/usr --datadir=/var/lib/mysql --user=mysql --log-

error=/var/log/mysqld.log --pid-file=/var/run/mysqld/mysqld.pid --socket=/var/lib/mysql/mysql.sock
12580 /usr/sbin/named-sdb -u named -t /var/named/chroot
36920 /usr/bin/ruby /usr/sbin/puppetmasterd
131508 /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java -server -Dorg.opends.server.scriptName=start-

ds org.opends.server.core.DirectoryServer --configClass org.opends.server.extensions.ConfigFileH
283748 /usr/lib/jvm/java-1.6.0-openjdk-1.6.0.0/jre/bin/java -

Djava.util.logging.config.file=/u02/tomcat/conf/logging.properties -server -Xms512m -Xmx512m -

XX:MaxPermSize=256m -Djvm=tomcat_virtualbox -D

$ free -m
             total       used       free     shared    buffers     cached
Mem:          1478       1277        201          0         73        634
-/+ buffers/cache:        568        910
Swap:         2015          0       2015

The problem is that if I try to use this command as tomcat user it will give only one error message:


Code:
[tomcat@cent01 work]$ java -jar ~/work/opensso/tools/configurator.jar -f 

/home/tomcat/work/test.testdomain.example.config
Configuration failed!
[tomcat@cent01 work]$
- which is very helpful ( I'm attaching this file as well. (test.testdomain.example.config.txt)

Here is the output from the tomcat log:


Code:
Nov 2, 2012 1:33:42 PM org.apache.catalina.core.StandardWrapperValve invoke
SEVERE: Servlet.service() for servlet [AMSetupServlet] in context with path [/opensso] threw exception 

[AMSetupFilter.doFilter] with root cause
com.sun.identity.setup.ConfiguratorException: Cannot connect to Directory Server.
        at com.sun.identity.setup.ServicesDefaultValues.setServiceConfigValues

(ServicesDefaultValues.java:141)
        at com.sun.identity.setup.AMSetupServlet.processRequest(AMSetupServlet.java:438)
        at com.sun.identity.setup.AMSetupServlet.doPost(AMSetupServlet.java:398)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:641)
        at javax.servlet.http.HttpServlet.service(HttpServlet.java:722)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter

(ApplicationFilterChain.java:305)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
        at com.sun.identity.setup.AMSetupFilter.doFilter(AMSetupFilter.java:99)
        at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter

(ApplicationFilterChain.java:243)
        at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:210)
        at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:225)
        at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:123)
        at org.apache.catalina.authenticator.AuthenticatorBase.invoke(AuthenticatorBase.java:472)
        at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:168)
        at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:98)
        at org.apache.catalina.valves.AccessLogValve.invoke(AccessLogValve.java:927)
        at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:118)
        at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:407)
        at org.apache.coyote.http11.AbstractHttp11Processor.process(AbstractHttp11Processor.java:1001)
        at org.apache.coyote.AbstractProtocol$AbstractConnectionHandler.process(AbstractProtocol.java:585)
        at org.apache.tomcat.util.net.JIoEndpoint$SocketProcessor.run(JIoEndpoint.java:310)
        at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1110)
        at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:603)
        at java.lang.Thread.run(Thread.java:679)

If I try to use status command then here is what I get:

Code:
[user1@cent01 openDS]$ sudo service opends status


>>>> Specify OpenDS LDAP connection parameters

Administrator user bind DN [cn=Directory Manager]:

Password for user 'cn=Directory Manager':
Unable to connect to the server at "host1.testdomain1.com" on port 4444

          --- Server Status ---
Server Run Status:        Started
Open Connections:         0

          --- Server Details ---
Host Name:                host1.testdomain1.com
Administrative Users:     cn=admin
Installation Path:        /u02/OpenDS-2.2.1
Version:                  OpenDS Directory Server 2.2.1
Java Version:             <not available> (*)
Administration Connector: Port 4444 (LDAPS)

          --- Connection Handlers ---
Address:Port : Protocol : State
-------------:----------:---------
--           : LDIF     : Disabled
0.0.0.0:161  : SNMP     : Disabled
0.0.0.0:636  : LDAPS    : Disabled
0.0.0.0:1389 : LDAP     : Enabled
0.0.0.0:1689 : JMX      : Disabled

          --- Data Sources ---
Base DN:     dc=testdomain,dc=com
Backend ID:  userRoot
Entries:     <not available> (*)
Replication: Disabled

* Information only available if you provide valid authentication information
when launching the status command.
The best thing is that if I go through web wizard and follow that web-wizard it will work without any

problems but I don't want to do it in that way. I would like to have automated with a script from a

command line

Thanks for any kind of tip or direction !!!
Attached Files
File Type: txt openDS-autoinstall.txt (4.9 KB, 70 views)
File Type: txt test.testdomain.example.config.txt (1.0 KB, 48 views)
Reply With Quote
Sponsored Links
  #2  
Old 5th November 2012, 18:19
egulik1 egulik1 is offline
Junior Member
 
Join Date: Aug 2012
Posts: 9
Thanks: 0
Thanked 1 Time in 1 Post
 
Default

Hello all,

I figured it out and just wanted to share this with everyone who may experience the same thing.
If you get error like this:

Code:
[tomcat@cent01 work]$ java -jar ~/work/opensso/tools/configurator.jar -f /home/tomcat/work/test.testdomain.example.config
Configuration failed!
and nothing else in the screen then I advise you to check your 'input' file as in my case is: /home/tomcat/work/test.testdomain.example.config. The issue in my case was that for some reason configurator thinks that line that starts with '#' sign means something and doesn't know what to do with it, so for every comment that you placing in this file you have do it like this:

Code:
...
# Configuration data store configuration
DATA_STORE=dirServer
DIRECTORY_SSL=SIMPLE
# DIRECTORY_SERVER=localhost
DIRECTORY_SERVER=192.168.55.1
...
Here is the way I had it before:

Code:
...
# Configuration data store configuration
DATA_STORE=dirServer
DIRECTORY_SSL=SIMPLE
#DIRECTORY_SERVER=localhost
DIRECTORY_SERVER=192.168.55.1
...
Good luck.
Administrator - please mark this thread as solved.
Thank you
Reply With Quote
The Following User Says Thank You to egulik1 For This Useful Post:
falko (6th November 2012)
Reply

Bookmarks

Tags
opends, opensso

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Combination of postfix and courier failing Xaymar Server Operation 3 7th March 2012 17:28
Being Spammed/Hacked/Probed not sure PLEASE HELP! kresser General 10 29th October 2010 17:25
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Forbidden 403; Samba access; config of maildeamon fawkes Installation/Configuration 4 14th January 2010 18:16
Squid Proxy Caching on Linux obzerver Installation/Configuration 4 13th August 2008 19:51


All times are GMT +2. The time now is 04:30.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.