Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th October 2012, 16:29
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Smile ownCloud ISPConfig 3 (.htaccess)

G'day guys,

I have Debian 6 (Squeeze) VPS with ISPConfig 3 installed. I'm looking at hosting some audio files for my Church seeing that I have 160GB of transfer per month and the files are about 150MB each (about 1.5 hours long).

Anyway I tried Subsonic (way too many options and clickable hiccups for old people or low IT literate people) tried a few other options aswell until I found ownCloud which looks sleek, clean and easy to use/administer.

My issues are these:

Firstly on a test virtual server (Debian) I can get it to work great, but it complains about .htaccess - which I can remedy but then I need to change the whole Apache config to
Code:
AllowOverride All
in
Quote:
/etc/apache2/sites-available/default
however is this the recommended way? security issues? administrator concerns?

Secondly on my test virtual server (Debian 6 and ISPConfig 3 = 192.168.1.201) I make a fake site (example.com) and set the DNS to point to this server then on another test virtual machine (WinXP = 192.168.1.205) I set my DNS Servers in the network config to point to 192.168.1.201 and type in the fake site = example.com and all things work.

Now I follow the same install procedure but instead of placing it in
Quote:
/var/www/owncloud
i place it in
Quote:
/var/www/example.com/web/owncloud
and run
Code:
chown -R web1:client0 owncloud
But it doesn't show up when I navigate to What am I missing? On my actual VPS I didn't ever make another .conf file for phpBB3 (Forum) or for my Wordpress (Blog) I just placed the folder via FTP and it worked.

I did check out the log for client0 and it showed this:

Quote:
[Tue Oct 30 23:00:09 2012] [emerg] [client 192.168.1.205] (13)Permission denied: mod_fcgid: can't lock process table in pid 6392
Any help would be appreciated. I don't mind to make a tutorial up if things work but word of warning I am a noob

Cheers guys,
Regards,
Steven Swarts
Reply With Quote
Sponsored Links
  #2  
Old 30th October 2012, 16:47
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Ok so I changed the setting of the website (example.com) in the test virtual server (Debian ISPConfig 3) to ModPHP and it works as expected.

However my currently running website http://www.swartsit.com is running under Fast-CGI

NOOB ALERT: I don't know the differences at all

But I use these "addons" to my client0:

phpBB3 = Forum
WordPress = Blog

So is this the right direction or am I completely mistaken?

Cheers,
Steven Swarts
Reply With Quote
  #3  
Old 30th October 2012, 16:50
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

fast-cgi is the correct php mode.Please ensure that the suexec checkbox is enabled in the website settings as well.

Please post the output of this command:

ls -la /var/www/example.com/web/
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 30th October 2012, 17:00
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
fast-cgi is the correct php mode.Please ensure that the suexec checkbox is enabled in the website settings as well.

Please post the output of this command:

ls -la /var/www/example.com/web/
Thanks Till, I thought as much found this: http://www.howtoforge.com/forums/arc...p/t-33167.html

suexec is enabled as well

Code:
drwx--x---  5 web1 client0 4096 Oct 30 23:32 .
drwxr-x--x  6 web1 client0 4096 Oct 30 22:47 ..
drwxr-xr-x  2 web1 client0 4096 Oct 30 22:47 error
-rwxr-xr--  1 web1 client0 7358 Oct 30 22:47 favicon.ico
-rwxr-xr--  1 web1 client0   26 Oct 30 22:47 .htaccess
-rw-r--r--  1 web1 client0   86 Oct 30 23:32 index.html
-rwxr-xr--  1 web1 client0 1861 Oct 30 22:47 index.html.bak
drwxr-xr-x 14 web1 client0 4096 Oct 30 23:43 owncloud
-rwxr-xr--  1 web1 client0   24 Oct 30 22:47 robots.txt
-rw-r--r--  1 web1 client0 6957 Oct 10 23:06 setup-owncloud.php
drwxr-xr-x  2 web1 client0 4096 Oct 30 22:47 stats

Last edited by sjswarts; 30th October 2012 at 17:04. Reason: Didn't answer everything
Reply With Quote
  #5  
Old 30th October 2012, 17:17
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Thats ok, please run this command and try to access the ownloud site again:

chown -R web1:client0 /var/www/php-fcgi-scripts/web1

Additionally, the owncloud setup script seems to be in the web directorym not the owncloud directory. What happens if you access this url:

http://example.com/setup-owncloud.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 30th October 2012, 17:27
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
Thats ok, please run this command and try to access the ownloud site again:

chown -R web1:client0 /var/www/php-fcgi-scripts/web1
Nothing changed...

Quote:
Originally Posted by till View Post
Additionally, the owncloud setup script seems to be in the web directorym not the owncloud directory. What happens if you access this url:

http://example.com/setup-owncloud.php
Yeah according to the ownCloud website there are two options to install either by this php script or by downloading the code and manually installing.

In ISPConfig under Sites I have the following:

CGI = Checked
SSI = unChecked
Ruby = unChecked
Python = unChecked
SuEXEC = Checked
Own Error-Documents = Checked
Auto-Subdomain = www.
SSL = unChecked
PHP = Fast-CGI
Active = Checked

Unfortunately neither work. But if I change to ModPHP it does.
Very strange and the logs just mention the same as I posted above.

Last edited by sjswarts; 30th October 2012 at 17:31. Reason: Missed some info
Reply With Quote
  #7  
Old 30th October 2012, 18:11
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

For some reason I decided to try it on my actual live VPS and changed the DNS of the Virtual Machine (Win XP) to point there. Setup DNS on my VPS as well and it works fine. Settings are identical I am running Fast-CGI with suexec and everything.

So strange, this test ISPConfig is more or less brand new. Something must be broken.

.htaccess is however not working still

I believe the server settings are at

Code:
AllowOveride None
Any ideas?

Cheers,
Steven Swarts
Reply With Quote
  #8  
Old 30th October 2012, 18:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The htaccess settings in ispconfig are "AllowOverride All" for all .htaccess files inside a website, so you can use any config options that are allowed for .htaccess files inside the /web/ directory of the site. All settings are defined by site, so the global override settings do not matter as they dont get applied to files in a website. Owncloud shall work out of the box, I've testet it some time ago and did not had to do any modications on a server installed as described in the perfect setup guide.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #9  
Old 31st October 2012, 06:13
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Default

Quote:
Originally Posted by till View Post
The htaccess settings in ispconfig are "AllowOverride All" for all .htaccess files inside a website, so you can use any config options that are allowed for .htaccess files inside the /web/ directory of the site. All settings are defined by site, so the global override settings do not matter as they dont get applied to files in a website. Owncloud shall work out of the box, I've testet it some time ago and did not had to do any modications on a server installed as described in the perfect setup guide.
Well I found that it installed fine via the script (assuming it would also by the download and extract method).

As for the .htaccess it doesn't take preference over the server. I set the settings in ownCloud and it DOES take effect (shown in /var/www/client/web/owncloud/.htaccess) but still uses server preferences listed in

Code:
/etc/php5/cgi/php.ini
which are for upload limits ...
Personally that works for me, but I could see that hosting providers would want to limit the upload to 5-25Mb. But in this case I wanted to have at least 150Mb upload.
Reply With Quote
  #10  
Old 31st October 2012, 08:38
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

Quote:
As for the .htaccess it doesn't take preference over the server. I set the settings in ownCloud and it DOES take effect (shown in /var/www/client/web/owncloud/.htaccess) but still uses server preferences listed in
You mix up a few things here, the .htaccess works fine and overrides the settings in the global apache configuration on your server. A .htaccess file is a config file of the apache server and not a config file of the php binary, the php settings that you refer to like php_value or php_flag are settings for the apache module mod_php and not for the php-fcgi program. You can set values for php-fcgi in the php.ini field of the website, so its even easier then editing a .htaccess file manually, the syntax is the same that you find in the php.ini.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
sjswarts (31st October 2012)
Reply

Bookmarks

Tags
.htaccess, apache, debian, ispconfig 3, owncloud

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 20:03
around 80 sleeping connections created by ISPConfig bkilinc General 2 1st October 2012 16:12
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Ignored phpvalues at .htaccess, ISPconfig or PHP mbria Installation/Configuration 9 16th December 2009 13:39
ISPConfig .htaccess problems. Code5 General 3 23rd July 2008 08:21


All times are GMT +2. The time now is 22:05.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.