Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 30th October 2012, 17:29
sjswarts sjswarts is offline
Senior Member
 
Join Date: May 2011
Location: Australia
Posts: 135
Thanks: 17
Thanked 5 Times in 5 Posts
Smile ownCloud ISPConfig 3 (.htaccess)

G'day guys,

I have Debian 6 (Squeeze) VPS with ISPConfig 3 installed. I'm looking at hosting some audio files for my Church seeing that I have 160GB of transfer per month and the files are about 150MB each (about 1.5 hours long).

Anyway I tried Subsonic (way too many options and clickable hiccups for old people or low IT literate people) tried a few other options aswell until I found ownCloud which looks sleek, clean and easy to use/administer.

My issues are these:

Firstly on a test virtual server (Debian) I can get it to work great, but it complains about .htaccess - which I can remedy but then I need to change the whole Apache config to
Code:
AllowOverride All
in
Quote:
/etc/apache2/sites-available/default
however is this the recommended way? security issues? administrator concerns?

Secondly on my test virtual server (Debian 6 and ISPConfig 3 = 192.168.1.201) I make a fake site (example.com) and set the DNS to point to this server then on another test virtual machine (WinXP = 192.168.1.205) I set my DNS Servers in the network config to point to 192.168.1.201 and type in the fake site = example.com and all things work.

Now I follow the same install procedure but instead of placing it in
Quote:
/var/www/owncloud
i place it in
Quote:
/var/www/example.com/web/owncloud
and run
Code:
chown -R web1:client0 owncloud
But it doesn't show up when I navigate to What am I missing? On my actual VPS I didn't ever make another .conf file for phpBB3 (Forum) or for my Wordpress (Blog) I just placed the folder via FTP and it worked.

I did check out the log for client0 and it showed this:

Quote:
[Tue Oct 30 23:00:09 2012] [emerg] [client 192.168.1.205] (13)Permission denied: mod_fcgid: can't lock process table in pid 6392
Any help would be appreciated. I don't mind to make a tutorial up if things work but word of warning I am a noob

Cheers guys,
Regards,
Steven Swarts
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
.htaccess, apache, debian, ispconfig 3, owncloud

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 - MultiServer Setup - With Dedicated Control Panel - How? SuperJC Installation/Configuration 4 16th October 2012 21:03
around 80 sleeping connections created by ISPConfig bkilinc General 2 1st October 2012 17:12
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 21:01
Ignored phpvalues at .htaccess, ISPconfig or PHP mbria Installation/Configuration 9 16th December 2009 14:39
ISPConfig .htaccess problems. Code5 General 3 23rd July 2008 09:21


All times are GMT +2. The time now is 15:28.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.