Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #31  
Old 22nd February 2010, 16:19
matt082606 matt082606 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default ISPConfig 2.2.35 .htaccess issue.

I spent the weekend reloading a webserver to try out ISPConfig. Everything was working before, I just wanted to make adding additional sites easier.

I am having the .htaccess issue however. All the sites I design I use redirect 404 to index, and NEED this to be the case.

This was easy to complete before as I added new vhosts.

Here is what I have tried to get this to work.
I added AllowOveride All to /etc/proftpd/proftpd.conf EDIT: Sorry this should read /etc/apache2/apache2.conf

I added them to ISP vhosts individually.

I added them from the ISP control panel to each site, I verified this went to the ISP Vhosts file as well.

I am running Ubuntu Server 9.10, installed using the steps here for perfect server and ISPConfig 2.2.35

I am thinking the next step is to manually point the default in ispconf Vhosts file from /error/fileNotFound.html to index.php hopefully that will get it working, and I will do that for each site needed. Edit2: This didn't work either. I put in the full path to the index file.

If anyone has found a way to get this working globally please explain it here as reading through this thread it keeps jumping from one users problem to the next without any solutions being posted. If I fix this on my own, or am given a solution that works I will make sure and acknowledge what worked so that future people finding this thread will have a working answer to the question.

Last edited by matt082606; 22nd February 2010 at 16:35. Reason: Update
Reply With Quote
Sponsored Links
  #32  
Old 23rd February 2010, 16:02
matt082606 matt082606 is offline
Junior Member
 
Join Date: Feb 2010
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default WOW I am a moron.

After many hours of searching for the problem I realized that my htaccess was pointing to index.html not index.php.

I fixed it and it is working on all sites. unfortunately all sites utilized a different solution above...

I will post the results of what works globally, and what works per site, as I clean up my mess.

Sorry
Reply With Quote
  #33  
Old 10th October 2010, 05:40
collimic collimic is offline
Member
 
Join Date: Dec 2008
Posts: 43
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
Ok, then the problem was in
Code:
<IfModule mod_python.c>
<Directory /var/www/web7/web>
Options +Indexes +FollowSymLinks +MultiViews
AllowOverride Indexes AuthConfig Limit FileInfo
Order allow,deny
allow from all
AddHandler mod_python .py
PythonHandler mod_python.publisher
PythonDebug On
</Directory>
</IfModule>
I should probably change
Code:
AllowOverride Indexes AuthConfig Limit FileInfo
to
Code:
AllowOverride all
I've added this to our bugtracker.
falko,
I just updated my ispconfig from 2.2.29 to 2.2.37 Everyhitng was working great. Now the .htaccess files are not working if I have python enabled. Can you tell me what file I need to access so it will change it to AllowOverride All?

Thank you.
Reply With Quote
  #34  
Old 10th October 2010, 17:14
collimic collimic is offline
Member
 
Join Date: Dec 2008
Posts: 43
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Well I feel bad about the last comment. I did not upgrade I just re installed the same version. But it would be great to know what to modify as I cannot get the upgrade to work just yet.
Reply With Quote
  #35  
Old 11th October 2010, 10:13
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by collimic View Post
as I cannot get the upgrade to work just yet.
What do you mean with that?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #36  
Old 11th October 2010, 19:40
collimic collimic is offline
Member
 
Join Date: Dec 2008
Posts: 43
Thanks: 7
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post
What do you mean with that?
It would be a topic for a new thread but I am running Ubuntu 8.10 and I cannot seam to get libarchive-tar-perl to install. I have installed perl-modules and it is working fine but it is not installing libarchive-tar-perl.

Any help would be great or I could start a new thread.

Thank for your help.
Reply With Quote
  #37  
Old 12th October 2010, 15:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,744 Times in 2,577 Posts
Default

Quote:
Originally Posted by collimic View Post
but it is not installing libarchive-tar-perl.
Why? Do you get any error messages?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #38  
Old 29th October 2012, 16:31
abdi abdi is offline
Senior Member
 
Join Date: Sep 2012
Posts: 118
Thanks: 0
Thanked 10 Times in 6 Posts
Default

Quote:
Originally Posted by falko View Post
Put something like

Code:
<Directory "/var/www/web#/web">
AllowOverride All
</Directory>
in the Apache Directives field of that web site in the ISPConfig interface.
Till in a case senario like mine where I am running Nginx as a webserver, how do I enable .htaccess for independent sites or globally?
Reply With Quote
  #39  
Old 29th October 2012, 16:59
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,419
Thanks: 834
Thanked 5,498 Times in 4,328 Posts
 
Default

.haccess is a apache technology, there is no such function in nginx.

As a sidenote, this thread is about ispconfig 2. ISPConfig 2 and ispconfig 3 are two completly different server controlpanel, so nothing that you read here in this thread applies to the ispconfig 3 version you use.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.

Last edited by till; 29th October 2012 at 17:01.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Upload ins't working good in ispconfig on ubuntu 6.06 djmostek Installation/Configuration 11 24th August 2007 22:14
vhost not working on ISPConfig 2.2.13 tannnk Installation/Configuration 2 22nd June 2007 14:31
fastcgi and php with ispconfig tosser Tips/Tricks/Mods 3 25th June 2006 21:01
FC4 Setup DNS and ISPCONFIG issues The General Installation/Configuration 7 15th May 2006 09:45
ISPconfig not working Venkatesh.S Installation/Configuration 2 28th July 2005 13:28


All times are GMT +2. The time now is 18:27.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.