#1  
Old 29th October 2012, 10:31
fbessone fbessone is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default Lost permissions after upgrade

Hello,

i upgraded to last ispconfig version and since that a normal users instead of seeing only his websites can see all, how can i reset permissions so that each client sees only belonged websites ?

Additionally, i can no longer access ispconfig interface/phpmyadmin through https but only http.

Does anybody has an idea about it?

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 29th October 2012, 10:40
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,060
Thanks: 826
Thanked 5,395 Times in 4,239 Posts
Default

Take a look at the affected user under System > CP users and ensure that the user type is "user" and not "admin".
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 29th October 2012, 11:13
fbessone fbessone is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default Thank you !

Thanks Till,
it was indeed changed to ADMIN. Reverted to user and now he sees only his websites.


For :8080 ispconfig panel, if i try to open it with https it reports back
Error 107 (net::ERR_SSL_PROTOCOL_ERROR): SSL protocol error

How can i fix it ?
Thanks again
Reply With Quote
  #4  
Old 29th October 2012, 11:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,060
Thanks: 826
Thanked 5,395 Times in 4,239 Posts
Default

The panel is only available as http or https but not http and https at the same time. So if it opens fine with http, then ssl has not been enabled for the panel during installation or update.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 29th October 2012, 11:58
fbessone fbessone is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default Ok

Ok, i understand. Maybe i havent selected the right option during upgrade.
Is there any chance to re-run the upgrade or to enable ssl and disable http ?
Reply With Quote
  #6  
Old 29th October 2012, 12:16
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,060
Thanks: 826
Thanked 5,395 Times in 4,239 Posts
 
Default

Download the ispconfig tar.gz, unpack it and run the update.php script which is in the install folder. During update, choose to recreate the sl cert as it does not seem to exist on your server or it was stored in the wrong location so that the updater could not find it.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 cant receive emails lishaw1968 Installation/Configuration 25 19th August 2013 10:37
can't send/receive mail fedora 12 - ispconfig 3 ev0css Installation/Configuration 9 17th May 2010 21:44
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 19:59
Lost connection to session during apt-get upgrade Thomas Jensen Installation/Configuration 14 30th November 2009 09:14
Upgrade... lost the database NuttyGambler Installation/Configuration 17 11th June 2007 16:35


All times are GMT +2. The time now is 16:21.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.