Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 15th October 2012, 23:43
blinden blinden is offline
Member
 
Join Date: Sep 2010
Posts: 41
Thanks: 3
Thanked 3 Times in 3 Posts
Default Email Forward Accounts "User unknown in virtual mailbox table."

When I create email forwards, it doesn't seem to pass a test, and refuses to let the remote server send the email into the server. I checked the DB, and the accounts are listed in the 'Mail_forwarding' table.

sending from a remote account using thunderbird, I get the message:

An error occurred while sending mail. The mail server responded: 5.1.1 <account@domain>: Recipient address rejected: User unknown in virtual mailbox table. Please check the message recipient account@domain and try again.

I've tried searching a bit, and haven't found any luck finding information on this specific situation.

Ubuntu 12.04
ISPConfig 3.0.4.6 Mulitserver Setup
Reply With Quote
Sponsored Links
  #2  
Old 17th October 2012, 19:06
blinden blinden is offline
Member
 
Join Date: Sep 2010
Posts: 41
Thanks: 3
Thanked 3 Times in 3 Posts
Default

So, I guess this comes down to the fact that when the email attempts to send to the server, it is looking at the mailbox table and not seeing the accounts.

Is there something missed or messed up that would make the server reference the mail_forwarding table additionally to verify the accounts. I've not had any luck finding much info because everything I search for returns a bunch of results about real email addresses not working, but not a lot of info for cases where it's only the forwards that aren't working.
Reply With Quote
  #3  
Old 18th October 2012, 08:37
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

What is the hostname of the server, is it "domain"?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #4  
Old 18th October 2012, 15:11
blinden blinden is offline
Member
 
Join Date: Sep 2010
Posts: 41
Thanks: 3
Thanked 3 Times in 3 Posts
Default

No, the hostname is mail.maindomain.com it's a different domain altogether.
Reply With Quote
  #5  
Old 18th October 2012, 17:14
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
Default

Please do a manual ispconfig update:

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php
and choose to reconfigure services during update so that the postfix configuration gets rewritten to ensure that it is correct.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 18th October 2012, 17:56
blinden blinden is offline
Member
 
Join Date: Sep 2010
Posts: 41
Thanks: 3
Thanked 3 Times in 3 Posts
Default

Completed that, no change.
Reply With Quote
  #7  
Old 25th October 2012, 01:08
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Question

I have this problem also. I've used ISPConfig for sometime and never had this problem with forwards. I have a forward setup, it is just a forward. When I send a test email from my gmail account I get this:

Code:
This is the mail system at host abda.clientdomain2.info.

I'm sorry to have to inform you that your message could not
be delivered to one or more recipients. It's attached below.

For further assistance, please send mail to postmaster.

If you do so, please include this problem report. You can
delete your own text from the attached returned message.

                   The mail system

<support@clientdomain1.com>: user unknown
This forward is set like so: support@clientdomain1.com forwards to support@completelydifferentdomain.com

Here is some config properties:

postconf -n
Code:
root@abda:/home/sysadmin# postconf -n
alias_database = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
alias_maps = hash:/etc/aliases, hash:/var/lib/mailman/data/aliases
append_dot_mydomain = no
biff = no
body_checks = regexp:/etc/postfix/body_checks
broken_sasl_auth_clients = yes
config_directory = /etc/postfix
dovecot_destination_recipient_limit = 1
header_checks = regexp:/etc/postfix/header_checks
html_directory = /usr/share/doc/postfix/html
mailbox_size_limit = 0
maildrop_destination_concurrency_limit = 1
maildrop_destination_recipient_limit = 1
message_size_limit = 0
mime_header_checks = regexp:/etc/postfix/mime_header_checks
mydestination = adba.nextcode.info, localhost, localhost.localdomain
myhostname = abda.nextcode.info
mynetworks = 127.0.0.0/8 [::1]/128
myorigin = /etc/mailname
nested_header_checks = regexp:/etc/postfix/nested_header_checks
owner_request_special = no
proxy_read_maps = $local_recipient_maps $mydestination $virtual_alias_maps $virtual_alias_domains $virtual_mailbox_maps $virtual_mailbox_domains $relay_recipient_maps $relay_domains $canonical_maps $sender_canonical_maps $recipient_canonical_maps $relocated_maps $transport_maps $mynetworks $virtual_mailbox_limit_maps
readme_directory = /usr/share/doc/postfix
receive_override_options = no_address_mappings
recipient_delimiter = +
relay_domains = mysql:/etc/postfix/mysql-virtual_relaydomains.cf
relay_recipient_maps = mysql:/etc/postfix/mysql-virtual_relayrecipientmaps.cf
relayhost = marintechit.com.outbound15.mxlogic.net
smtp_sasl_auth_enable = no
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtpd_banner = $myhostname ESMTP $mail_name (Ubuntu)
smtpd_client_message_rate_limit = 100
smtpd_client_restrictions = check_client_access mysql:/etc/postfix/mysql-virtual_client.cf
smtpd_recipient_restrictions = permit_mynetworks, permit_sasl_authenticated, check_recipient_access mysql:/etc/postfix/mysql-virtual_recipient.cf, reject_unauth_destination
smtpd_sasl_auth_enable = yes
smtpd_sasl_authenticated_header = yes
smtpd_sasl_path = private/auth
smtpd_sasl_type = dovecot
smtpd_sender_restrictions = check_sender_access mysql:/etc/postfix/mysql-virtual_sender.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_tls_security_level = may
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtpd_use_tls = yes
transport_maps = proxy:mysql:/etc/postfix/mysql-virtual_transports.cf
virtual_alias_domains =
virtual_alias_maps = proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf, proxy:mysql:/etc/postfix/mysql-virtual_email2email.cf, hash:/var/lib/mailman/data/virtual-mailman
virtual_gid_maps = static:5000
virtual_mailbox_base = /var/vmail
virtual_mailbox_domains = proxy:mysql:/etc/postfix/mysql-virtual_domains.cf
virtual_mailbox_maps = proxy:mysql:/etc/postfix/mysql-virtual_mailboxes.cf
virtual_transport = dovecot
virtual_uid_maps = static:5000
Postmap query:
Code:
root@abda:/home/sysadmin# postmap -q support@marintechit.com proxy:mysql:/etc/postfix/mysql-virtual_forwardings.cf
support@marintech.zendesk.com
root@abda:/home/sysadmin#
I'm running the latest stable version of ISPConfig and using the latest Perfect Server 3
Reply With Quote
  #8  
Old 25th October 2012, 01:21
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

Also, I get the same exact problem with the one alias account I have. And it is set as this: billing@codomain.com goes to user@codomain.com
Reply With Quote
  #9  
Old 25th October 2012, 02:29
pebkac pebkac is offline
Senior Member
 
Join Date: Feb 2009
Posts: 132
Thanks: 2
Thanked 7 Times in 7 Posts
Default

I fixed my issue by commenting out this line in main.cf

receive_override_options = no_address_mappings

Thanks!
Reply With Quote
  #10  
Old 25th October 2012, 07:34
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,977
Thanks: 825
Thanked 5,369 Times in 4,216 Posts
 
Default

Just a guess, did sou disable amavisd on your srver?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Questions about v2.2.32, email accounts and others electronico_nc Installation/Configuration 2 3rd October 2012 21:24
hotmail rejects outgoing email nzimas Server Operation 3 1st May 2009 03:39
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
Howto suggestion suse PhP ver 4 + Ver 5 wwparrish Suggest HOWTO 11 7th August 2006 13:29
configuring IPTABLES firewall adityavpratap HOWTO-Related Questions 9 27th May 2006 21:42


All times are GMT +2. The time now is 22:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.