Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 24th October 2012, 09:03
vaio1 vaio1 is offline
Senior Member
 
Join Date: Jul 2007
Location: Italy
Posts: 664
Thanks: 77
Thanked 12 Times in 7 Posts
Default setquota: Not setting block grace time on because softlimit is not exceeded

Hi guys,

I have discovered that some clients in my host have exceeded the limit set for the traffic but ISPConfig doesn't block them.

In the meanwhile I have seen in the system log this message:

setquota: Not setting block grace time on /dev/disk/by-uuid/5376739d-9145-48f8-bf8a-f583671aea20 because softlimit is not exceeded.

So I have tried to debug the cron php code and I have found an error in the traffic quota calculation. This is the snipped code that I have get from the cron_daily.php

Line: 434
$web_traffic = (int)$tmp['total_traffic_bytes']/1024/1024;

result:
traffic_quota: 12000
total_traffic: 17228142008
web_traffic: 2047.9999990463

In this situation the user will be not Blocked by the server for the quota exceeded!

change it in:

$web_traffic = round($tmp['total_traffic_bytes']/1024/1024);

result:
traffic_quota: 12000
total_traffic: 17218633650
web_traffic: 16421

this solve the problem.


Furthermore where have I to set the Traffic Quota Lock option in the administration panel?

Array
(
[sys_groupid] => 136
[domain_id] => 3847
[domain] => mydomain.com
[traffic_quota] => 12000
[traffic_quota_lock] => n
)

At the end I have discovered that if I disable a website ticking off the active option checkbox the websites don't go offline.

thanks

Last edited by vaio1; 24th October 2012 at 09:34.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
softlimit is not exceeded sumfvm Installation/Configuration 2 14th May 2012 11:39
Ubuntu 11.1 breaks down mjnet Installation/Configuration 2 11th May 2012 09:49
user login problem after creation marcob Installation/Configuration 22 22nd May 2009 11:44
ISP Config hesitation when opening web pages frankb Installation/Configuration 7 15th December 2008 13:06
/etc/passwd wiped out after updating user via CP DantePasquale Installation/Configuration 4 25th April 2008 20:29


All times are GMT +2. The time now is 19:44.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.