#1  
Old 22nd October 2012, 13:54
Epoxy Epoxy is offline
Junior Member
 
Join Date: Oct 2012
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Unhappy Domain Alias problem

Hi all,
Sorry for my english, i'm french.
I try unfortunely to configure an alias domain.
Site1.com have a good forum
Site2.com have a good onlineshop (prestashop 1.5)
I just want shop.site1.com go to site2.com with the url shop.site1.com.

I've tryed all solution see on google last 2 days, and i don't want to breack somethink like my pc lol.

Please help !

http://docs.ispconfig.org/creating-w...s-web-domains/ don't work with any flag, i stay on site1.com or redirected with the url site2.com

shop.site1.com have a registration zone A (good?)

Lot of thx !
Reply With Quote
Sponsored Links
  #2  
Old 22nd October 2012, 14:23
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Login to ispconfig, Go to sites, click on aliasdomain and select "site2.com" as website and enter shop.site1.com in the alias field and click on save. Then add a a A-record "shop" to the zone "site1.com" in dns.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Epoxy (22nd October 2012)
  #3  
Old 22nd October 2012, 14:57
Epoxy Epoxy is offline
Junior Member
 
Join Date: Oct 2012
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Sorry, but you explain the link posted on my first post. Don't work, i've tried all combinaison of this tool.

Thx !
Reply With Quote
  #4  
Old 22nd October 2012, 15:00
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Thats the correct procedure. Then ispconfig is either not installed correctly on your server or your dns record is not correct. Please post the real domains that you setup and the apache vhost configuration file of site2.com, the file is in /etc/apache2/sites-enabled if you use debian or ubuntu.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Epoxy (22nd October 2012)
  #5  
Old 22nd October 2012, 15:05
Epoxy Epoxy is offline
Junior Member
 
Join Date: Oct 2012
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default

site1 is iphone-avenue.eu, the link for site2 is "La boutique" (boutique.iphone-avenue.eu) at the top of page, and the real site2 is zonefactory.eu (i work the theme !).

Code:
<Directory /var/www/zonefactory.eu>
    AllowOverride None
    Order Deny,Allow
    Deny from all
</Directory>

<VirtualHost 94.23.38.74:80>
      DocumentRoot /var/www/zonefactory.eu/web

    ServerName zonefactory.eu
    ServerAlias *.zonefactory.eu
    ServerAlias *.boutique.iphone-avenue.eu boutique.iphone-avenue.eu
    ServerAdmin webmaster@zonefactory.eu

    ErrorLog /var/log/ispconfig/httpd/zonefactory.eu/error.log


    ErrorDocument 400 /error/400.html
    ErrorDocument 401 /error/401.html
    ErrorDocument 403 /error/403.html
    ErrorDocument 404 /error/404.html
    ErrorDocument 405 /error/405.html
    ErrorDocument 500 /error/500.html
    ErrorDocument 503 /error/503.html

    <Directory /var/www/zonefactory.eu/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
    <Directory /var/www/clients/client2/web2/web>
        Options FollowSymLinks
        AllowOverride All
        Order allow,deny
        Allow from all
    </Directory>
thx a lot !
Reply With Quote
  #6  
Old 22nd October 2012, 15:13
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Please remove / disable the wildcard subdomains and use subdomain www in the site settings. Wildcard subdomains can confuse apache and are bad for your search engine ranking anyway. The config is corrcet and the dns record seems to be ok as well.

What is the exact problem that you have, content froa wrong server or content fromawrong site or no content at all? When I enter the url boutique.iphone-avenue.eu I get the content of a site, is this site hosted on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Epoxy (22nd October 2012)
  #7  
Old 22nd October 2012, 15:40
Epoxy Epoxy is offline
Junior Member
 
Join Date: Oct 2012
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
Default

The link boutique.iphone-avenue.eu don't go to zonefactory.eu, she stay on iphone-avenue.eu. I need to have this link on zonefactory.eu (multi-shop with domain name).
I've put 'www' on alias domain, and the problem is the same

iphone-avenue.eu is SEO and ranked only if no 'www'

Thx
Reply With Quote
  #8  
Old 22nd October 2012, 15:56
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,177
Thanks: 829
Thanked 5,414 Times in 4,257 Posts
Default

Is the site iphone-avenue.eu on the same server and did you activate wildcard subdomain there as well? Then deactivate wildcard subdomain in the site iphone-avenue.eu because when you enable it there, all pageviews for all subdomains of the domain iphone-avenue.eu will get redirected there even if you add a aliasdomain to another site.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
Epoxy (22nd October 2012)
  #9  
Old 22nd October 2012, 16:08
Epoxy Epoxy is offline
Junior Member
 
Join Date: Oct 2012
Posts: 5
Thanks: 4
Thanked 0 Times in 0 Posts
 
Thumbs up

Ok, you resolv my problem, i'was afraid to touch a domaine & website where i've no problems with them. I've tryed somethink wrong friday, and the dns & google was down for iphone-avenue.

Thank you very very much, i link this forum in my favorite. In france, we are far to be react than here.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Postfix delivery problem erebus Installation/Configuration 8 29th July 2014 20:17
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 12:47
Problem with the addition site and domain name Titeuf Installation/Configuration 2 25th November 2009 17:38
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
post fix error after a year aberrio Server Operation 5 5th May 2009 21:33


All times are GMT +2. The time now is 06:18.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.