Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Feature Requests

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 14th October 2012, 18:19
dupcantx dupcantx is offline
Junior Member
 
Join Date: Oct 2012
Posts: 3
Thanks: 2
Thanked 0 Times in 0 Posts
Red face Nginx Protected folders nothing PHP support (solved)

Hi, I'm actually using ISPConfig 3.0.4.6 with NginX and php-fpm on Centos 5.
I want to report a little bug in "Protected Folders".

When I add new "Protected Folder", the nginx configuration do not write PHP section, so when i try to run the /Protected-Folder/index.php, it will be downloaded and not interpreted.

solved

file /etc/nginx/sites-available/domain.tld.vhost

Quote:
location ^ ~ /Protected-Folder/ {
auth_basic "Members Only";
auth_basic_user_file /var/www/clients/client1/web5/web/Protected-Folder/.htpasswd;
}
to

Quote:
location ^ ~ /Protected-Folder/ {
auth_basic "Members Only";
auth_basic_user_file / var/www/clients/client1/web5/web/Protected-Folder/.htpasswd;
include /etc/nginx/fastcgi_params;
fastcgi_pass unix :/var/lib/php5-fpm/web5.sock; - or fastcgi_pass 127.0.0.1:9010;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $ document_root $ fastcgi_script_name;
fastcgi_param PATH_INFO $ fastcgi_script_name;
fastcgi_intercept_errors one;
}
changed

best regards

Last edited by dupcantx; 15th October 2012 at 12:28.
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Only Problems since Updating from 3.0.3.3 to 3.0.4.1 mbay General 4 17th May 2012 12:56
ubuntu and nginx delgado2061 Installation/Configuration 0 27th November 2011 23:36
Problem with services!! banzaiwebstudio.com Installation/Configuration 7 19th May 2010 21:13
Unable to install ISPConfig bdonecker Installation/Configuration 21 26th May 2009 08:20
Apache2 Freezes celtic Server Operation 31 28th May 2007 17:18


All times are GMT +2. The time now is 00:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.