Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th October 2012, 12:19
coozila coozila is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default The Perfect Server - CentOS 6.3 x86_64 (nginx, Dovecot, ISPConfig 3) - Page 4

http://www.howtoforge.com/perfect-se...ispconfig-3-p4

[root@CentOS-63-64-minimal home]# /etc/init.d/dovecot start
Starting Dovecot Imap: Error: service(pop3-login): listen(*, 110) failed: Address already in use
Error: service(pop3-login): listen(::, 110) failed: Address already in use
Error: service(pop3-login): listen(*, 995) failed: Address already in use
Error: service(pop3-login): listen(::, 995) failed: Address already in use
Error: service(imap-login): listen(*, 143) failed: Address already in use
Error: service(imap-login): listen(::, 143) failed: Address already in use
Error: service(imap-login): listen(*, 993) failed: Address already in use
Error: service(imap-login): listen(::, 993) failed: Address already in use
Fatal: Failed to start listeners
Reply With Quote
Sponsored Links
  #2  
Old 8th October 2012, 12:24
coozila coozila is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default :))) perfect server

[root@CentOS-63-64-minimal ~]# yum install postfix
Loaded plugins: fastestmirror, priorities
Loading mirror speeds from cached hostfile
* base: ftp.plusline.de
* epel: mirror.kiewel-online.ch
* extras: ftp.plusline.de
* remi: remirpm.mirror.gymkl.ch
* rpmforge: mirror1.hs-esslingen.de
* updates: ftp.plusline.de
1408 packages excluded due to repository priority protections
Setting up Install Process
Resolving Dependencies
--> Running transaction check
---> Package postfix.x86_64 2:2.6.6-2.2.el6_1 will be installed
--> Finished Dependency Resolution

Dependencies Resolved

================================================== ==============================
Package Arch Version Repository Size
================================================== ==============================
Installing:
postfix x86_64 2:2.6.6-2.2.el6_1 base 2.0 M

Transaction Summary
================================================== ==============================
Install 1 Package(s)

Total download size: 2.0 M
Installed size: 9.7 M
Is this ok [y/N]: y
Downloading Packages:
postfix-2.6.6-2.2.el6_1.x86_64.rpm | 2.0 MB 00:00
Running rpm_check_debug
Running Transaction Test
Transaction Test Succeeded
Running Transaction
Installing : 2ostfix-2.6.6-2.2.el6_1.x86_64 1/1
Verifying : 2ostfix-2.6.6-2.2.el6_1.x86_64 1/1

Installed:
postfix.x86_64 2:2.6.6-2.2.el6_1

Complete!
[root@CentOS-63-64-minimal ~]# chkconfig --levels 235 sendmail off
error reading information on service sendmail: No such file or directory
[root@CentOS-63-64-minimal ~]# chkconfig --levels 235 postfix on
[root@CentOS-63-64-minimal ~]# /etc/init.d/sendmail stop
-bash: /etc/init.d/sendmail: No such file or directory
[root@CentOS-63-64-minimal ~]# /etc/init.d/postfix restart
Shutting down postfix: [FAILED]
Starting postfix: [ OK ]
[root@CentOS-63-64-minimal ~]#
Reply With Quote
  #3  
Old 8th October 2012, 12:34
coozila coozila is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default 14 Install Amavisd-new, SpamAssassin, And ClamAV :))) perfect server

[root@CentOS-63-64-minimal ~]# /etc/init.d/clamd.amavisd startsa-update
Usage: /etc/init.d/clamd.amavisd {start|stop|status|restart|reload|condrestart}
[root@CentOS-63-64-minimal ~]# chkconfig --levels 235 amavisd on
[root@CentOS-63-64-minimal ~]# chkconfig --del clamd
[root@CentOS-63-64-minimal ~]# chkconfig --levels 235 clamd.amavisd on
[root@CentOS-63-64-minimal ~]# /usr/bin/freshclam
ClamAV update process started at Mon Oct 8 12:31:45 2012
main.cvd is up to date (version: 54, sigs: 1044387, f-level: 60, builder: sven)
daily.cld is up to date (version: 15441, sigs: 275894, f-level: 63, builder: guitar)
bytecode.cvd is up to date (version: 190, sigs: 36, f-level: 63, builder: neo)
[root@CentOS-63-64-minimal ~]# /etc/init.d/amavisd start
Starting amavisd: fetch_modules: error loading required module Compress/Zlib.pm:
Compress::Raw::Zlib version 2.052 required--this is only version 2.02 at /usr/lib64/perl5/Compress/Zlib.pm line 11.
BEGIN failed--compilation aborted at /usr/lib64/perl5/Compress/Zlib.pm line 11.
Compilation failed in require at /usr/sbin/amavisd line 197.
ERROR: MISSING REQUIRED BASIC MODULES:
Compress::Zlib
BEGIN failed--compilation aborted at /usr/sbin/amavisd line 237.
[FAILED]

[root@CentOS-63-64-minimal ~]# /etc/init.d/clamd.amavisd start
Starting clamd.amavisd: [ OK ]
Reply With Quote
  #4  
Old 8th October 2012, 14:55
coozila coozila is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default isp config end instalation i cant login perfect server

Reconfigure Crontab? (yes,no) [yes]: yes

Updating Crontab
Restarting services ...
Stopping mysqld: [ OK ]
Starting mysqld: [ OK ]
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Stopping saslauthd: [ OK ]
Starting saslauthd: [ OK ]
fetch_modules: error loading required module Compress/Zlib.pm:
Compress::Raw::Zlib version 2.052 required--this is only version 2.02 at /usr/lib64/perl5/Compress/Zlib.pm line 11.
BEGIN failed--compilation aborted at /usr/lib64/perl5/Compress/Zlib.pm line 11.
Compilation failed in require at /usr/sbin/amavisd line 197.
ERROR: MISSING REQUIRED BASIC MODULES:
Compress::Zlib
BEGIN failed--compilation aborted at /usr/sbin/amavisd line 237.
Shutting down amavisd: [FAILED]

fetch_modules: error loading required module Compress/Zlib.pm:
Compress::Raw::Zlib version 2.052 required--this is only version 2.02 at /usr/lib64/perl5/Compress/Zlib.pm line 11.
BEGIN failed--compilation aborted at /usr/lib64/perl5/Compress/Zlib.pm line 11.
Compilation failed in require at /usr/sbin/amavisd line 197.
ERROR: MISSING REQUIRED BASIC MODULES:
Compress::Zlib
BEGIN failed--compilation aborted at /usr/sbin/amavisd line 237.
Starting amavisd: [FAILED]

Stopping clamd.amavisd: [ OK ]
Starting clamd.amavisd: [ OK ]
Stopping Courier authentication services: authdaemond
Starting Courier authentication services: authdaemond
Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Stopping Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Starting Courier-IMAP server: imap imap-ssl pop3 pop3-ssl
Stopping Dovecot Imap: [FAILED]
Error: service(pop3-login): listen(*, 110) failed: Address already in use
Error: service(pop3-login): listen(::, 110) failed: Address already in use
Error: service(pop3-login): listen(*, 995) failed: Address already in use
Error: service(pop3-login): listen(::, 995) failed: Address already in use
Error: service(imap-login): listen(*, 143) failed: Address already in use
Error: service(imap-login): listen(::, 143) failed: Address already in use
Error: service(imap-login): listen(*, 993) failed: Address already in use
Error: service(imap-login): listen(::, 993) failed: Address already in use
Fatal: Failed to start listeners
Starting Dovecot Imap: [FAILED]
Reloading php-fpm: [ OK ]
nginx: [emerg] "fastcgi_buffer_size" directive is duplicate in /etc/nginx/sites-enabled/000-apps.vhost:26
nginx: configuration file /etc/nginx/nginx.conf test failed

=================================
fastcgi_buffer_size and fastcgi_buffers

is part of fastcgi_params



location ~ \.php$ {
try_files $uri =404;
include /etc/nginx/fastcgi_params;
fastcgi_pass unix:/var/lib/php5-fpm/ispconfig.sock;
fastcgi_index index.php;
fastcgi_param SCRIPT_FILENAME $document_root$fastcgi_script_name;
fastcgi_param PATH_INFO $fastcgi_script_name;
fastcgi_buffer_size 128k;
fastcgi_buffers 256 4k;

fastcgi_busy_buffers_size 256k;
fastcgi_temp_file_write_size 256k;
}




Stopping pure-ftpd: [ OK ]
Starting pure-ftpd: [ OK ]
Update finished.
[root@CentOS-63-64-minimal install]# cd /etc/dovecot
[root@CentOS-63-64-minimal dovecot]# mv dovecot.conf dovecot.conf_orig
[root@CentOS-63-64-minimal dovecot]# ln -s ../dovecot.conf dovecot.conf
[root@CentOS-63-64-minimal dovecot]# /etc/init.d/dovecot restart
Stopping Dovecot Imap: [FAILED]
Starting Dovecot Imap: Error: service(pop3-login): listen(*, 110) failed: Address already in use
Error: service(pop3-login): listen(::, 110) failed: Address already in use
Error: service(pop3-login): listen(*, 995) failed: Address already in use
Error: service(pop3-login): listen(::, 995) failed: Address already in use
Error: service(imap-login): listen(*, 143) failed: Address already in use
Error: service(imap-login): listen(::, 143) failed: Address already in use
Error: service(imap-login): listen(*, 993) failed: Address already in use
Error: service(imap-login): listen(::, 993) failed: Address already in use
Fatal: Failed to start listeners

Last edited by coozila; 8th October 2012 at 15:05.
Reply With Quote
  #5  
Old 8th October 2012, 14:57
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

The setup you used to install your server uses courier pop3 / imap daemon. Seems as if you had a differents etup or controlpanel installed on your server before without reinstalling as dovecot seems to be present on your server which causes a conflict with courier. You should remove dovecot to get the setup working.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #6  
Old 10th October 2012, 13:10
coozila coozila is offline
Junior Member
 
Join Date: Oct 2012
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default i have restart instalation from fresh server

http://www.howtoforge.com/perfect-se...ispconfig-3-p4


12 Install Postfix

Postfix can be installed as follows:

yum install postfix

Then turn off Sendmail and start Postfix:

chkconfig --levels 235 sendmail off
chkconfig --levels 235 postfix on
/etc/init.d/sendmail stop
/etc/init.d/postfix restart

this step gett error
[root@CentOS-63-64-minimal ~]# chkconfig --levels 235 sendmail off
error reading information on service sendmail: No such file or directory
[root@CentOS-63-64-minimal ~]# chkconfig --levels 235 postfix on
[root@CentOS-63-64-minimal ~]# /etc/init.d/sendmail stop
-bash: /etc/init.d/sendmail: No such file or directory
[root@CentOS-63-64-minimal ~]# /etc/init.d/postfix restart
Shutting down postfix: [ OK ]
Starting postfix: [ OK ]
Reply With Quote
  #7  
Old 12th October 2012, 12:40
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

This is ok - it just means that sendmail isn't installed which is fine.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #8  
Old 19th October 2012, 13:03
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 126
Thanks: 6
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
 
Default

if u used
minimal install CD
like i do, then no mail server is installed
it's very very minimal, more embedded than minimal
so, no sendmail, no postfix, no exim....
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
500 internal error after upgrade abintipl Installation/Configuration 9 18th July 2012 12:51
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 17:02
Postfix can't received email from exterior astra2000 Server Operation 5 17th October 2009 23:26
I don't recieve mail. privir Installation/Configuration 2 3rd June 2009 22:08


All times are GMT +2. The time now is 06:38.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.