Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 1st October 2012, 01:19
atjensen11 atjensen11 is offline
Senior Member
 
Join Date: Dec 2007
Posts: 199
Thanks: 9
Thanked 6 Times in 6 Posts
Default Re-Associate Server with Master Server in Multiserver Setup

I followed the multiserver setup How To for Debian.

I have a mail server within the setup that is partially not working. It performs most tasks as needed, but it will not create new email domains. I have tried resolving the issue the last couple of weeks through the help of this forum.

Is there a way I can simply re-associate the mail server with the main server in the setup?

What would happen if I uninstall ISPConfig from the mail server and then reinstalled? Would I have to recreate the email domains and mailboxes through the ISPConfig administration panel on the main server or would the data in the database get mirror onto the server once reinstalled?

I am about at the point where I need to stand up a new mail server to fix this problem.
Reply With Quote
Sponsored Links
  #2  
Old 1st October 2012, 11:15
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,009
Thanks: 840
Thanked 5,651 Times in 4,461 Posts
Default

Quote:
Is there a way I can simply re-associate the mail server with the main server in the setup?
No.

Quote:
What would happen if I uninstall ISPConfig from the mail server and then reinstalled? Would I have to recreate the email domains and mailboxes through the ISPConfig administration panel on the main server or would the data in the database get mirror onto the server once reinstalled?
You would have to delete all meail domains and accounts first and then recreate them on the new server. So thats not a real option.

You might want to consider to contact our ispconfig support instead as such a problem can always be fixed without a reinstall.

http://support.projektfarm.com
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 8th October 2012, 01:06
atjensen11 atjensen11 is offline
Senior Member
 
Join Date: Dec 2007
Posts: 199
Thanks: 9
Thanked 6 Times in 6 Posts
 
Default [SOLVED] Re-Associate Server with Master Server in Multiserver Setup

I decided to stand up a brand new email server and add it to the multiserver setup. After going through this effort, I repeated my test step and was disappointed to see the new server behaved just like the old server. I began to suspect a problem with the master server in the setup.

I decided to step through the ISPConfig code. I noticed that the server.sh script calls the mail module. The mail module raises an event which is included in the mail plugin. Upon searching the mail plugin, I could not find any function that creates the mail domain directory. Instead, I noticed that the function which creates the user mailbox does a check to see if the mail domain directory exists. If the mail domain directory doesn't exist, the user mailbox function creates it.

Therefore, I concluded that the test I was performing to see if the server was working correctly was flawed. I simply needed to create a mailbox within the new email domain in order for the mail domain directory to be created.

I elected to delete all the email domains and mailboxes and then recreate them on the new server I stood up. I then moved all the email data from the old server to the new server. I only wish I would have searched through the ISPConfig code prior to deleting the email domains from the master server. I was committed at that point and had to finish the transition to the new server.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 Installation - Postfix queue stuck andrew971218 Installation/Configuration 21 15th July 2011 15:42
amavis & ispconfig 3 yalex2000 Installation/Configuration 20 18th February 2010 18:02
subdomain and mail relay configuration aranthorn Installation/Configuration 24 3rd September 2007 23:53
Rejecting outbound mail tristanlee85 General 11 20th May 2007 18:04
Problems with Postfix Mysql Courier PatrickAdrichem Installation/Configuration 3 13th April 2007 16:44


All times are GMT +2. The time now is 15:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.