Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 5th October 2012, 11:04
tonyreaper tonyreaper is offline
Junior Member
 
Join Date: Jun 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default Error connecting to IMAP server: localhost. 111 : Connection refused

Really ticking me off. I had this server configured right the first time a few months back but when i moved and had to change service providers somehow my vmware files corrupted so i had to reinstall everything. idk what happened but somewhere along the line i messed up my email settings. i am on ubuntu 12.04 server on vmware with a single static ip managing everything. i just got 2 domains successfully installed and their A zones changed to my static ip. Now could it be that since I'm still keeping the godaddy nameservers that could be why my email isn't working or is dovecot and postfix messed up. I think I messed up the dovecot.conf file and ended up having to purge both postfix and dovecot. i reinstalled them but dovecot isn't appearing in my /etc folder. i need a lot of help. i've scoured over the ispconfig3 manual but haven't found anything that would help me and the same has been done with google.
Reply With Quote
Sponsored Links
  #2  
Old 5th October 2012, 11:09
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,190
Thanks: 829
Thanked 5,418 Times in 4,260 Posts
Default

Ensure that you run a ispconfig update with reconfiguring services after you reinstalled postfix and dovvecot, otherwise the services are not configured and can not work.

Code:
cd /tmp
wget http://www.ispconfig.org/downloads/ISPConfig-3-stable.tar.gz
tar xvfz ISPConfig-3-stable.tar.gz
cd ispconfig3_install/install
php -q update.php
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 5th October 2012, 11:15
tonyreaper tonyreaper is offline
Junior Member
 
Join Date: Jun 2012
Posts: 5
Thanks: 0
Thanked 0 Times in 0 Posts
Default

the other issue i had was that if i stopped and restarted dovecot it said it started but when i checked its status it said that it was stopped. when i'd start the server dovecot service always failed.
Reply With Quote
  #4  
Old 5th October 2012, 11:24
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,190
Thanks: 829
Thanked 5,418 Times in 4,260 Posts
 
Default

Check the mail.log file for errors.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig3 mail doesn't work pehden Installation/Configuration 20 9th December 2013 14:05
error.log is full of notices mod_fcgid 007007 Installation/Configuration 13 8th September 2012 11:29
haproxy with stunnel problem abubin Server Operation 6 10th April 2012 15:08
ERROR: Connection dropped by IMAP server. [Centos 5.4, courier imap,squirrel, etc] darevil HOWTO-Related Questions 7 9th June 2010 14:49
Stange mail problem The-Ghost Installation/Configuration 6 25th April 2010 19:59


All times are GMT +2. The time now is 16:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.