Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 30th September 2012, 00:05
rlischer rlischer is offline
Senior Member
 
Join Date: Jul 2009
Posts: 121
Thanks: 6
Thanked 1 Time in 1 Post
Default Help, mail will not send/receive

I am running Ubuntu 12.04 on Amazon ec2 and everything seems to work except mail. Here is my log:

Code:
Sep 29 20:45:01 ip-10-243-150-85 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Sep 29 20:45:01 ip-10-243-150-85 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Sep 29 20:45:02 ip-10-243-150-85 postfix/smtps/smtpd[6862]: connect from localhost[127.0.0.1]
Sep 29 20:45:02 ip-10-243-150-85 postfix/smtps/smtpd[6862]: SSL_accept error from localhost[127.0.0.1]: lost connection
Sep 29 20:45:02 ip-10-243-150-85 postfix/smtps/smtpd[6862]: lost connection after CONNECT from localhost[127.0.0.1]
Sep 29 20:45:02 ip-10-243-150-85 postfix/smtps/smtpd[6862]: disconnect from localhost[127.0.0.1]
Sep 29 20:49:38 ip-10-243-150-85 postfix/smtps/smtpd[6945]: connect from localhost[127.0.0.1]
Sep 29 20:50:01 ip-10-243-150-85 postfix/smtps/smtpd[6973]: connect from localhost[127.0.0.1]
Sep 29 20:50:01 ip-10-243-150-85 postfix/smtps/smtpd[6973]: SSL_accept error from localhost[127.0.0.1]: lost connection
Sep 29 20:50:01 ip-10-243-150-85 postfix/smtps/smtpd[6973]: lost connection after CONNECT from localhost[127.0.0.1]
Sep 29 20:50:01 ip-10-243-150-85 postfix/smtps/smtpd[6973]: disconnect from localhost[127.0.0.1]
Sep 29 20:50:02 ip-10-243-150-85 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Sep 29 20:50:02 ip-10-243-150-85 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Sep 29 20:51:36 ip-10-243-150-85 postfix/smtps/smtpd[6973]: connect from mail-wg0-f44.google.com[74.125.82.44]
Reply With Quote
Sponsored Links
  #2  
Old 30th September 2012, 11:37
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

There seems to be a problem with your SSL cert. Have you tried to recreate it with the default values?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 30th September 2012, 15:01
rlischer rlischer is offline
Senior Member
 
Join Date: Jul 2009
Posts: 121
Thanks: 6
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
There seems to be a problem with your SSL cert. Have you tried to recreate it with the default values?
If it's the same SSL cert I make when installing PureFTP I get this error on this line: "sudo echo 1 > /etc/pure-ftpd/conf/TLS" then I get Permission Denied every time. Would this cause my SSL problem?

thanks
Reply With Quote
  #4  
Old 1st October 2012, 22:21
rlischer rlischer is offline
Senior Member
 
Join Date: Jul 2009
Posts: 121
Thanks: 6
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
There seems to be a problem with your SSL cert. Have you tried to recreate it with the default values?
I recreated my SSL Cert. Here is my new log:

Code:
Oct 1 19:08:54 ip-10-245-83-208 postfix/smtps/smtpd[2617]: lost connection after CONNECT from localhost[127.0.0.1]
Oct 1 19:08:54 ip-10-245-83-208 postfix/smtps/smtpd[2617]: disconnect from localhost[127.0.0.1]
Oct 1 19:08:54 ip-10-245-83-208 dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
Oct 1 19:08:54 ip-10-245-83-208 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=2707, secured
Oct 1 19:08:54 ip-10-245-83-208 dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=79/687
Oct 1 19:10:02 ip-10-245-83-208 postfix/smtps/smtpd[2617]: connect from localhost[127.0.0.1]
Oct 1 19:10:02 ip-10-245-83-208 postfix/smtps/smtpd[2617]: SSL_accept error from localhost[127.0.0.1]: lost connection
Oct 1 19:10:02 ip-10-245-83-208 postfix/smtps/smtpd[2617]: lost connection after CONNECT from localhost[127.0.0.1]
Oct 1 19:10:02 ip-10-245-83-208 postfix/smtps/smtpd[2617]: disconnect from localhost[127.0.0.1]
Oct 1 19:10:02 ip-10-245-83-208 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 1 19:10:02 ip-10-245-83-208 dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 1 19:14:35 ip-10-245-83-208 dovecot: pop3-login: Disconnected: Inactivity (no auth attempts): rip=54.243.225.199, lip=10.245.83.208, TLS
Oct 1 19:14:46 ip-10-245-83-208 dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
Oct 1 19:14:46 ip-10-245-83-208 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=2807, secured
Oct 1 19:14:46 ip-10-245-83-208 dovecot: imap(rlischer@fatbikes.org): Disconnected: Logged out bytes=44/709
Oct 1 19:14:46 ip-10-245-83-208 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=2809, secured
Oct 1 19:14:46 ip-10-245-83-208 dovecot: imap(rlischer@fatbikes.org): Disconnected: Logged out bytes=386/1275
Oct 1 19:14:46 ip-10-245-83-208 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=2811, secured
Oct 1 19:14:46 ip-10-245-83-208 dovecot: imap(rlischer@fatbikes.org): Disconnected: Logged out bytes=117/1401
Oct 1 19:14:48 ip-10-245-83-208 dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=2813, secured
Oct 1 19:14:48 ip-10-245-83-208 dovecot: imap(rlischer@fatbikes.org): Disconnected: Logged out bytes=79/687
Oct 1 19:14:58 ip-10-245-83-208 postfix/smtps/smtpd[2814]: connect from localhost[127.0.0.1]
Oct 1 19:15:01 ip-10-245-83-208 dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Reply With Quote
  #5  
Old 3rd October 2012, 21:00
rlischer rlischer is offline
Senior Member
 
Join Date: Jul 2009
Posts: 121
Thanks: 6
Thanked 1 Time in 1 Post
Default

update. It appears that I can send/receive email to myself using Outlook with SSL turned on. I can also send email to my gmail account, but if I reply in gmail it never makes it back to me.

Any ideas?

New log:
Code:
Oct 3 17:43:24 server postfix/smtp[7142]: 7BC62224E8: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.41, delays=0.14/0/0.03/0.24, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as D09B522557)
Oct 3 17:43:24 server postfix/qmgr[1633]: 7BC62224E8: removed
Oct 3 17:43:25 server dovecot: lda(rob@fatbikes.org): sieve: msgid=<000d01cda18e$e13c3620$a3b4a260$@fatbikes.org>: stored mail into mailbox 'INBOX'
Oct 3 17:43:25 server postfix/pipe[7165]: D09B522557: to=, relay=dovecot, delay=0.15, delays=0.01/0.04/0/0.1, dsn=2.0.0, status=sent (delivered via dovecot service)
Oct 3 17:43:25 server postfix/qmgr[1633]: D09B522557: removed
Oct 3 17:43:27 server postfix/smtps/smtpd[7162]: disconnect from unknown[66.161.136.106]
Oct 3 17:43:33 server postfix/smtps/smtpd[7162]: warning: hostname Target-Marketing.STATIC.fuse.net does not resolve to address 66.161.136.106: Name or service not known
Oct 3 17:43:33 server postfix/smtps/smtpd[7162]: connect from unknown[66.161.136.106]
Oct 3 17:43:33 server postfix/smtps/smtpd[7162]: 67A6A224E8: client=unknown[66.161.136.106], sasl_method=LOGIN, sasl_username=rob@fatbikes.org
Oct 3 17:43:33 server postfix/cleanup[7141]: 67A6A224E8: message-id=<001d01cda18e$e68f4770$b3add650$@fatbikes.org>
Oct 3 17:43:33 server postfix/qmgr[1633]: 67A6A224E8: from=, size=3694, nrcpt=1 (queue active)
Oct 3 17:43:33 server amavis[1337]: (01337-03) (!!)file(1) utility (/usr/bin/file) FAILED: run_command: can't fork: Cannot allocate memory at /usr/sbin/amavisd-new line 3081, line 277.
Oct 3 17:43:34 server postfix/smtpd[7116]: connect from localhost.localdomain[127.0.0.1]
Oct 3 17:43:34 server postfix/smtpd[7116]: 27E8822557: client=localhost.localdomain[127.0.0.1]
Oct 3 17:43:34 server postfix/cleanup[7141]: 27E8822557: message-id=<001d01cda18e$e68f4770$b3add650$@fatbikes.org>
Oct 3 17:43:34 server postfix/qmgr[1633]: 27E8822557: from=, size=4158, nrcpt=1 (queue active)
Oct 3 17:43:34 server postfix/smtpd[7116]: disconnect from localhost.localdomain[127.0.0.1]
Oct 3 17:43:34 server amavis[1337]: (01337-03) Passed CLEAN, [66.161.136.106] [66.161.136.106] -> , Message-ID: <001d01cda18e$e68f4770$b3add650$@fatbikes.org>, mail_id: PNZBsyB9U94K, Hits: -0.999, size: 3694, queued_as: 27E8822557, 685 ms
Oct 3 17:43:34 server postfix/smtp[7142]: 67A6A224E8: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=0.82, delays=0.12/0/0/0.7, dsn=2.0.0, status=sent (250 2.0.0 from MTA([127.0.0.1]:10025): 250 2.0.0 Ok: queued as 27E8822557)
Oct 3 17:43:34 server postfix/qmgr[1633]: 67A6A224E8: removed
Oct 3 17:43:34 server dovecot: lda(rob@fatbikes.org): sieve: msgid=<001d01cda18e$e68f4770$b3add650$@fatbikes.org>: stored mail into mailbox 'INBOX'
Oct 3 17:43:34 server postfix/pipe[7165]: 27E8822557: to=, relay=dovecot, delay=0.12, delays=0.02/0/0/0.1, dsn=2.0.0, status=sent (delivered via dovecot service)
Oct 3 17:43:34 server postfix/qmgr[1633]: 27E8822557: removed
Oct 3 17:43:36 server postfix/smtps/smtpd[7162]: disconnect from unknown[66.161.136.106]
Oct 3 17:43:49 server dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=7170, secured
Oct 3 17:43:49 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=44/709
Oct 3 17:43:49 server dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=7172, secured
Oct 3 17:43:50 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=449/4107
Oct 3 17:43:50 server dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=7174, secured
Oct 3 17:43:50 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=300/1395
Oct 3 17:43:56 server dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=7176, secured
Oct 3 17:43:56 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=143/2566
Oct 3 17:44:00 server dovecot: imap-login: Login: user=, method=PLAIN, rip=127.0.0.1, lip=127.0.0.1, mpid=7178, secured
Oct 3 17:44:00 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=143/2566
Oct 3 17:44:12 server postfix/smtps/smtpd[7162]: connect from localhost.localdomain[127.0.0.1]
Reply With Quote
  #6  
Old 4th October 2012, 12:43
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Please check if the MX record of your domain is pointing to the correct server. You can check that as follows:
Code:
dig mx yourdomain.com
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #7  
Old 4th October 2012, 13:44
rlischer rlischer is offline
Senior Member
 
Join Date: Jul 2009
Posts: 121
Thanks: 6
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
Please check if the MX record of your domain is pointing to the correct server. You can check that as follows:
Code:
dig mx yourdomain.com
Here is what I get:

Code:
Roberts-iMac:~ rlischer$ dig mx fatbikes.org

; <<>> DiG 9.8.3-P1 <<>> mx fatbikes.org
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 16129
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;fatbikes.org.			IN	MX

;; ANSWER SECTION:
fatbikes.org.		300	IN	MX	10 mail.fatbikes.org.

;; Query time: 108 msec
;; SERVER: 192.168.1.1#53(192.168.1.1)
;; WHEN: Thu Oct  4 06:42:58 2012
;; MSG SIZE  rcvd: 51
Reply With Quote
  #8  
Old 5th October 2012, 11:32
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,748 Times in 2,579 Posts
Default

Does the A record of mail.fatbikes.org point to the correct IP?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #9  
Old 5th October 2012, 14:58
rlischer rlischer is offline
Senior Member
 
Join Date: Jul 2009
Posts: 121
Thanks: 6
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by falko View Post
Does the A record of mail.fatbikes.org point to the correct IP?
yes. If you want to log into my EC2 instance and look around I'll send you my key. I am just using ec2 to try to learn my way around. I have never had any problems with ISPConfig 3, so I know if has something to do with Amazon. Either a port of something with SSL.

More from the mail log:
Code:
Oct 5 12:55:05 server postfix/smtps/smtpd[2229]: lost connection after CONNECT from server70.appriver.com[69.20.119.203]
Oct 5 12:55:05 server postfix/smtps/smtpd[2229]: disconnect from server70.appriver.com[69.20.119.203]
Oct 5 12:56:52 server dovecot: auth-worker: mysql(localhost): Connected to database dbispconfig
Oct 5 12:56:52 server dovecot: imap-login: Login: user=, method=PLAIN, rip=66.161.136.106, lip=10.158.26.160, mpid=2338, TLS
Oct 5 12:56:52 server dovecot: imap-login: Login: user=, method=PLAIN, rip=66.161.136.106, lip=10.158.26.160, mpid=2340, TLS
Oct 5 12:57:29 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=535/3743
Oct 5 12:57:29 server dovecot: imap(rob@fatbikes.org): Disconnected: Logged out bytes=63/556
Oct 5 12:57:29 server postfix/smtps/smtpd[2348]: connect from localhost.localdomain[127.0.0.1]
Oct 5 13:00:02 server dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 5 13:00:02 server dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 5 13:00:02 server postfix/smtps/smtpd[2528]: connect from localhost.localdomain[127.0.0.1]
Oct 5 13:00:02 server postfix/smtps/smtpd[2528]: SSL_accept error from localhost.localdomain[127.0.0.1]: lost connection
Oct 5 13:00:02 server postfix/smtps/smtpd[2528]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct 5 13:00:02 server postfix/smtps/smtpd[2528]: disconnect from localhost.localdomain[127.0.0.1]
Oct 5 13:00:05 server postfix/smtps/smtpd[2528]: connect from server70.appriver.com[69.20.119.203]
Oct 5 13:02:29 server postfix/smtps/smtpd[2348]: SSL_accept error from localhost.localdomain[127.0.0.1]: Connection timed out
Oct 5 13:02:29 server postfix/smtps/smtpd[2348]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct 5 13:02:29 server postfix/smtps/smtpd[2348]: disconnect from localhost.localdomain[127.0.0.1]
Oct 5 13:05:02 server dovecot: imap-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 5 13:05:02 server dovecot: pop3-login: Disconnected (no auth attempts): rip=127.0.0.1, lip=127.0.0.1, secured
Oct 5 13:05:02 server postfix/smtps/smtpd[2793]: connect from localhost.localdomain[127.0.0.1]
Oct 5 13:05:02 server postfix/smtps/smtpd[2793]: SSL_accept error from localhost.localdomain[127.0.0.1]: lost connection
Oct 5 13:05:02 server postfix/smtps/smtpd[2793]: lost connection after CONNECT from localhost.localdomain[127.0.0.1]
Oct 5 13:05:02 server postfix/smtps/smtpd[2793]: disconnect from localhost.localdomain[127.0.0.1]
Oct 5 13:05:05 server postfix/smtps/smtpd[2528]: SSL_accept error from server70.appriver.com[69.20.119.203]: lost connection
Oct 5 13:05:05 server postfix/smtps/smtpd[2528]: lost connection after CONNECT from server70.appriver.com[69.20.119.203]
Oct 5 13:05:05 server postfix/smtps/smtpd[2528]: disconnect from server70.appriver.com[69.20.119.203]

Last edited by rlischer; 5th October 2012 at 16:13.
Reply With Quote
  #10  
Old 5th October 2012, 23:26
pititis pititis is offline
Senior Member
 
Join Date: Dec 2010
Location: Mnchen
Posts: 364
Thanks: 39
Thanked 89 Times in 68 Posts
 
Default

Hello,

Can you post the ouput of:

Code:
 postconf
Cheers

Last edited by pititis; 5th October 2012 at 23:28.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 23:58
mail recipient linux_red Installation/Configuration 6 9th March 2012 15:24
Sendig mail Error fisherofer Installation/Configuration 12 30th November 2011 08:56
ISPconfig 3.0.3.2 postfix not relaying outgoing attachments mychoice2009 Installation/Configuration 3 13th April 2011 18:42
Postfix reject connections gabrix Server Operation 27 25th January 2007 09:37


All times are GMT +2. The time now is 16:02.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.