Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th September 2012, 15:20
localseo localseo is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Unhappy HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while

Hello,

Just finished installling through howto for :The Perfect Server - CentOS 6.3 x86_64 (Apache2, Dovecot, ISPConfig 3)

Everything seemed to be running fine until I setup a domain with some traffic and it lasted for about 5 minutes.

I now just get

HTTP Error 500 (Internal Server Error): An unexpected condition was encountered while the server was attempting to fulfill the request.

When restarting apache I get

Quote:
Iniciando httpd: [Thu Sep 27 16:14:44 2012] [warn] NameVirtualHost *:80 has no VirtualHosts
And apache error log shows this:

Quote:
[Thu Sep 27 16:15:01 2012] [notice] caught SIGTERM, shutting down
[Thu Sep 27 16:15:01 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Thu Sep 27 16:15:01 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Sep 27 16:15:01 2012] [notice] Digest: generating secret for digest authentication ...
[Thu Sep 27 16:15:01 2012] [notice] Digest: done
[Thu Sep 27 16:15:01 2012] [error] python_init: Python version mismatch, expected '2.6.5', found '2.6.6'.
[Thu Sep 27 16:15:01 2012] [error] python_init: Python executable found '/usr/bin/python'.
[Thu Sep 27 16:15:01 2012] [error] python_init: Python path being used '/usr/lib64/python26.zip:/usr/lib64/python2.6/:/usr/lib64/python2.6/plat-linux2:/usr/lib64/python2.6/lib-tk:/usr/lib64/python2.6/lib-old:/usr/lib64/python2.6/lib-dynload'.
[Thu Sep 27 16:15:01 2012] [notice] mod_python: Creating 4 session mutexes based on 10 max processes and 0 max threads.
[Thu Sep 27 16:15:01 2012] [notice] mod_python: using mutex_directory /tmp
[Thu Sep 27 16:15:01 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Thu Sep 27 16:15:01 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.7 PHP/5.3.3 mod_python/3.3.1 Python/2.6.6 mod_ruby/1.3.0 Ruby/1.8.7(2011-06-30) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
Any ideas how to fix?

Thank you
Adam
Reply With Quote
Sponsored Links
  #2  
Old 27th September 2012, 15:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,788
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Please post the error message from the error.log of the website.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 27th September 2012, 15:39
localseo localseo is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry hadnt checked there, lots of Fiel does not exist and this

Quote:
[Thu Sep 27 16:24:42 2012] [error] [client 41.204.205.132] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind
[Thu Sep 27 16:26:07 2012] [warn] [client 5.9.20.93] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 16:26:07 2012] [error] [client 5.9.20.93] Premature end of script headers: submit.php
Thanks
Reply With Quote
  #4  
Old 27th September 2012, 16:25
localseo localseo is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Sorry didnt look there.


Quote:
[Thu Sep 27 16:24:42 2012] [error] [client 41.204.205.132] client sent HTTP/1.1 request without hostname (see RFC2616 section 14.23): /w00tw00t.at.ISC.SANS.DFind
[Thu Sep 27 16:26:07 2012] [warn] [client 5.9.20.93] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 16:26:07 2012] [error] [client 5.9.20.93] Premature end of script headers: submit.php
Thanks
Reply With Quote
  #5  
Old 27th September 2012, 22:01
localseo localseo is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Hi dont know why but my reply doesnt seem to be going back.

Trying again

This is the strangest thing I see in the domain error log

Thanks

Quote:
[Thu Sep 27 22:09:02 2012] [warn] [client 5.9.1.221] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 22:09:02 2012] [error] [client 5.9.1.221] Premature end of script headers: submit.php
[Thu Sep 27 22:09:13 2012] [warn] [client 5.9.1.221] mod_fcgid: read data timeout in 360 seconds
[Thu Sep 27 22:09:13 2012] [error] [client 5.9.1.221] Premature end of script headers: submit.php
Reply With Quote
  #6  
Old 28th September 2012, 10:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
[Thu Sep 27 22:09:13 2012] [warn] [client 5.9.1.221] mod_fcgid: read data timeout in 360 seconds
It seems as if your script is taking too long to execute.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
localseo (1st October 2012)
  #7  
Old 1st October 2012, 08:30
localseo localseo is offline
Junior Member
 
Join Date: Sep 2012
Posts: 5
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Thanks,

Will try to change conf too

<IfModule mod_fcgid.c>
AddHandler fcgid-script .fcgi
IdleTimeout 300
BusyTimeout 300
ProcessLifeTime 7200
IPCConnectTimeout 300
IPCCommTimeout 7200
</IfModule>

See if it works

Quote:
Originally Posted by falko View Post
It seems as if your script is taking too long to execute.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
User unknown in relay recipient table Taxick Installation/Configuration 12 9th April 2013 13:31
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 11:49
Bind9 Error Messages (and a problem with A records...) erosbk Server Operation 0 23rd May 2011 08:18
Problem with mail server and subdomains MyKE General 7 26th February 2010 11:18
The Perfect Setup Suse 9.3 - Postfix problems new_bee05 HOWTO-Related Questions 20 25th November 2005 03:30


All times are GMT +2. The time now is 03:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.