Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 27th September 2012, 21:21
Disassembler Disassembler is offline
Junior Member
 
Join Date: Jul 2012
Posts: 19
Thanks: 2
Thanked 7 Times in 5 Posts
Default SOAP API problems in 3.0.4.6

I have a sizeable Plesk installation to migrate to ISPconfig. Being the type who rather than doing a couple hours of mindless clicking would spend three times that writing code, I set out to write a generic converter that might even benefit others in the same situation. But I'm having problems with the SOAP API, particularly the domains_domain_add function. It always gives me a "permission denied" error even though my API user has every single checkmark for permissions set. I'm not sure whether the problem occurs with other functions too so far as I've only done the bits for clients and domains so far; clients work fine though.

The problem occurs with both my Perl program and the PHP example by the way. So far I've simply hacked checkPerm() to always return true to be able to go on with development ...

I'm on a remote island in the Galapagos with rather intermittent internet at the moment, so please excuse any delays in getting back to this thread (and my inability to do any serious debugging on this ISPconfig install running in VirtualBox on my little netbook ). Just checked out the SVN version to see if it makes a difference though.
Reply With Quote
Sponsored Links
 

Bookmarks

Tags
bug, soap

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3 Remote api - SOAP error kassyo General 9 27th November 2013 13:05
SOAP problem with ISPConfig API xaver Programming/Scripts 4 5th January 2012 12:27
Soap API and Welcome email adminnc General 1 26th January 2011 08:27
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11
Empty Recycle Bin jon335 General 40 6th May 2006 11:56


All times are GMT +2. The time now is 15:12.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.