Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 13th September 2012, 22:11
user2012 user2012 is offline
Junior Member
 
Join Date: Sep 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

is rare, I followed the steps as it appears.

when I create a user in phpmyadmin, typing ls-l did not appear

drwxr-xr-x 2 ftpuser ftpgroup 3 July 4096 22:23 www.example.com

the user and group are created, but do not appear to write ls-l. or have to connect the user via filezilla to ftp folder is created in / home?

thanks,
Reply With Quote
Sponsored Links
  #12  
Old 14th September 2012, 16:38
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Quote:
Originally Posted by user2012 View Post
the user and group are created, but do not appear to write ls-l. or have to connect the user via filezilla to ftp folder is created in / home?

thanks,
Yes, you have to connect with FileZilla. The folder will then be created automatically.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #13  
Old 25th September 2012, 19:19
user2012 user2012 is offline
Junior Member
 
Join Date: Sep 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default

friends, I could not connect to the FTP server, I tested with Windows XP and Seven and the same thing happens. the server is in a LAN.
Reply With Quote
  #14  
Old 26th September 2012, 11:55
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

Any errors messages?

Did you check your firewall settings? Did you try active and passive FTP?
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #15  
Old 20th November 2012, 16:11
babixeddu babixeddu is offline
Junior Member
 
Join Date: Nov 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default Hate this s...stuff

It's very frustrating read all, and at the end... ta tannn where the f*** is your problem? is gone? how did you have solved this problem? eh? eh? Hate this. Hate this.

I've the same problem. I've followed the same tutorial as is, and at the end I can't connect:

- auth.log
Code:
[...] pure-ftpd: pam_unix(pure-ftpd:auth): check pass; user unknown
[...] pure-ftpd: pam_unix(pure-ftpd:auth): authentication failure; logname= uid=0 euid=0 tty=pure-ftpd ruser=exampleuser rhost=dynamic-adsl[...]
- syslog
Code:
[...]  [ERROR] The SQL server seems to be down [Can't connect to local MySQL server through socket '*****/var/run/mysqld/mysqld.sock' (2)]
[...]  [INFO] PAM_RHOST enabled. Getting the peer address
[...]  [WARNING] Authentication failed for user [exampleuser]
[...]  [INFO] Logout.
- /etc/pure-ftpd/db/mysql.conf is the same (naturally I've changed the psw, which contains a special char, can be this?).

- Port 3306 it's closed to the world but the connection is made with the mysql.sock so it's irrelevant. 21 is - naturally - open.

Any thought?

Thanks

---- EDIT ----

It seems to be solved: the problem was on the folder permission and probably on the /etc/pure-ftpd/db/mysql.conf ... So:

1) when copying the code made by falko, it's better to double check if the pasted code is good.
2) I've created an "ftp" folder under /home (so: /home/ftp) and I've assigned the owner with chown root.ftpgroup -R to the ftp folder.
3) I've changed the mysql row:

INSERT INTO `ftpd` (`User`, `status`, `Password`, `Uid`, `Gid`, `Dir`, `ULBandwidth`, `DLBandwidth`, `comment`, `ipaccess`, `QuotaSize`, `QuotaFiles`) VALUES ('exampleuser', '1', MD5('secret'), '2001', '2001', '/home/ftp/www.example.com', '100', '100', '', '*', '50', '0');

- Now I got a timeout error but the user is logged in and the folder is created under /home/ftp.

---- EDIT 2 ----
The timeout error was generated when selecting "Passive mode" from Filezilla. Choosing "Active mode" solves the problem.

Hope it's useful, cheers!

Last edited by babixeddu; 20th November 2012 at 17:55. Reason: adding solution to timeout
Reply With Quote
  #16  
Old 26th March 2013, 17:46
user2012 user2012 is offline
Junior Member
 
Join Date: Sep 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with pureftpd

dear, I did what you explained, but when trying to connect with the user created, reappears me the following information:

Response: 220-Local time is now 12:37. Server port: 21.
Response: 220-This is a private system - No anonymous login
Response: 220-IPv6 connections are Also welcome on this server.
Response: 220 You will be disconnected after 15 minutes of inactivity.
Command: USER peter
Response: 331 User peter OK. Password required
Command: PASS ******
Response: 530 Login authentication failed
Error: Critical error
Error: Could not connect to server

assigning root.ftpgroup chown-R to the ftp folder, writing ls-l, is as follows:

drwxr-xr-x 2 root 4096 Mar 26 12:12 ftp

thanks
Reply With Quote
  #17  
Old 26th March 2013, 20:46
user2012 user2012 is offline
Junior Member
 
Join Date: Sep 2012
Posts: 11
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problem with pureftpd

if I try to connect to a system user, this connects seamlessly. with virtual users is where I can not connect.

if you can help me please.
Reply With Quote
  #18  
Old 29th March 2013, 12:27
mihail mihail is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

hello everyone. I have the same problem as the "user2012".
Mar 29 13:10:26 hosting pure-ftpd: pam_unix(pure-ftpd:auth): check pass; user un known
Mar 29 13:10:26 hosting pure-ftpd: pam_unix(pure-ftpd:auth): authentication fail ure; logname= uid=0 euid=0 tty=pure-ftpd ruser=anonymous rhost=host90-80-dynamic
Reply With Quote
  #19  
Old 8th April 2013, 12:01
mihail mihail is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

here solve the problem with error 503:
edit the file '#vi /etc/fail2ban/filter.d/pureftpd.conf'
change the line: ' failregex = pure-ftpd(?:\[\d+\])?: (.+?@<HOST>) \[WARNING\] %(__errmsg)s \[.+\]$ '
after the change will look like: ' failregex = pure-ftpd(?:\[\d+\])?: (.+?@<HOST>/)) \[WARNING\] %(__errmsg)s \[.+\]$ '
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Basic problem - pureftpd djmostek Installation/Configuration 5 19th July 2012 17:25
Major recovery Toucan Installation/Configuration 18 9th August 2011 11:45
MySQL Error Nolan Installation/Configuration 12 16th February 2011 02:15
postfix/cleanup: warning: virtual_alias_maps map lookup problem penkku Server Operation 1 11th February 2011 13:48
Virtual Hosting With PureFTPd And MySQL quota problem GaulHahn Server Operation 3 29th July 2008 14:32


All times are GMT +2. The time now is 16:47.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.