#1  
Old 23rd August 2012, 22:22
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 194
Thanks: 8
Thanked 15 Times in 7 Posts
Question Redirect problem

Well I have tried Alias-domain, Sub-domain and all combinations there-off and if I don't get a solid error I keep getting the same problem.

My Scenario is this

DNS set = ok pop.domain.tld A IP LITERAL
DNS set = ok www.domain.tld A IP LITERAL

If i set the redirect to my webmail /var/www/webmail
Code:
lrwxrwxrwx  1 root root      16 Aug 23 20:34 webmail -> /var/www/webmail/
I get
Quote:
Not Found

The requested URL /webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/ was not found on this server.
Can you please explain why ISPConfig 3 generate this?

Code:
Subdomain for website

    Domain

Host [pop]
Domain [domain.tld]
Redirect Type [L]
Redirect Path [/webmail]

Active [Y]
Code:
/etc/apache2/sites-available/domain.tld.vhost
Code:
<VirtualHost *:80>
      DocumentRoot /var/www/domain.tld/web

    ServerName domain.tld
    ServerAlias *.domain.tld
    ServerAlias pop.domain.tld
    ServerAdmin webmaster@domain.tld
.
.
.
.
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^pop.domain.tld$ [NC]
        RewriteCond %{REQUEST_URI} !^/webdav/
    RewriteRule   ^/(.*)$ /webmail/$1  [L]

</VirtualHost>
Help - I guess my knowledge of this is not good
Reply With Quote
Sponsored Links
  #2  
Old 23rd August 2012, 22:32
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

The redirect that ispconfig created in the file is correct for the details that you entered in the ispconfig interface. Please explain what you want the redirect to do.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th August 2012, 09:53
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 194
Thanks: 8
Thanked 15 Times in 7 Posts
Default

I simply want users that enter http://pop.domain.tld to go to the http://domain.tld/webmail/src/login.php or http://domain.tld/webmail/ where they can use squirrelmail
http://www.domain.tld and http://domain.tld has web content

It used to work then we re-did the domain.tld website - thereafter it was messed up. We changed it ti SuEXEC and fastCGI for use with Joomla

Why does the directive add so many /webmail's ?

Last edited by Morons; 24th August 2012 at 09:55.
Reply With Quote
  #4  
Old 24th August 2012, 10:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
Default

Quote:
Why does the directive add so many /webmail's ?
You added a loop, so apache adds webmail until the max loop depth is reached.

Change the redirect type to "noflag" and set the redirect path to "http://domain.tld/webmail/"
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #5  
Old 24th August 2012, 14:09
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 194
Thanks: 8
Thanked 15 Times in 7 Posts
Default

Changing to noflag does not remove the loop, where else can the loop get created? What must I search for?
Reply With Quote
  #6  
Old 24th August 2012, 14:12
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lneburg, Germany
Posts: 36,794
Thanks: 840
Thanked 5,612 Times in 4,423 Posts
 
Default

I explained you to change two settings, not just the redirect type. Please reraed post #4.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
postfix/trivial-rewrite digitalage HOWTO-Related Questions 19 13th March 2013 20:02
Sending email issue lezelf Installation/Configuration 15 9th August 2011 12:20
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
ERROR- Connection dropped by imap-server Al1937 Installation/Configuration 10 4th September 2009 22:15


All times are GMT +2. The time now is 20:54.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.