Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd August 2012, 18:50
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 931
Thanks: 16
Thanked 261 Times in 208 Posts
Default Forum submission via return key problem

Hi,

could someone please double check this behaviour:

If a form (like add mail etc) is submitted using the return key the ajax request is sent twice.
This happens at least if the tab focus is on the "Save" button, maybe on input fields, too.

It happens on login too, if you submit using return key (watch firebug console).

Tested with default and default-v2 theme.

Datalog entries are also created twice then.
__________________
Marius Cramer

pixcept KG
Reply With Quote
Sponsored Links
  #2  
Old 23rd August 2012, 20:44
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,202
Thanks: 829
Thanked 5,420 Times in 4,262 Posts
Default

I guess this is caused by line 112 in main.tpl of the default template.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 24th August 2012, 08:34
Croydon Croydon is offline
ISPConfig Developer
 
Join Date: Jul 2007
Location: Koblenz, Germany
Posts: 931
Thanks: 16
Thanked 261 Times in 208 Posts
 
Default

Fixed it in svn for themes default and default-v2.
__________________
Marius Cramer

pixcept KG
Reply With Quote
The Following User Says Thank You to Croydon For This Useful Post:
till (24th August 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 17:58
table lookup problem aurelius Installation/Configuration 5 2nd November 2011 19:12
HELP DNS and DHCP I AM LOST krisarmstrong Server Operation 0 18th August 2009 23:27
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 19:38


All times are GMT +2. The time now is 03:14.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.