Prev Previous Post   Next Post Next
  #1  
Old 23rd August 2012, 22:22
Morons Morons is offline
Senior Member
 
Join Date: Aug 2006
Posts: 189
Thanks: 8
Thanked 15 Times in 7 Posts
Question Redirect problem

Well I have tried Alias-domain, Sub-domain and all combinations there-off and if I don't get a solid error I keep getting the same problem.

My Scenario is this

DNS set = ok pop.domain.tld A IP LITERAL
DNS set = ok www.domain.tld A IP LITERAL

If i set the redirect to my webmail /var/www/webmail
Code:
lrwxrwxrwx  1 root root      16 Aug 23 20:34 webmail -> /var/www/webmail/
I get
Quote:
Not Found

The requested URL /webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/webmail/ was not found on this server.
Can you please explain why ISPConfig 3 generate this?

Code:
Subdomain for website

    Domain

Host [pop]
Domain [domain.tld]
Redirect Type [L]
Redirect Path [/webmail]

Active [Y]
Code:
/etc/apache2/sites-available/domain.tld.vhost
Code:
<VirtualHost *:80>
      DocumentRoot /var/www/domain.tld/web

    ServerName domain.tld
    ServerAlias *.domain.tld
    ServerAlias pop.domain.tld
    ServerAdmin webmaster@domain.tld
.
.
.
.
    RewriteEngine on
    RewriteCond %{HTTP_HOST}   ^pop.domain.tld$ [NC]
        RewriteCond %{REQUEST_URI} !^/webdav/
    RewriteRule   ^/(.*)$ /webmail/$1  [L]

</VirtualHost>
Help - I guess my knowledge of this is not good
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
postfix problems with smtp linkdeb Server Operation 13 15th March 2014 18:58
postfix/trivial-rewrite digitalage HOWTO-Related Questions 19 13th March 2013 20:02
Sending email issue lezelf Installation/Configuration 15 9th August 2011 12:20
Strange email problem for one of my domains... any help appreciated paulrobert_a Installation/Configuration 5 9th August 2010 15:15
ERROR- Connection dropped by imap-server Al1937 Installation/Configuration 10 4th September 2009 22:15


All times are GMT +2. The time now is 04:01.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.