#1  
Old 22nd August 2012, 04:46
Monotoba Monotoba is offline
Member
 
Join Date: May 2009
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Question Help with open_basedir

Hi all,

I am having to rebuild my server manually and I came across an issue. all my Code Igniter sites are receiving an open_basedir error. The sites have the application and system directories set as siblings under the parent web? directory. i.e.:

client?
-web?
--application
--cache
--system
--media
---images
---docs
---files

I am receiving the following error: Message: is_file(): open_basedir restriction in effect.
File(application/modules/index.html/config/routes.php) is not within the allowed path(s): (/var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/[CUT-SITENAME]/web:/srv/www/[CUT-SITENAME]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php)

Filename: MX/Modules.php

Line Number: 369

I have the following line in the PHP open_basedir option: /var/www/clients/client1/web1/web:/var/www/clients/client1/web1/tmp:/var/www/[CUT-SITENAME]/web:/srv/www/[CUT - SITENAME]/web:/usr/share/php5:/tmp:/usr/share/phpmyadmin:/etc/phpmyadmin:/var/lib/phpmyadmin:/usr/share/php

So how do I need to change this to make things work correctly?

Thanks for te help.
Edit/Delete Message

Last edited by Monotoba; 22nd August 2012 at 05:02.
Reply With Quote
Sponsored Links
  #2  
Old 22nd August 2012, 08:49
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
Default

Add the path:

/var/www/clients/client1/web1

separated by : at the end of the open basedir paths on the options tab of the website settings. Then wait a minute until the cahnges are written to disk.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd August 2012, 12:47
Monotoba Monotoba is offline
Member
 
Join Date: May 2009
Posts: 30
Thanks: 0
Thanked 0 Times in 0 Posts
Default

I tried that and it still gives me the same error. I also tried switch php types and adding the apache directory commands to the apache config setcion under Web Domains->Options:

<Directory /var/www/[CUT - SITENAME]/web>
php_admin_flag engine on
php_admin_value open_basedir none
</Directory>

Still no luck....
Reply With Quote
  #4  
Old 22nd August 2012, 13:07
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,083
Thanks: 826
Thanked 5,396 Times in 4,240 Posts
 
Default

Quote:
I tried that and it still gives me the same error.
Where exactly did you change that? You have top changie it under Sites > website > options and not under System > Server config.

Quote:
I also tried switch php types and adding the apache directory commands to the apache config setcion under Web Domains->Options:

<Directory /var/www/[CUT - SITENAME]/web>
php_admin_flag engine on
php_admin_value open_basedir none
</Directory>
This will not work this way. If you wnat to switch the php type, then do that in the website settings.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Tags
code igniter, ispconfig3, open_basedir, php

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT +2. The time now is 18:53.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.