Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 14th August 2012, 21:02
amutu amutu is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default php5-fpm with apache2 on fedora17

Hello,

I'm trying to setup php5-fpm with apache on fedora apache as in the how-to but it's not working for me. From the error log:

[Tue Aug 14 21:53:42 2012] [notice] Digest: generating secret for digest authentication ...
[Tue Aug 14 21:53:42 2012] [notice] Digest: done
[Tue Aug 14 21:53:42 2012] [notice] FastCGI: wrapper mechanism enabled (wrapper: /usr/sbin/suexec)
[Tue Aug 14 21:53:42 2012] [notice] FastCGI: process manager initialized (pid 2458)
[Tue Aug 14 21:53:42 2012] [notice] Apache/2.2.22 (Unix) DAV/2 mod_fastcgi/2.4.6 configured -- resuming normal operations
[Tue Aug 14 21:53:44 2012] [error] [client 127.0.0.1] File does not exist: /usr/lib/cgi-bin/php5-fcgi
[Tue Aug 14 21:53:44 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Tue Aug 14 21:53:44 2012] [error] [client 127.0.0.1] File does not exist: /usr/lib/cgi-bin/php5-fcgi
[Tue Aug 14 21:53:44 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Tue Aug 14 21:53:45 2012] [error] [client 127.0.0.1] File does not exist: /usr/lib/cgi-bin/php5-fcgi
[Tue Aug 14 21:53:45 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Tue Aug 14 21:53:45 2012] [error] [client 127.0.0.1] File does not exist: /usr/lib/cgi-bin/php5-fcgi

Thanks


ps: when i got to localhost/info.php (document root is /var/www/html/) i get this:
"
Not Found
The requested URL /php5-fcgi/info.php was not found on this server."

Why does it search in /php5-fcgi/info.php?

Last edited by amutu; 14th August 2012 at 21:05.
Reply With Quote
Sponsored Links
  #2  
Old 15th August 2012, 14:18
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Make sure that you have
Code:
FastCgiWrapper Off
in /etc/httpd/conf.d/fastcgi.conf.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #3  
Old 15th August 2012, 16:37
amutu amutu is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

doesn't work.
in browser i see this:

Bad Request

Your browser sent a request that this server could not understand.

and in error_log:
[Wed Aug 15 17:34:53 2012] [error] [client 127.0.0.1] Invalid URI in request GET /info.php HTTP/1.1
[Wed Aug 15 17:34:53 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
[Wed Aug 15 17:34:53 2012] [error] [client 127.0.0.1] File does not exist: /var/www/html/favicon.ico
Reply With Quote
  #4  
Old 15th August 2012, 19:26
amutu amutu is offline
Junior Member
 
Join Date: Aug 2012
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default

where is file php5-fcgi coming from? because i'm trying to compile php on my own and i need to know what flag to add to configure....
Reply With Quote
  #5  
Old 16th August 2012, 10:22
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
 
Default

php5-fcgi doesn't exist which is ok.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPConfig 3.0.1.4 causes Apache to have too many open files gkovacs Installation/Configuration 29 27th February 2013 08:59
Apache2 high load lano Server Operation 3 24th December 2011 17:29
yet another apache2 tuning thread Ovidiu Server Operation 65 5th July 2011 15:07
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Upgrade to php 5.2 in suse 10.1 gimhan90 Installation/Configuration 3 1st January 2009 20:32


All times are GMT +2. The time now is 20:08.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.