Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Plugins/Modules/Addons

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
View Poll Results: Would you like to see a mailuser interface for Roundcube & Squirrelmail?
Yes 211 99.06%
No 2 0.94%
Voters: 213. You may not vote on this poll

Reply
 
Thread Tools Display Modes
  #471  
Old 15th August 2012, 19:45
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 324
Thanks: 55
Thanked 93 Times in 58 Posts
Send a message via Skype™ to Horfic
Default

ok, sorry for that.

But there is a ticket in my tracker with the same issue.

http://bugs.web-wack.at/issues/31
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
Sponsored Links
  #472  
Old 22nd August 2012, 14:25
EPMS EPMS is offline
Junior Member
 
Join Date: Aug 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Hello,
i have a problem with the plugin. I updatet my ISPConfig Version with no problems. When i know want to login in roundcube i get an error like "login incorrect". When i disable the plugin everything is ok. I updatet the Plugin also. But no effect.

Where can be my problem?

Thanks for help.
Reply With Quote
  #473  
Old 22nd August 2012, 14:28
Horfic Horfic is offline
Senior Member
 
Join Date: Mar 2009
Location: Austria
Posts: 324
Thanks: 55
Thanked 93 Times in 58 Posts
Send a message via Skype™ to Horfic
Default

FAQ: http://bugs.web-wack.at/documents/3

Code:
Q: After I installed all plugins, I can't login.
A: The autoselect feature is probably activated and the $rcmail_config['default_host'] is not empty. Please refer to step 6 of the install instructions.
So just disable the autoselect plugin
__________________
web wack creations - We create your custom web application
Mailuser interface for ISPConfig 3
Reply With Quote
  #474  
Old 14th September 2012, 18:51
cassus cassus is offline
Junior Member
 
Join Date: Sep 2012
Posts: 10
Thanks: 4
Thanked 2 Times in 2 Posts
Default

I've just installed plugin according to http://bugs.web-wack.at/documents/1
ispc 3.0.4.6.
roundcube 0.7.1.
last version of plugin

but i can't see the "account" tab. Where might be a problem? thanks
Reply With Quote
  #475  
Old 15th September 2012, 13:01
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 132
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Default

i think that last plugin version is for last roundcube version
and your one isn't

but maybe i'm wrong
Reply With Quote
  #476  
Old 15th September 2012, 16:59
cassus cassus is offline
Junior Member
 
Join Date: Sep 2012
Posts: 10
Thanks: 4
Thanked 2 Times in 2 Posts
Default

yes, you were right, I installed last version of roundcube (0.8.1.) and it is OK now. Thanks !

I assumed that 0.7.1. will be ok according to these requirements http://bugs.web-wack.at/documents/2
but it isn't working

Last edited by cassus; 15th September 2012 at 17:12.
Reply With Quote
  #477  
Old 5th December 2012, 05:43
SenseiSimple SenseiSimple is offline
Junior Member
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Soap Error: autoresponder_end_date_isgreater

On the Change Password plugin [ROUNDCUBEDIR/plugins/ispconfig3_pass/ispconfig3_pass.php, on saving the new password, one gets

"Soap Error: autoresponder_end_date_isgreater"

with Roundcube 0.8, ISPconfig 3.0.5Beta1

http://bugs.web-wack.at/issues/37 (i haven't received a confirmation email from registration on the bug tracker)

I created a patch to check if the autoresponder dates aren't 0000's (not set), otherwise, it should all work as normal. I also repositioned the Try/Catch blocks to only include the relevant parts (this could probably be better, i hate repeated code)

Code:
--- ispconfig3_pass.php.old	2012-12-04 22:14:53.000000000 -0600
+++ ispconfig3_pass.php	2012-12-04 22:06:38.000000000 -0600
@@ -63,48 +63,58 @@
 			{
 				try
 				{
-          $soap = new SoapClient(null, array('location' => $this->rcmail_inst->config->get('soap_url').'index.php',
+          			$soap = new SoapClient(null, array('location' => $this->rcmail_inst->config->get('soap_url').'index.php',
 									'uri'      => $this->rcmail_inst->config->get('soap_url')));
 					$session_id = $soap->login($this->rcmail_inst->config->get('remote_soap_user'),$this->rcmail_inst->config->get('remote_soap_pass'));
 					$mail_user = $soap->mail_user_get($session_id, array('login' => $this->rcmail_inst->user->data['username']));
-          
-          $startdate = $mail_user[0]['autoresponder_start_date'];
-          $enddate = $mail_user[0]['autoresponder_end_date'];
-        
-          if (strtotime($startdate) <= time())
-          $startdate = date('Y').'-'.date('m').'-'.date('d').' '.date('H').':'.date('i', time() + 300);
-		
-          $startdate = array('year' => substr($startdate,0,4),
-							'month' => substr($startdate,5,2),
-							'day' => substr($startdate,8,2),
-							'hour' => substr($startdate,11,2),
-							'minute' => substr($startdate,14,2));
-							
-          $enddate = array('year' => substr($enddate,0,4),
-						'month' => substr($enddate,5,2),
-						'day' => substr($enddate,8,2),
-						'hour' => substr($enddate,11,2),
-						'minute' => substr($enddate,14,2));
-
-          $params = $mail_user[0];
-          $params['autoresponder_start_date'] = $startdate;
-          $params['autoresponder_end_date'] = $enddate;
-          $params['password'] = $newpwd;
+//PATCH 12-04-2012 http://bugs.web-wack.at/issues/37 senseisimple - [Soap Error: autoresponder_end_date_isgreater]	
+				}
+				catch (SoapFault $e)
+				{
+					$this->rcmail_inst->output->command('display_message', 'Soap Error: '.$e->getMessage(), 'error');
+				}
+
+				$params = $mail_user[0];
+				$params['password'] = $newpwd;
+				if ( $mail_user[0]['autoresponder_start_date'] != '0000-00-00 00:00:00' ) {
+					$startdate = $mail_user[0]['autoresponder_start_date'];
+					$enddate = $mail_user[0]['autoresponder_end_date'];
+
+					if (strtotime($startdate) <= time())
+					$startdate = date('Y').'-'.date('m').'-'.date('d').' '.date('H').':'.date('i', time() + 300);
+					$startdate = array('year' => substr($startdate,0,4),
+									'month' => substr($startdate,5,2),
+									'day' => substr($startdate,8,2),
+									'hour' => substr($startdate,11,2),
+									'minute' => substr($startdate,14,2));
+
+					$enddate = array('year' => substr($enddate,0,4),
+								'month' => substr($enddate,5,2),
+								'day' => substr($enddate,8,2),
+								'hour' => substr($enddate,11,2),
+								'minute' => substr($enddate,14,2));
 
+					$params['autoresponder_start_date'] = $startdate;
+					$params['autoresponder_end_date'] = $enddate;
+				}
+
+			  	try
+				{
 					$uid = $soap->client_get_id($session_id, $mail_user[0]['sys_userid']);
 					$update = $soap->mail_user_update($session_id, $uid, $mail_user[0]['mailuser_id'], $params);
 					$soap->logout($session_id);
-					
+
 					$this->rcmail_inst->output->command('display_message', $this->gettext('successfullysaved'), 'confirmation');
-					
+
 					$_SESSION['password'] = $this->rcmail_inst->encrypt($newpwd);
-					
+
 					$this->rcmail_inst->user->data['password'] = $_SESSION['password'];
 				}
 				catch (SoapFault $e)
 				{
 					$this->rcmail_inst->output->command('display_message', 'Soap Error: '.$e->getMessage(), 'error');
 				}
+//END PATCH 12-4-2012
 			}
 		}
 		$this->init_html();
@@ -154,4 +164,4 @@
 		return $out;
 	}
 }
-?>
\ No newline at end of file
+?>

Last edited by SenseiSimple; 5th December 2012 at 06:21.
Reply With Quote
  #478  
Old 7th December 2012, 02:01
gapa gapa is offline
Junior Member
 
Join Date: Nov 2011
Posts: 7
Thanks: 2
Thanked 0 Times in 0 Posts
Default

Thanks for looking into this. But I have problems with applying your patch. Am I doing something wrong?

br,
gapa
Reply With Quote
  #479  
Old 7th December 2012, 02:41
SenseiSimple SenseiSimple is offline
Junior Member
 
Join Date: Dec 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by gapa View Post
Thanks for looking into this. But I have problems with applying your patch. Am I doing something wrong?

br,
gapa
I patched against the latest SVN version, i believe there were changes from what's downloadable on the site and what's in SVN,


svn co http://svn.web-wack.at/ispconfig3_roundcube3/trunk/ .

http://www.howtoforge.com/forums/sho...9&postcount=20
look at the Update section of the first part, try the svn up . command in the plugins directory (though i suspect it will have to have been loaded from the svn in the first place... If you haven't made any modifications, just pull it all from svn (backing up your account login info file first)

ROUNDCUBEDIR/plugins/ispconfig3_account/config/config.inc.php

then apply the patch

let me know if still doesn't work, i'll generate the patch again.

Last edited by SenseiSimple; 7th December 2012 at 02:43.
Reply With Quote
  #480  
Old 7th December 2012, 08:57
brainkiller2000 brainkiller2000 is offline
Junior Member
 
Join Date: Jul 2005
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default

@SenseiSimple

The patch does not work for me. I updadet to the last svn of the ipsconfig plugin files.

I got the following errors:
Code:
File to patch: ispconfig3_pass.php
patching file ispconfig3_pass.php
Hunk #1 FAILED at 63.
patch unexpectedly ends in middle of line
patch: **** malformed patch at line 93:
Thanks in advance or helping!
Reply With Quote
Reply

Bookmarks

Tags
interface, ispconfig 3, mail, roundcube, squirrelmail, webmail

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ffmpeg Video support for ubuntu 7.10 [suphp-ispconfig] amaurib Installation/Configuration 13 16th February 2010 17:26
Debian Lenny: waiting for interface eth0:1 before doing NFS mounts (warning) edge Installation/Configuration 2 9th June 2009 07:55
IPtables rule to let PPTP access LAN brianwebb01 Installation/Configuration 0 1st May 2008 21:23
How to create a dhcp server for intranet (with multi-homed alias)? zenny HOWTO-Related Questions 8 29th February 2008 15:16
No DHCP on second LAN interface DrJohn Server Operation 2 8th November 2007 02:58


All times are GMT +2. The time now is 17:48.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.