Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Server Operation

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 29th July 2012, 21:20
rygotype rygotype is offline
Junior Member
 
Join Date: Mar 2010
Posts: 7
Thanks: 1
Thanked 1 Time in 1 Post
Default Failed to authenticate with pure-ftpd on CentOS 5.8 (32bit) running ispconfig3

I asked this question late last night about how I can get the latest PHP, MySQL, and phpmyadmin on my 32bit installation of CentOS 5.8.

I was able to get PHP and MySQL back up and running successfully. I was unable to get phpmyadmin3 working, but phpmyadmin2 is still running like a champ. That's another can of worms.

However, during the process, my pure-ftpd was removed. I reinstalled it after the new PHP and MySQL were installed by running:

Code:
yum install pure-ftpd 

chkconfig --levels 235 pure-ftpd on
/etc/init.d/pure-ftpd start
However, now I am getting authentication errors. My ispconfig3 database still exists and my ftp users are still in the proper db table for ispconfig3.
Code:
Status: Connection established, waiting for welcome message...
Response:   220---------- Welcome to Pure-FTPd [privsep] [TLS] ----------
Response:   220-You are user number 1 of 50 allowed.
Response:   220-Local time is now 12:29. Server port: 21.
Response:   220-This is a private system - No anonymous login
Response:   220-IPv6 connections are also welcome on this server.
Response:   220 You will be disconnected after 15 minutes of inactivity.
Command:    USER test_ftp
Response:   331 User test_ftp OK. Password required
Command:    PASS ********
Response:   530 Login authentication failed
Error:  Critical error
Error:  Could not connect to server
Log file shows this message:

Code:
[ERROR] The SQL server seems to be down [Host '127.0.0.1' is not allowed to connect to this MySQL server]
To actually formulate a question, How can I fix this authentication issue?
Reply With Quote
Sponsored Links
  #2  
Old 30th July 2012, 02:03
rygotype rygotype is offline
Junior Member
 
Join Date: Mar 2010
Posts: 7
Thanks: 1
Thanked 1 Time in 1 Post
 
Default

To anyone who may encounter this same situation, I have found a solution. Not exactly sure WHY this simple small change would solve my problem. Don't 127.0.0.1 and localhost mean the same thing? If anyone could provide a better solution, allowing for both 127.0.0.1 AND localhost, that would be greatly appreciated. I'm just glad my ftp server works again.

Edit the pureftpd-mysql.conf file

Code:
vi /etc/pure-ftpd/pureftpd-mysql.conf
Changed this:

Code:
MYSQLServer     127.0.0.1
To this:
Code:
MYSQLServer     localhost
Reply With Quote
The Following User Says Thank You to rygotype For This Useful Post:
falko (30th July 2012)
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ioncube install kwickcut Installation/Configuration 6 17th May 2013 22:00
vlogger (problem) cusco General 3 7th May 2012 16:32
Centos 5.2 + ISPConfig 3 tutorial - Problem with email tanakskool Server Operation 1 3rd June 2009 17:22
Freebsd 6.1 support misterm Installation/Configuration 10 9th April 2009 10:29
High Availability Samba cluster - DRBD + Heartbeat djalex Server Operation 58 25th May 2007 20:38


All times are GMT +2. The time now is 20:59.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.