Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th July 2012, 00:18
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Default Problem while update

Hey,

I run ispconfig_update.sh command and after selecting stable and yes for backup its stop at this http://cl.ly/ILnj if I select stable and no for backup its stop too. ISPconfig now dont working and I cant update. Someone can help me? Thanks
Reply With Quote
Sponsored Links
  #2  
Old 27th July 2012, 00:32
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Default

I updated because monitor in ispconfig not work and today if created database its shows in ispconfig but I cant login in to it in phpmyadmin. Thanks for support.
Reply With Quote
  #3  
Old 27th July 2012, 01:15
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Default

Ok i found in install log this, perhaps it will help.

HTML Code:
Fri Jul 27 01:06:04 CEST 2012 - [ISPConfig] - /tmp/ispconfig3_install/install/lib/update.lib.php, Line 38: read in ispconfig3.sql
Reply With Quote
  #4  
Old 27th July 2012, 08:07
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

This is ost likely a issue with the shell, the script is not stopped,you just dont see the cursor prompt. Please press return.

Quote:
I updated because monitor in ispconfig not work and today if created database its shows in ispconfig but I cant login in to it in phpmyadmin. Thanks for support.
The most likely reason is that your mysql root password has been changed and you did not set the new root password in /usr/local/ispconfig/server/lib/mysql_clientdb.conf. This can also be the resaon for your update problem. You might also want to check your php.ini file if there are any functions disabled.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
MichalCerny (27th July 2012)
  #5  
Old 27th July 2012, 10:32
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Default

If i press enter its do nothing http://cl.ly/INp6 what about the error in ispconfig_install.log?

Fri Jul 27 10:29:27 CEST 2012 - [ISPConfig] - /tmp/ispconfig3_install/install/lib/update.lib.php, Line 38: read in ispconfig3.sql
Reply With Quote
  #6  
Old 27th July 2012, 10:57
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Default

Ok I changed db user and password in usr/local/ispconfig/server/lib/config.php to db user and password same in usr/local/ispconfig/server/lib/mysql_clientdb.conf and now after backup in update its type this

mysqldump: Got error: 23: Out of resources when opening file './dbispconfig/web_folder.MYD' (Errcode: 24) when using LOCK TABLES
Checking ISPConfig database ..

ispconfig_install.log still type
Fri Jul 27 10:50:01 CEST 2012 - [ISPConfig] - /tmp/ispconfig3_install/install/lib/update.lib.php, Line 38: read in ispconfig3.sql

any suggestions, help? Thanks
Reply With Quote
  #7  
Old 27th July 2012, 11:31
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Quote:
Ok I changed db user and password in usr/local/ispconfig/server/lib/config.php to db user and password same in usr/local/ispconfig/server/lib/mysql_clientdb.conf and now after backup in update its type this
Thats not a god idea, please undo that before your setup gets broken. The file /usr/local/ispconfig/server/lib/config.php may never contain the root user and password.

Quote:
mysqldump: Got error: 23: Out of resources when opening file './dbispconfig/web_folder.MYD' (Errcode: 24) when using LOCK TABLES
Checking ISPConfig database ..
This indicates a resource problem, e.g. a full harddisk. Please post the output of:

df -h

and run a repair in phpmyadmin on all tables in the dbispconfig database.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
MichalCerny (27th July 2012)
  #8  
Old 27th July 2012, 11:36
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
Default

Quote:
Originally Posted by till View Post
Thats not a god idea, please undo that before your setup gets broken. The file /usr/local/ispconfig/server/lib/config.php may never contain the root user and password.

This indicates a resource problem, e.g. a full harddisk. Please post the output of:

df -h
and run a repair in phpmyadmin on all tables in the dbispconfig database.
Filesystem Size Used Avail Use% Mounted on
/dev/sda2 59G 2.3G 54G 5% /
tmpfs 1004M 0 1004M 0% /dev/shm
/dev/sda1 291M 45M 232M 17% /boot
Reply With Quote
  #9  
Old 27th July 2012, 11:42
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,461
Thanks: 813
Thanked 5,240 Times in 4,108 Posts
Default

Ok. And what about the database check?

And please post the output of the command:

free
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #10  
Old 27th July 2012, 11:45
MichalCerny MichalCerny is offline
Junior Member
 
Join Date: Jul 2012
Posts: 9
Thanks: 2
Thanked 1 Time in 1 Post
 
Default

I have problem now I backup back the config.php file and cant access to phpmyadmin type "#2002 - The server is not responding (or the local MySQL server's socket is not correctly configured)"

and error log in httpd types .. kill me now I'm idiot

[Fri Jul 27 11:39:27 2012] [notice] caught SIGTERM, shutting down
[Fri Jul 27 11:39:28 2012] [notice] suEXEC mechanism enabled (wrapper: /usr/sbin/suexec)
[Fri Jul 27 11:39:28 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jul 27 11:39:28 2012] [warn] RSA server certificate CommonName (CN) `31.31.7.6' does NOT match server name!?
[Fri Jul 27 11:39:28 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
panic: fold_constants JMPENV_PUSH returned 2 at /usr/local/ispconfig/server/scripts/vlogger line 229.
[Fri Jul 27 11:39:28 2012] [notice] Digest: generating secret for digest authentication ...
[Fri Jul 27 11:39:28 2012] [notice] Digest: done
DBI connect('database=dbispconfig;host=localhost:3306' ,'ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /usr/local/ispconfig/server/scripts/vlogger line 257
[Fri Jul 27 11:39:28 2012] [warn] RSA server certificate is a CA certificate (BasicConstraints: CA == TRUE !?)
[Fri Jul 27 11:39:28 2012] [warn] RSA server certificate CommonName (CN) `31.31.7.6' does NOT match server name!?
[Fri Jul 27 11:39:28 2012] [warn] Init: Name-based SSL virtual hosts only work for clients with TLS server name indication support (RFC 4366)
[Fri Jul 27 11:39:28 2012] [notice] Apache/2.2.15 (Unix) DAV/2 mod_fcgid/2.3.6 PHP/5.3.2 mod_ruby/1.3.0 Ruby/1.8.7(2010-06-23) mod_ssl/2.2.15 OpenSSL/1.0.0-fips configured -- resuming normal operations
DBI connect('database=dbispconfig;host=localhost:3306' ,'ispconfig',...) failed: Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2) at /usr/local/ispconfig/server/scripts/vlogger line 514
DBI Error: at /usr/local/ispconfig/server/scripts/vlogger line 514, <STDIN> line 2.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ispconfig 3 update problem qiubosu Installation/Configuration 1 16th September 2011 08:42
Virtual Users And Domains With Postfix, Courier, MySQL And SquirrelMail -Ubuntu 8.04 c4rdinal HOWTO-Related Questions 112 23rd August 2011 10:49
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
sending e-mail using mail() function linuxuser1 HOWTO-Related Questions 38 21st April 2009 12:20
php4 problem after update Aloa Installation/Configuration 2 14th February 2008 12:23


All times are GMT +2. The time now is 21:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.