#1  
Old 21st July 2012, 17:29
Anand_47 Anand_47 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default suphp not working

I am trying to compile lamp server with suphp. I installed all of it and i am getting php info page with normal apache handler but when i try to use suphp i am getting errors with libmysqlclient.so.18 cannot open shared object no such file or directory i am using mysql 5.5 php 5.4 and apache 2.2 . I installed sql server in /sql directory .i can see /sql/lib/libmysqlclient.so.18.0.0 .But why it is not working .Anyone please help me out thanx
Reply With Quote
Sponsored Links
  #2  
Old 21st July 2012, 18:18
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 18 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

probably can't find the lib because it's not in the standard location like /lib/ or /usr/lib/
you should create a symlink for the library in one of this dirs usally /usr/lib/ or /usr/lib/mysql/

Code:
for file in $(ls /sql/lib/ | grep libmysqlclient.so); do ln -s /sql/lib/$file /usr/lib/$file; done
Reply With Quote
The Following User Says Thank You to TiTex For This Useful Post:
Anand_47 (21st July 2012)
  #3  
Old 22nd July 2012, 15:41
Anand_47 Anand_47 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default suphp

I did the same thing but its not working i created symbolic links to /usr/lib/mysql
in the directory libmysqlclient.so.16 and some other files present .But still I am getting errors..Check my error log screen shots Thanks for quick replay..
Attached Images
 
Reply With Quote
  #4  
Old 22nd July 2012, 15:58
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 18 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

what linux distribution are you using ?
is it a 32bit or 64bit distribution ?
can you also post the link for the howto you followed ?
also what is the output of ls -l /usr/lib/ | grep libmysqlclient.so && ls -l /usr/lib/mysql
Reply With Quote
The Following User Says Thank You to TiTex For This Useful Post:
Anand_47 (24th July 2012)
  #5  
Old 23rd July 2012, 11:07
Anand_47 Anand_47 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default suphp

Yes here it is i am using cenos 6 32-bit edition i listed /usr/lib but i didnt get any output probably nothing in there here m posting my /usr/lib/mysql and /sql/lib directory thanks for your posts bro..
Attached Images
  
Reply With Quote
  #6  
Old 23rd July 2012, 11:15
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 18 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

run these commands as i posted them one by one, just copy/paste in a ssh terminal
Code:
rm -f /usr/lib/mysql/libmysqlclient.so
rm -f /usr/lib/mysql/libmysqlclient.so.18
rm -f /usr/lib/mysql/libmysqlclient.so.18.0.0
for file in $(ls /sql/lib/ | grep libmysqlclient.so); do ln -s /sql/lib/$file /usr/lib/mysql/$file; done
and try again after that , if still not working post again the content of
Code:
ls -l /usr/lib/mysql
Reply With Quote
  #7  
Old 24th July 2012, 10:43
Anand_47 Anand_47 is offline
Junior Member
 
Join Date: Jun 2012
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
 
Default suphp not working

I am still getting same error i think my os damaged have to reinstall or something
i was getting same error when i try to install fastcgi also.linux sometimes so hard like this unknown things sorry for my bad english thanks for your support
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
suphp not working Anand_47 Installation/Configuration 0 15th June 2012 13:07
my site not working busykid Installation/Configuration 1 27th September 2011 10:55
my site not working busykid Installation/Configuration 1 26th September 2011 20:39
suPHP not working my PHP pages give a 500 error floweringmind Server Operation 1 13th April 2009 06:24
suPHP not working lazat Server Operation 1 18th June 2006 20:00


All times are GMT +2. The time now is 04:56.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.