Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 23rd July 2012, 00:16
carlosmay carlosmay is offline
Junior Member
 
Join Date: Apr 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default Problem trying to reload apache

The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) - Page 6

/etc/init.d/apache2 reload

Syntax error on line 6 of /etc/apache2/conf.d/aquirrelmail.conf:
Invalid command 'AddTypeapplication/x-httpd-php.php', perhaps misspelles or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
...fail!


thanks for you help
Reply With Quote
Sponsored Links
  #2  
Old 23rd July 2012, 01:19
rosehosting rosehosting is offline
Member
 
Join Date: Jun 2012
Posts: 39
Thanks: 0
Thanked 7 Times in 6 Posts
Default

Quote:
Originally Posted by carlosmay View Post
The Perfect Server - Ubuntu 12.04 LTS (Apache2, BIND, Dovecot, ISPConfig 3) - Page 6

/etc/init.d/apache2 reload

Syntax error on line 6 of /etc/apache2/conf.d/aquirrelmail.conf:
Invalid command 'AddTypeapplication/x-httpd-php.php', perhaps misspelles or defined by a module not included in the server configuration
Action 'configtest' failed.
The Apache error log may have more information.
...fail!


thanks for you help

it looks like you have a (real) syntax error on line 6 in your /etc/apache2/conf.d/aquirrelmail.conf file and it also looks like you are missing mod_php module ....

as suggested by the output, what is apache's error log file saying about this?

also can you post your '/etc/apache2/conf.d/aquirrelmail.conf' file?
Reply With Quote
  #3  
Old 23rd July 2012, 01:54
carlosmay carlosmay is offline
Junior Member
 
Join Date: Apr 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

i get this problem after edit this file also as you ask here it is

vi /etc/apache2/conf.d/squirrelmail.conf
Attached Images
 
Reply With Quote
  #4  
Old 23rd July 2012, 02:15
rosehosting rosehosting is offline
Member
 
Join Date: Jun 2012
Posts: 39
Thanks: 0
Thanked 7 Times in 6 Posts
Default

you have a typo on line 6 between 'AddType' and 'application/x-httpd-php' and '.php'. It should be:

Quote:
AddType application/x-httpd-php .php
Reply With Quote
  #5  
Old 23rd July 2012, 02:58
carlosmay carlosmay is offline
Junior Member
 
Join Date: Apr 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Just Coping and pasting a reply, I find out that when you do that you can see how really the txt should be, because on the manual this txt was red and all underlined wich was difficult to understand

Quote:
[...]
<Directory /usr/share/squirrelmail>
Options FollowSymLinks
<IfModule mod_php5.c>
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .
php_admin_value upload_tmp_dir /var/lib/squirrelmail/tmp
php_admin_value open_basedir /usr/share/squirrelmail:/etc/squirrelmail:/var/lib/squirrelmail:/etc/hostname:/etc/mailname:/var/spool/squirrelmail
php_flag register_globals off
</IfModule>
<IfModule mod_dir.c>
DirectoryIndex index.php
</IfModule>
# access to configtest is limited by default to prevent information leak
<Files configtest.php>
order deny,allow
deny from all
allow from 127.0.0.1
</Files>
</Directory>
[...]
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sending mails: fine > recive: bad Moundy General 1 20th June 2012 00:40
Courier Imap is not working HellMind General 5 12th April 2012 02:04
Problem with apache dejan.b Installation/Configuration 2 11th May 2010 16:34
PHP5 + Apache + mpm_worker fcgid problem kipikipi Server Operation 2 2nd February 2010 16:16
Centos 4.4 32bit Hangs, High Server load 3cwired_com Server Operation 11 16th November 2006 16:47


All times are GMT +2. The time now is 03:41.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.