Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Developers' Forum

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
 
 
Thread Tools Display Modes
Prev Previous Post   Next Post Next
  #1  
Old 17th July 2012, 12:04
teves teves is offline
Senior Member
 
Join Date: Oct 2006
Posts: 149
Thanks: 27
Thanked 13 Times in 10 Posts
Default Migrating to ISPC3 from other panels (here: Ispconfig 2)

Hello,

I am writing a skript for migrating ISPConfig2 to ISPConfig3.
While programming I have found a few issues that prevent me from getting on with the project.

At this moment, the script can read resellers and clients from ISPConfig2 and create them in ISPConfig3. Technically, I read directly from the ISPConfig2 database and use the remote api of ISPConfig3 to create the clients. I create both resellers and clients with the client_add function, and with clients I set the $reseller_id of the function to assign clients to the parent resellers.

But this does not work properly. As far as I can tell from the created database entries, everything worked fine regarding the assignment of clients and resellers. When I log in as admin, I see all created clients and resellers. But when I log in as a reseller, I do not have a client tab and can see no clients.
First I thought the assignment had gone wrong, but when whenever I try to delete the reseller as admin, ISPConfig3 tells me that the reseller has clients, and I have to delete these first.

Any hints what I might be doing wrong?

Another thing I noticed is that with the api creation of clients no id_rsa and ssh_rsa values are created in the database. Also, the created_at value cannot be written it seems.


Regards, Tom
Reply With Quote
Sponsored Links
 

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
ISPconfig 3: can't send or receive messages zogthegreat Installation/Configuration 6 22nd May 2010 14:45
Loads of mysql connections to dbispconfig StrikerNL General 2 5th March 2009 14:31
ISPConfig installation into multiple OpenVZ containers letezo Installation/Configuration 11 3rd March 2009 22:47
Migrating from Virtualmin to ISPConfig xare Installation/Configuration 3 16th July 2006 12:58
SP-Server Setup - Ubuntu 5.10 "Breezy Badger" - Page 6 (changes) LuisC-SM HOWTO-Related Questions 0 21st April 2006 15:16


All times are GMT +2. The time now is 06:37.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.