Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th July 2012, 15:11
Nap Nap is offline
Senior Member
 
Join Date: Oct 2006
Posts: 143
Thanks: 8
Thanked 1 Time in 1 Post
Default ISPConfig uses Localhost settings, VHosts instead through Apache Directive

Hi,
I'm trying to make the ISPConfig page available to my clients via their own domain name. So far I've been able to do it, but not as elegantly as I would like.

If they use the correct url, https://mydomain:ISPConfig_Port, it works fine. However, if they forget to enter the 's' and type http://mydomain:ISPConfig_Port Apache returns an error. Which is exactly what I want. (Not looking for a redirect here. They just gotta get it right.)

However, in the error page, I get references to webmaster@localhost (as ServerAdmin) and the hostname.domain.int (ServerName) as links within the error message.

After investigation, I realised there is only one virtualhost entry for the ISPConfig in sites-enabled, and though the various domain names I'm hosting all work (they point to the same machine) the daemon is owned by the localhost. Hence my clients see the localhost address instead of their own.

I am thinking that I could change that behaviour by putting a virtualhost entry into the Apache Directives for ISPConfig in each of the client's domain options page and setting the server parameters this way.

Has anyone done this in their install?

For the moment, I'm just going to change the error messages to not mention emails and domains.

Cheers,
Nap
Reply With Quote
Sponsored Links
  #2  
Old 17th July 2012, 09:29
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,486
Thanks: 813
Thanked 5,255 Times in 4,121 Posts
 
Default

You are mixing up port based and namebased vhosts here. The ispconfig vhost is a port based vhost and not a namebesed vhost, for a port based vhost, there exists only one for all domains and not one for every domain. The port based vhost uses the fqdn server name (and not localhost) as hostname. If your server sues localhost, then you entered a wrong hostname during server installation.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Version 1.3 of the ISPConfig 3 Manual is finally available! falko General 44 2nd December 2011 12:04
Mail Not Working midcarolina Installation/Configuration 11 2nd October 2011 15:40
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Proftpd + MySQL virtual users, can't connect geekman HOWTO-Related Questions 28 27th September 2010 18:03
External Email Getting Lost jash General 10 8th November 2005 21:55


All times are GMT +2. The time now is 17:29.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.