Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 16th July 2012, 23:09
aheschel aheschel is offline
Junior Member
 
Join Date: Jul 2012
Posts: 1
Thanks: 0
Thanked 0 Times in 0 Posts
 
Default MySQL replication with SSL on Centos6

Easy question. Not super familar with mysql yet but can't figure out how to debug a setup of two mysql instance with ssl replication. It works randomly and all the basic commands show that it working. Have the info below and of cource I can connect to both boxes from each other, the firewall is open to 3306 on each machine and etc. Have tested this but status windows show it working but when I manually change something in mysqlworkbench sometimes I see the change being replicated and then sometimes after say a reboot, with insuring that the slave is started through mysqladmin, it just stops working when I am testing it. My question is I can't seem to figure out what logs would show me what is happening between these two servers. Need to figure out if the ssl is doing its handshack and the slave is connection to the *.bin files to see what has changes and etc. Any help on how I can debug would be greatly appreciated.

current slave status
*************************** 1. row ***************************
Slave_IO_State: Waiting for master to send event
Master_Host: server.seersoft.co
Master_User: slave_user
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mysql-bin.000018
Read_Master_Log_Pos: 106
Relay_Log_File: mysqld-relay-bin.000042
Relay_Log_Pos: 251
Relay_Master_Log_File: mysql-bin.000018
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
Replicate_Do_DB: test,test_gui,test_gui_copy
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 106
Relay_Log_Space: 552
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: Yes
Master_SSL_CA_File: /etc/mysql/newcerts/ca-cert.pem
Master_SSL_CA_Path:
Master_SSL_Cert: /etc/mysql/newcerts/client-cert.pem
Master_SSL_Cipher:
Master_SSL_Key: /etc/mysql/newcerts/client-key.pem
Seconds_Behind_Master: 0
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 0
Last_SQL_Error:
1 row in set (0.00 sec)

current master staus
*************************** 1. row ***************************
Slave_IO_State: Waiting for master to send event
Master_Host: server.seersoft.co
Master_User: slave_user
Master_Port: 3306
Connect_Retry: 60
Master_Log_File: mysql-bin.000018
Read_Master_Log_Pos: 106
Relay_Log_File: mysqld-relay-bin.000042
Relay_Log_Pos: 251
Relay_Master_Log_File: mysql-bin.000018
Slave_IO_Running: Yes
Slave_SQL_Running: Yes
Replicate_Do_DB: test,test_gui,test_gui_copy
Replicate_Ignore_DB:
Replicate_Do_Table:
Replicate_Ignore_Table:
Replicate_Wild_Do_Table:
Replicate_Wild_Ignore_Table:
Last_Errno: 0
Last_Error:
Skip_Counter: 0
Exec_Master_Log_Pos: 106
Relay_Log_Space: 552
Until_Condition: None
Until_Log_File:
Until_Log_Pos: 0
Master_SSL_Allowed: Yes
Master_SSL_CA_File: /etc/mysql/newcerts/ca-cert.pem
Master_SSL_CA_Path:
Master_SSL_Cert: /etc/mysql/newcerts/client-cert.pem
Master_SSL_Cipher:
Master_SSL_Key: /etc/mysql/newcerts/client-key.pem
Seconds_Behind_Master: 0
Master_SSL_Verify_Server_Cert: No
Last_IO_Errno: 0
Last_IO_Error:
Last_SQL_Errno: 0
Last_SQL_Error:
1 row in set (0.00 sec)


All looks good, especially the slave IO and SQL yes yes and the position and bin number match. Should work.
Reply With Quote
Sponsored Links
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Need help with ISPConfig 3 Update midcarolina Installation/Configuration 36 8th November 2011 22:07
CPU load locks up box. Apache or MYSQL related. crypted General 61 29th October 2010 22:16
How To Set Up MySQL Database Replication With SSL Encryption On CentOS 5.4 mstalnaker HOWTO-Related Questions 1 7th October 2010 15:12
ISPConfig3 Mail Warn Errors reason8 General 3 25th November 2009 13:58
Management/system config/settings & /server/settings not working!! dactor Installation/Configuration 9 6th February 2008 09:11


All times are GMT +2. The time now is 05:49.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.