Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 6th July 2012, 10:08
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Name resolution is not working correctly on your server or you changed your mysql configuratio so that it does not listen to localhost anymore. Check your /etc/hosts file to ensure that it contains the line:

127.0.0.1 localhost

and ccheck your mysql config to ensure that mysql listens on all interfaces.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
m4l41k4t (10th July 2012)
Sponsored Links
  #12  
Old 6th July 2012, 12:02
m4l41k4t m4l41k4t is offline
Member
 
Join Date: May 2012
Posts: 32
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Not intend to apologize in advance for the double post, but since reading the above problem and the solution re-install ISPConfig. But because I am afraid to reinstall ISPConfignya think could be done with the upgrade version but not as well.

Previously the problem is when I access the ISPConfig web hosting and web access to ISPConfig (https://XXXX:8080) appears an error like this "Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 ".

Then in / etc / mysql / my.cnf I add the following line "max_connections = 500" and the above error is not there anymore.
But when I try to test send email can not and appear error like my previous post.


and for your advice before I check should have been:

root@test:~# cat /etc/hosts
127.0.0.1 localhost
113.XXX.XXX.XXX dummy.example.net
124.XXX.XXX.XXX test.dummy.example.net test

# The following lines are desirable for IPv6 capable hosts
::1 ip6-localhost ip6-loopback
fe00::0 ip6-localnet
ff00::0 ip6-mcastprefix
ff02::1 ip6-allnodes
ff02::2 ip6-allrouters
root@test:~#


root@test:~# grep bind-address /etc/mysql/my.cnf
#bind-address = 127.0.0.1
root@test:~#

What should I do this again so I can finish the problem?



UPDATED:


now I'm watching is no more error as before.
But when I try to send a test email sent but not entered in the Mail Inbox.

I try to telnet port 25 from the cmd very long response and then drop out:
220 test.dummy.example.net ESMTP (Network)
421 4.4.2 test.dummy.wanxp.net Error: timeout exc

Connection to host lost.

C:\Documents and Settings\Administrator>


and very many activity from mail.log
Jul 6 05:40:36 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/smtpd[13598]: disconnect from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/cleanup[12320]: 11F7ED114EA: message-id=<34094546.698x650812188s>
Jul 6 05:40:37 test postfix/smtpd[13598]: warning: hostname mvx-201-76-189-3.mundivox.com does not resolve to address 201.76.189.3: Name or service not known
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13019]: 0E68FD110D3: client=unknown[83.111.172.202]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[218.93.235.35]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: lost connection after CONNECT from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[210.17.221.25]

Last edited by m4l41k4t; 6th July 2012 at 12:43.
Reply With Quote
  #13  
Old 6th July 2012, 12:41
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,733
Thanks: 840
Thanked 5,597 Times in 4,407 Posts
Default

Quote:
Previously the problem is when I access the ISPConfig web hosting and web access to ISPConfig (https://XXXX:8080) appears an error like this "Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 Warning: mysql_connect (): Too many connections in / usr / local / ISPConfig / interface / lib / classes / db_mysql.inc.php on line 76 ".
Ok,so your connection Limit is too low:

set:

max_connections = 500
max_user_connections = 500

in postfix my.cnf in the [mysqld] section and restart mysql.

Then check the file /etc/resolv.conf and ansure that all dns servers listed there exist and are reachable from your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
The Following User Says Thank You to till For This Useful Post:
m4l41k4t (10th July 2012)
  #14  
Old 6th July 2012, 13:06
m4l41k4t m4l41k4t is offline
Member
 
Join Date: May 2012
Posts: 32
Thanks: 11
Thanked 0 Times in 0 Posts
Default

in the file / etc / mysql / my.cnf I have add the following line:
max_connections = 500
max_user_connections = 500

in the file /etc/resolv.conf
nameserver 8.8.8.8
nameserver 8.8.4.4

And after that there is no more error as before.

but after that it now

But when I try to send a test email sent but not entered in the Mail Inbox.

I try to telnet port 25 from the cmd very long response and then drop out:
220 test.dummy.example.net ESMTP (Network)
421 4.4.2 test.dummy.example.net Error: timeout exc

Connection to host lost.

C:\Documents and Settings\Administrator>


and very many activity from mail.log, in tail -f /var/log/mail.log

Jul 6 05:40:36 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/smtpd[13598]: disconnect from unknown[180.211.163.108]
Jul 6 05:40:36 test postfix/cleanup[12320]: 11F7ED114EA: message-id=<34094546.698x650812188s>
Jul 6 05:40:37 test postfix/smtpd[13598]: warning: hostname mvx-201-76-189-3.mundivox.com does not resolve to address 201.76.189.3: Name or service not known
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13019]: 0E68FD110D3: client=unknown[83.111.172.202]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[218.93.235.35]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: lost connection after CONNECT from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13338]: disconnect from unknown[202.69.40.174]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[201.76.189.3]
Jul 6 05:40:37 test postfix/smtpd[13338]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from ns3.s-dns.de[66.113.136.93]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from 189-83-29-161.user.veloxzone.com.br[189.83.29.161]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: lost connection after CONNECT from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: disconnect from unknown[213.230.21.98]
Jul 6 05:40:37 test postfix/smtpd[13598]: connect from unknown[210.17.221.25]
Reply With Quote
  #15  
Old 8th July 2012, 04:57
m4l41k4t m4l41k4t is offline
Member
 
Join Date: May 2012
Posts: 32
Thanks: 11
Thanked 0 Times in 0 Posts
Default

because still not normal I try to test this also apt-get update and apt-get upgrade on my ubuntu machine.
And also because I have seen in the menu "Monitor" like this:

ISPConfig 3.0.4.6
State: info (0 unknown, 0 info, 2 warning, 0 critical, 0 error)
ok:
The state of your Hard-Disk space is ok [More...]
Your Mail queue load is ok [More...]
Your RAID is ok [More...]
Your Server load is ok [More...]
All needed services are online [More...]
The System Log is O.K. [More...]

warning:
Your virus protection is OUTDATED! [More...]
One or more components needs an update [More...]

but when I get to step apt-get upgrade I found a massive this, is this a problem or not?

or should I uninstall / install again to "Postfix, amavisd-new, SpamAssassin, And Clamav" and whether in this way there is a negative-effect with the email that has been previously dicreate?


clamav (0.97.5+dfsg-1) unstable; urgency=medium

This release of clamav no longer ships signature files in clamav-base so
no signatures are available until after freshclam has run and downloaded
them. This is an upstream change.

-- Scott Kitterman <scott@kitterman.com> Fri, 15 Jun 2012 11:39:26 -0400

/tmp/tmpBagrWi (END)

Last edited by m4l41k4t; 8th July 2012 at 05:03.
Reply With Quote
  #16  
Old 8th July 2012, 08:58
m4l41k4t m4l41k4t is offline
Member
 
Join Date: May 2012
Posts: 32
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Updated:

I have tried to uninstall and install Clamav and has been updated.
I see from mailog (/ var / log / mail.log) is very much like spam email activity within 20 seconds was more than 1121 Kbytes in 204 Requests in the Mail Queue.
Is it because many of these activities that cause I can not send and receive email?
I've tried to delete the Mail Queue with the command "postsuper-d ALL" and deleted but there is always more.
Shortly after I tried to remove and test send / receive email could not be fixed.

And how to reduce the activity of this spam on my server?

Thanks

Last edited by m4l41k4t; 8th July 2012 at 09:02.
Reply With Quote
  #17  
Old 8th July 2012, 23:44
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
Default

Quote:
Originally Posted by m4l41k4t View Post
warning:
Your virus protection is OUTDATED! [More...]
One or more components needs an update [More...]

but when I get to step apt-get upgrade I found a massive this, is this a problem or not?

or should I uninstall / install again to "Postfix, amavisd-new, SpamAssassin, And Clamav" and whether in this way there is a negative-effect with the email that has been previously dicreate?


clamav (0.97.5+dfsg-1) unstable; urgency=medium

This release of clamav no longer ships signature files in clamav-base so
no signatures are available until after freshclam has run and downloaded
them. This is an upstream change.

-- Scott Kitterman <scott@kitterman.com> Fri, 15 Jun 2012 11:39:26 -0400

/tmp/tmpBagrWi (END)
http://www.howtoforge.com/forums/sho...ction+OUTDATED
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
m4l41k4t (10th July 2012)
  #18  
Old 9th July 2012, 05:28
m4l41k4t m4l41k4t is offline
Member
 
Join Date: May 2012
Posts: 32
Thanks: 11
Thanked 0 Times in 0 Posts
Default

Quote:
Originally Posted by falko View Post

If it can be said to be normal, but why I still can not send / receive emails where previously there was no problem.

previously I have done this at my ubuntu machine "apt-get-u upgrade" but stop and appear like this: * d / cron.default: change to a deprecated message to make it clear
/ tmp / tmpccxWzC

This is because I still can not send / receive email?

Thanks.
Reply With Quote
  #19  
Old 10th July 2012, 10:50
m4l41k4t m4l41k4t is offline
Member
 
Join Date: May 2012
Posts: 32
Thanks: 11
Thanked 0 Times in 0 Posts
Default

The problem can not send / receive e-mail has been Successful and thank you for all the solution.

And one more thing I want to ask: why in this tutorial there is talk about saslauthd (http://www.howtoforge.com/perfect-se...ispconfig-3-p4) but in this tutorial does not exist (http: / / http://www.howtoforge.com/perfect-se...ispconfig-3-p4). Is SMTP auth only be done in ubuntu, 11:10 ISPConfig-3-and-ubuntu-12:04 ISPConfig-3 can not be done?
Because now I'm watching from mail.log so many activities Spam.
Reply With Quote
  #20  
Old 11th July 2012, 17:48
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,747 Times in 2,578 Posts
 
Default

Quote:
Originally Posted by m4l41k4t View Post
And one more thing I want to ask: why in this tutorial there is talk about saslauthd (http://www.howtoforge.com/perfect-se...ispconfig-3-p4) but in this tutorial does not exist (http: / / http://www.howtoforge.com/perfect-se...ispconfig-3-p4). Is SMTP auth only be done in ubuntu, 11:10 ISPConfig-3-and-ubuntu-12:04 ISPConfig-3 can not be done?
Because now I'm watching from mail.log so many activities Spam.
One tutorial uses Courier and saslauthd, the other one uses Dovecot (which is able to handle SMTP-AUTH, so saslauthd is not needed).
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 23:41
Sending mail ISPConfig 3 but not receivind catza Installation/Configuration 20 19th May 2010 13:47
postfix, pop3 uvbnserved Server Operation 22 24th May 2009 22:00
Undelivered Mail Returned to Sender Error202 General 5 7th May 2009 12:14
localhost postfix/master: fatal: bind 127.0.0.1 port 125: Permission denied g18c Installation/Configuration 4 24th March 2009 18:39


All times are GMT +2. The time now is 14:25.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.