Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 2nd July 2012, 19:18
commentator commentator is offline
Senior Member
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 146
Thanks: 49
Thanked 7 Times in 5 Posts
Default debian wheezy delay start postfix/fetchmail?

Hi,

I'm testing Debian Wheezy with postfix mailserver and clamscan as in one of the perfect setup howto's. Also running fetchmail to pop some mailboxes.

Works perfect for previous Debian release. Saturday upgraded to Wheezy. Now there is problem when booting. Postfix/Clamscan results in abnormal high cpu load.

When disable it from starting and starting it manual after some time no problem. How can I delay this start automaticaly so I don't have to log in and start postfix manual ?
Reply With Quote
Sponsored Links
  #2  
Old 3rd July 2012, 16:35
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You could try something like this in /etc/rc.local:

Code:
sleep 600 && /etc/init.d/postfix start
This will delay the Postfix start for ten minutes. Please note that this will also delay all other commands that come after this line in /etc/rc.local, so it is a good idea to use this as the last command (before the exit line) in /etc/rc.local.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
The Following User Says Thank You to falko For This Useful Post:
commentator (3rd July 2012)
  #3  
Old 3rd July 2012, 18:11
commentator commentator is offline
Senior Member
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 146
Thanks: 49
Thanked 7 Times in 5 Posts
Default

Ok, thanks for your response.
Going to try that later this evening.
Reply With Quote
  #4  
Old 5th July 2012, 20:04
commentator commentator is offline
Senior Member
 
Join Date: Jul 2008
Location: The Netherlands
Posts: 146
Thanks: 49
Thanked 7 Times in 5 Posts
 
Default

update:

works perfect Thank you
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Installation just stops, and dies. cosmicsafari Installation/Configuration 3 19th July 2011 10:24
monitrc configuration for Debian ISPConfig 3 server Hans Tips/Tricks/Mods 2 27th March 2011 23:22
[debian 5 + ispconfig 3] Unable to send mail tanakskool HOWTO-Related Questions 6 4th November 2009 18:20
"Too many open files in system" problems Berry Installation/Configuration 3 10th November 2007 21:58
Bind Failed christoph2k HOWTO-Related Questions 4 28th April 2007 00:57


All times are GMT +2. The time now is 07:11.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.