Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 27th June 2012, 17:19
globiws globiws is offline
Junior Member
 
Join Date: Jun 2012
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default Ubuntu Jailkit multiple problems

I've just done a new clean install of ISPConfig on Ubuntu 12.04

When I SSH in as a user, I get multiple issues:

s2globi@globi.ca:~$ wget google.com
--2012-06-27 15:15:06-- http://google.com/
Resolving google.com (google.com)... failed: Name or service not known.
wget: unable to resolve host address `google.com'
s2globi@globi.ca:~$ scp google.com .
unknown user 5004
s2globi@globi.ca:~$ whoami
whoami: cannot find name for user ID 5004

WGET cannot resolve DNS.
SCP gives a strange error.
WHOAMI doesn't know much at all.

this is an extract from my /etc/passwd:
web1:x:5004:5005::/var/www/clients/client2/web1/./home/web1:/bin/false
s2globi:x:5004:5005::/var/www/clients/client2/web1/./home/s2globi:/usr/sbin/jk_chrootsh

I've read ALL the forums and can't find an answer.

Please help.
Thanks,
-Andreas
Reply With Quote
Sponsored Links
  #2  
Old 27th June 2012, 17:22
globiws globiws is offline
Junior Member
 
Join Date: Jun 2012
Posts: 16
Thanks: 0
Thanked 1 Time in 1 Post
Default

Another strange issue is when I'm logged in as a web user and do an LS -AL, the ownership of files is NOT WEBn:CLIENTn, but the UID:

drwxr-xr-x 6 5004 5005 4096 Jun 6 18:41 inc
-rw-r--r-- 1 5004 5005 1934 Mar 11 2011 index.BCK.php
-rw-r--r-- 1 5004 5005 4953 Jun 6 18:43 index.php
Reply With Quote
  #3  
Old 30th June 2012, 09:45
Steveorevo Steveorevo is offline
Member
 
Join Date: Feb 2010
Posts: 33
Thanks: 6
Thanked 6 Times in 5 Posts
 
Default

I was able to restore scp/wget functionality, please see:

http://www.howtoforge.com/forums/sho...67&postcount=3
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Connection timed out on intermail outgoing mails gouravgarg Server Operation 6 5th March 2010 20:31
Unbale to login to Postfix from webmail wasimriz HOWTO-Related Questions 5 6th April 2009 13:49
Ubuntu 8.10 ProFTPD and ISPConfig 3.0.0.8 Problems! rich107951 Installation/Configuration 1 6th February 2009 16:07
user mail problems with The Perfect Server - Ubuntu Gutsy Gibbon (Ubuntu 7.10) rmccain HOWTO-Related Questions 3 15th January 2008 04:33
Problem on restart bind9 satimis Server Operation 6 30th October 2007 02:01


All times are GMT +2. The time now is 04:26.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.