Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #11  
Old 28th June 2012, 09:38
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for your reply, where do I change the resolv.conf as when I change it directly it rests back to the above value?
Reply With Quote
Sponsored Links
  #12  
Old 28th June 2012, 09:54
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

as far as i know in /etc/network/interfaces you specify the order of the nameservers with
dns-nameservers 127.0.0.1 192.168.0.3 ... , and after a network restart is should update the /etc/resolv.conf with the values in order specified in /etc/network/interfaces .
if this doesn't work for you check /etc/network/run/eth0 or something like that
you can read more about this here http://www.stgraber.org/2012/02/24/dns-in-ubuntu-12-04/

Last edited by TiTex; 28th June 2012 at 10:07.
Reply With Quote
  #13  
Old 28th June 2012, 19:36
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for your posts, I am still getting the following error:

Quote:
root@eden:/# nslookup eden.local
Server: 127.0.0.1
Address: 127.0.0.1#53

** server can't find eden.local: SERVFAIL
Reply With Quote
  #14  
Old 28th June 2012, 19:52
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

how about
Code:
nslookup www.eden.local
does it give you the same error?
Reply With Quote
  #15  
Old 28th June 2012, 19:54
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Yes same error
Reply With Quote
  #16  
Old 28th June 2012, 20:04
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

can you post the contents of the files named.conf and pri.eden.local ?
i'm trying to reproduce the error on a test server (ubuntu 12.04+ispconfig3) but it just doesn't happen

Last edited by TiTex; 28th June 2012 at 20:54.
Reply With Quote
  #17  
Old 28th June 2012, 21:18
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks your help its appriciated.

this is my /etc/bind/named.conf

Quote:
// This is the primary configuration file for the BIND DNS server named.
//
// Please read /usr/share/doc/bind9/README.Debian.gz for information on the
// structure of BIND configuration files in Debian, *BEFORE* you customize
// this configuration file.
//
// If you are just adding zones, please do that in /etc/bind/named.conf.local

include "/etc/bind/named.conf.options";
include "/etc/bind/named.conf.local";
include "/etc/bind/named.conf.default-zones";
this is the /etc/bind/named.conf.local
Quote:
zone "eden.local" {
type master;
allow-transfer {none;};
file "/etc/bind/pri.eden.local";
};
This is the /etc/bind/pri.eden.local
Quote:
$TTL 3600
@ IN SOA ns.eden.local. info.eden.local. (
2012062806 ; serial, todays date + todays serial #
7200 ; refresh, seconds
540 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

eden.local. 3600 A 192.168.0.3
eden.local. 3600 MX 10 mail.eden.local.
eden.local. 3600 NS ns1.eden.local.
mail 3600 A 192.168.0.3
www 3600 A 192.168.0.3
Reply With Quote
  #18  
Old 29th June 2012, 17:20
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 17 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

you don't have an A record for ns1 , you can solve this by adding a record like this
Code:
ns1 3600 A 192.168.0.3
or replace
Code:
eden.local. 3600 NS ns1.eden.local.
with
Code:
eden.local. 3600 NS eden.local.
or something else your server will respond to ... like localhost
Reply With Quote
  #19  
Old 29th June 2012, 19:02
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks that worked a treat. But I cant seem to be able add sub domains to different sites. For example:

testing.eden.local
Reply With Quote
  #20  
Old 29th June 2012, 19:12
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
 
Default

Also my /etc/bind/pri.eden.local is getting overwritten on reboot?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
I Fail at installing ispconfig where did I go wrong? stocker741 Installation/Configuration 14 30th October 2008 14:12


All times are GMT +2. The time now is 23:22.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.