Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > Linux Forums > HOWTO-Related Questions

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 24th June 2012, 18:54
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default ISPConfig Local DNS server settings (Ubuntu 12.04 LTS)

Hi there,

I have just completed the install of ISP config on my local server and everything is running very smooth. I would like to create websites locally without having to edit my pc host file every time I set up a local site on my server. I also want all of the pc's on my network to go via this server.

How is this possible I am very new to DNS so some light reading would be great thanks in advance for you response.
Reply With Quote
Sponsored Links
  #2  
Old 25th June 2012, 16:10
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

*Bump*

Sorry wondered if this is possible?
Reply With Quote
  #3  
Old 26th June 2012, 13:00
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,701
Thanks: 1,900
Thanked 2,743 Times in 2,577 Posts
Default

You must create a local DNS server and then use it in your router settings so that the router tells the client PCs (via DHCP) to use that nameserver.

You can use the DNS module in ISPConfig to create DNS zones.
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote
  #4  
Old 26th June 2012, 14:13
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

thanks for your reply.

How would I check that the setting I have put into ISP config are running correctly?
Reply With Quote
  #5  
Old 26th June 2012, 22:18
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

OK so I set up a Zone and when I do a nslookup of the domain on the the server I get the following error:

eden@eden:/etc/bind$ nslookup eden.local
;; Got SERVFAIL reply from 127.0.0.1, trying next server
;; Got SERVFAIL reply from 127.0.0.1, trying next server
Server: ::1
Address: ::1#53

** server can't find eden.local: SERVFAIL

When I do an NSLookup of the IP I get the following:

eden@eden:/etc/bind$ nslookup 192.168.0.3
Server: 127.0.0.1
Address: 127.0.0.1#53

** server can't find 3.0.168.192.in-addr.arpa.: NXDOMAIN

################################################## #

Not sure where I am going wrong here? Screenshots of my zone page attached.
Attached Images
  
Reply With Quote
  #6  
Old 27th June 2012, 11:07
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 18 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

you should have a file pri.eden.local in your /etc/bind/ folder , check if it's there
Reply With Quote
  #7  
Old 27th June 2012, 18:48
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

Thanks for your reply.

Yes it is there it contains the following:

#######################################

$TTL 3600
@ IN SOA ns1.eden.local. info@eden.local. (
2012062702 ; serial, todays date + todays serial #
7200 ; refresh, seconds
540 ; retry, seconds
604800 ; expire, seconds
86400 ) ; minimum, seconds
;

eden.local. 3600 A 192.168.0.3
eden.local. 3600 MX 10 mail.eden.local.
eden.local. 3600 NS ns1.eden.local.
eden.local. 3600 NS ns2.eden.local.
mail 3600 A 192.168.0.3
www 3600 A 192.168.0.3
Reply With Quote
  #8  
Old 27th June 2012, 20:54
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 18 Times in 17 Posts
Send a message via Skype™ to TiTex
Default

can you post the contents of /etc/resolv.conf ?
also is your bind/named service started ?
Reply With Quote
  #9  
Old 27th June 2012, 20:59
neoszion neoszion is offline
Junior Member
 
Join Date: Jun 2012
Posts: 14
Thanks: 1
Thanked 0 Times in 0 Posts
Default

the etc/resolv.conf
Quote:
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.0.3
Yes the bind name service is running, but to be sure I just done a "sudo service bind9 start"...
Reply With Quote
  #10  
Old 28th June 2012, 07:59
TiTex TiTex is offline
Senior Member
 
Join Date: Aug 2011
Location: Cluj-Napoca,Romania
Posts: 125
Thanks: 0
Thanked 18 Times in 17 Posts
Send a message via Skype™ to TiTex
 
Default

the first entry in your resolv.conf should be
Code:
nameserver 127.0.0.1
check your /etc/network/interfaces and make sure there is an entry like
Code:
dns-nameservers 127.0.0.1
do a network restart
Code:
/etc/init.d/networking restart
it should work now
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
SquirrelMail login not working glenneh Installation/Configuration 13 9th April 2011 20:01
Not working emails (DNS and postfix problem?) shekiman Installation/Configuration 9 1st March 2011 16:25
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Email problem 'Cannot set my user or group id.' (using ISPConfig 3 + OpenSuSE 11.2) urosm Installation/Configuration 5 19th June 2010 22:41
I Fail at installing ispconfig where did I go wrong? stocker741 Installation/Configuration 14 30th October 2008 14:12


All times are GMT +2. The time now is 09:04.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.