#1  
Old 22nd June 2012, 11:42
frokkels frokkels is offline
Junior Member
 
Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Problems with other mail server

I have a ispconfig 3 mail server setup according to the Perfect server tutorial on this website using Debian Squeeze. The problem is as follows. There are certain companies in my country that does not configure their email servers correctly. Their hostnames are not set up properly or their ptr records are not correct. Is there a way to whitelist those servers.

I have searched the internet for 2 days on this problem and tried setting the server up's as senders under Postfix Whitelist in the cotrol panel but nothing works.

Please help
Reply With Quote
Sponsored Links
  #2  
Old 22nd June 2012, 11:59
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
Default

Servers with wrong PTR records are not blacklisted in a normal perfect setup, so you must have enabled features to blacklist them manually in postfix main.cf. Please post the exact error messages from your mail.log and the content of the postfix main.cf file.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 22nd June 2012, 12:11
frokkels frokkels is offline
Junior Member
 
Join Date: Jun 2012
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Now I feel a bit stupid. It would seem that it was blocking it but reading the log further down the email is delivered.

Jun 19 15:03:19 mail postfix/smtpd[4938]: warning: 41.208.60.66: hostname 41-208-60-66.mtnns.net verification failed: Name or service not known
Jun 19 15:03:19 mail postfix/smtpd[4938]: connect from unknown[41.208.60.66]
Jun 19 15:03:19 mail policyd-spf[4943]: None; identity=helo; client-ip=41.208.60.66; helo=mail.integr8fax.com; envelope-from=platform@integr8fax.com; receiver=user@local.co.za
Jun 19 15:03:19 mail policyd-spf[4943]: None; identity=mailfrom; client-ip=41.208.60.66; helo=mail.integr8fax.com; envelope-from=platform@integr8fax.com; receiver=user@local.co.za
Jun 19 15:03:19 mail postgrey[6165]: action=pass, reason=triplet found, client_name=unknown, client_address=41.208.60.66, sender=platform@integr8fax.com, recipient=uuser@local.co.za
Jun 19 15:03:19 mail postfix/smtpd[4938]: C22D75A3DB: client=unknown[41.208.60.66]
Jun 19 15:03:19 mail postfix/cleanup[4946]: C22D75A3DB: message-id=<927329c3819cf3d678e4da9a71e1d217@gaxplatform.c o.za>
Jun 19 15:03:20 mail postfix/qmgr[23641]: C22D75A3DB: from=<platform@integr8fax.com>, size=146370, nrcpt=1 (queue active)
Jun 19 15:03:20 mail postfix/smtpd[4938]: disconnect from unknown[41.208.60.66]

(user information removed for privacy reasons)

Am I right that the delivery happened anyway?
Reply With Quote
  #4  
Old 22nd June 2012, 12:46
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,586
Thanks: 792
Thanked 4,983 Times in 3,903 Posts
 
Default

The email was delivered.

You use postgrey which is a software that blocks incoming email for a specified time to minimize spam, if the other mail server tries to deliver the email again after a few minutes, the email gets delivered.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Getting Email Working ISPConfig3 Squirrelmail and Courier etc Ian Wilson Installation/Configuration 17 19th June 2013 22:58
Can't receive mails baicunko Server Operation 12 3rd August 2011 22:02
postfix problem jagsler Server Operation 41 7th July 2011 14:19
CentoS doesn't send the emails vaio1 Installation/Configuration 18 5th November 2008 17:51
Core 4: Error Messages on Fresh Install re CTX/SSL jjw Installation/Configuration 30 6th September 2006 12:16


All times are GMT +2. The time now is 02:45.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.