#1  
Old 21st June 2012, 11:06
beenfishing beenfishing is offline
Member
 
Join Date: Jan 2010
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Default Database server

Hi

I have a multiserver setup on Debian 6, my websites all of a sudden cant connect to the db server.

I tried to restart mysql on the db server and I get the following error.

ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Please help

Thanks
Reply With Quote
Sponsored Links
  #2  
Old 21st June 2012, 11:17
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,788
Thanks: 821
Thanked 5,337 Times in 4,187 Posts
Default

Have ou changed any settings in the my.cnf file or installed a Linux update which might have changed settings in that file? Do you get any error messages in the syslog?
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
  #3  
Old 21st June 2012, 11:33
beenfishing beenfishing is offline
Member
 
Join Date: Jan 2010
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
 
Default Database Server

Thanks for you super speedy response.

I managed to find out how to fix it on the internet.

I hadn't done an update or anything like that.

To fix it i changed the socket path from /var/run/mysqld/mysqld.sock

to

/tmp/mysql.sock

and now it's working.

Is this ok to do?
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Horde Groupware Webmail Edition ByteMe Networking Tips/Tricks/Mods 17 20th December 2012 10:12
Sending email issue lezelf Installation/Configuration 15 9th August 2011 11:20
Statistic not working mzo Installation/Configuration 49 20th April 2011 12:19
ISPConfig3 mail doesn't work Marr General 6 1st September 2010 09:32
Problem with mail server and subdomains MyKE General 7 26th February 2010 10:18


All times are GMT +2. The time now is 16:09.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.