Go Back   HowtoForge Forums | HowtoForge - Linux Howtos and Tutorials > ISPConfig 3 > Installation/Configuration

Do you like HowtoForge? Please consider supporting us by becoming a subscriber.
Reply
 
Thread Tools Display Modes
  #1  
Old 8th June 2012, 04:44
tek tek is offline
Junior Member
 
Join Date: Feb 2012
Location: Silicon Valley
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to tek Send a message via AIM to tek Send a message via Yahoo to tek Send a message via Skype™ to tek
Default Unison eating up system resources

I followed the how-TO for "Installing A Web, Email & MySQL Database Cluster On Debian 6.0 With ISPConfig 3" and have had it running for a while now one two blade servers. Everything was good for a while but now unison just goes crazy and no clue really why or what I can do about it.

This is my last run on top with one of the blades just having been rebooted but in a few hours it will run out of memory, and start using swap and after that at some point services will start failing till I kill off unison and then it repeats.
root@blade007:/etc# top
top - 19:39:27 up 1:27, 2 users, load average: 8.69, 8.77, 7.84
Tasks: 199 total, 11 running, 188 sleeping, 0 stopped, 0 zombie
Cpu(s): 98.2%us, 0.9%sy, 0.0%ni, 0.0%id, 0.0%wa, 0.0%hi, 0.9%si, 0.0%st
Mem: 32955516k total, 12861232k used, 20094284k free, 610956k buffers
Swap: 2585588k total, 0k used, 2585588k free, 4194928k cached

PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
12123 root 20 0 679m 661m 1772 R 48 2.1 6:03.79 /usr/bin/unison
12028 root 20 0 654m 636m 1772 R 46 2.0 8:23.31 /usr/bin/unison
10339 root 20 0 675m 656m 1772 R 45 2.0 16:20.93 /usr/bin/unison
10467 root 20 0 733m 709m 1772 R 45 2.2 13:18.29 /usr/bin/unison
12222 root 20 0 650m 632m 1772 R 43 2.0 3:56.67 /usr/bin/unison
10112 root 20 0 677m 659m 1772 R 42 2.0 22:25.94 /usr/bin/unison
10206 root 20 0 690m 671m 1736 R 40 2.1 19:14.75 /usr/bin/unison
12314 root 20 0 676m 657m 1736 R 39 2.0 1:53.87 /usr/bin/unison
10558 root 20 0 683m 664m 1772 R 37 2.1 10:51.03 /usr/bin/unison
10344 root 20 0 42152 6512 2216 S 2 0.0 0:32.48 ssh 192.168.1.131 -e none unison -server
10115 root 20 0 42568 6940 2216 S 1 0.0 0:44.85 ssh 192.168.1.131 -e none unison -server
10469 root 20 0 42856 7236 2216 S 1 0.0 0:25.40 ssh 192.168.1.131 -e none unison -server
10562 root 20 0 42536 6908 2216 R 1 0.0 0:21.30 ssh 192.168.1.131 -e none unison -server
12033 root 20 0 42088 6456 2216 S 1 0.0 0:16.18 ssh 192.168.1.131 -e none unison -server
12126 root 20 0 41992 6372 2216 S 1 0.0 0:11.51 ssh 192.168.1.131 -e none unison -server
12225 root 20 0 42792 6972 2216 S 1 0.0 0:06.97 ssh 192.168.1.131 -e none unison -server
12318 root 20 0 42440 6808 2216 S 1 0.0 0:02.84 ssh 192.168.1.131 -e none unison -server
10210 root 20 0 42344 6720 2216 S 1 0.0 0:39.14 ssh 192.168.1.131 -e none unison -server
16 root 20 0 0 0 0 S 0 0.0 0:00.12 [events/1]

please note, while load now is 8, its worked its way as high as 70 before killing things off and this has been rebooted just over 1.5 hours ago.

about midnight or so either apache or mysql or postfix or all of them will die off till I run killall unison and then it starts it over again. The system is a dual xeon quad cores with 32 gigs of ram.. yet thats not enough.. crazy ...
Reply With Quote
Sponsored Links
  #2  
Old 8th June 2012, 09:30
till till is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 35,340
Thanks: 810
Thanked 5,172 Times in 4,055 Posts
 
Default

What might be is that the unison sync timespan is set too short, so that more then one unison instance is run by cron at a time. Change the cronjob on set it to a higher timespan. If this wont help, you might want to contact the unison developers and ask them what might cause this and check if there is a newer version of unison available which might fix the issue on your server.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Auto Start ISPConfig royrobinson Installation/Configuration 15 30th May 2012 10:48
mail queue - mail not sending not receiving Amorphous Installation/Configuration 2 24th January 2012 23:55
Can all the installation and configuration be automated (Kickstart) gabby Installation/Configuration 0 30th January 2010 19:47
The system is currently updating the configuration files. warlock General 8 21st February 2009 18:15
How to install OpenOficeOrg 3.0.0 in Ubuntu 8.04 ernesthagger HOWTO-Related Questions 43 23rd December 2008 14:42


All times are GMT +2. The time now is 21:43.


Powered by vBulletin® Version 3.8.7
Copyright ©2000 - 2014, vBulletin Solutions, Inc.